CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Trouble shooting about OpenFOAM installation in Ubuntu 12.04

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 10, 2012, 22:23
Default Trouble shooting about OpenFOAM installation in Ubuntu 12.04
  #1
New Member
 
Huma Nait
Join Date: Dec 2012
Posts: 2
Rep Power: 0
Nait is on a distinguished road
Hi,

I have tried to install OpenFOAM 2.1.x on Ubuntu 12.04 following the instruction on http://www.openfoam.org/download/git.php
However, when run the foamInstallationTest script, the following message shows:

***************************

Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: xutianhua-PC
OS: Linux version 3.2.0-34-generic-pae
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/xutianhua/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/xutianhua/OpenFOAM/xutianhua-2.1.x no no
$WM_THIRD_PARTY_DIR .../xutianhua/OpenFOAM/ThirdParty-2.1.x yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/xutianhua/OpenFOAM/OpenFOAM-2.1.x yes yes yes

$FOAM_APPBIN ...AM-2.1.x/platforms/linuxGccDPOpt/bin yes yes yes
$FOAM_SITE_APPBIN ...te/2.1.x/platforms/linuxGccDPOpt/bin no no
$FOAM_USER_APPBIN ...ua-2.1.x/platforms/linuxGccDPOpt/bin no no
$WM_DIR ...ianhua/OpenFOAM/OpenFOAM-2.1.x/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...AM-2.1.x/platforms/linuxGccDPOpt/lib yes yes yes
$FOAM_SITE_LIBBIN ...te/2.1.x/platforms/linuxGccDPOpt/lib no no
$FOAM_USER_LIBBIN ...ua-2.1.x/platforms/linuxGccDPOpt/lib no no
$MPI_ARCH_PATH ...1.x/platforms/linuxGcc/openmpi-1.5.3 yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
flex 2.5.35 /usr/bin/flex
./foamInstallationTest: 267: [: -lt: unexpected operator
./foamInstallationTest: 269: [: -gt: unexpected operator
./foamInstallationTest: 274: [: -lt: unexpected operator
./foamInstallationTest: 276: [: -gt: unexpected operator
./foamInstallationTest: 281: [: !=: unexpected operator
gcc /usr/bin/gcc
gzip 1.4 /bin/gzip
tar 1.26 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/xutianhua/OpenFOAM/OpenFOAM-2.1.x/platforms/linuxGccDPOpt/bin/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.
The foam installation contains 1 critical error(s).

Review the output for warning messages and consult
the installation guide for troubleshooting.

Done

*************************************

Then I run the ./Allwmake in the /src folder, the message in the attachment shows.

Then how can I solve the problem?

Thanks
Attached Files
File Type: gz make.log.tar.gz (2.4 KB, 3 views)
Nait is offline   Reply With Quote

Old   December 12, 2012, 10:12
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Huma Nait and welcome to the forum!

If I'm guessing this correctly, you have the Gold ld version installed by default, while OpenFOAM needs the BFD version of ld.

This has been already reported here: http://www.openfoam.org/mantisbt/view.php?id=685

The quickest solution is to uninstall the package "binutils-gold", rebuild OpenFOAM 2.1.x and after that install "binutils-gold" again.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   December 12, 2012, 11:20
Default
  #3
New Member
 
Huma Nait
Join Date: Dec 2012
Posts: 2
Rep Power: 0
Nait is on a distinguished road
Thanks to Bruno.

I have my unbuntu 12.04 reinstalled and the problems solved

Actually I suspect it is the influence of the ATI graphic card driver because I installed the driver before the installation of OF in my first try.
Nait is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFoam 2.0.0 installation Jan_Peters OpenFOAM Installation 86 April 27, 2012 05:32
OpenFOAM 1.6-ext git installation on Ubuntu 11.10 x64 Attesz OpenFOAM Installation 45 January 13, 2012 13:38
OpenFOAM Installation Errors on Ubuntu 10.04 ozzythewise OpenFOAM Installation 1 June 19, 2010 05:59
Installation of OpenFOAM-1.6 on Ubuntu 9.10 marval OpenFOAM Installation 2 March 17, 2010 09:33
Trouble with installing OpenFOAM on Ubuntu Milos OpenFOAM Installation 16 November 16, 2009 03:44


All times are GMT -4. The time now is 06:09.