CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Unsuccessful Installaton Of OpenFOAM-1.6 and Paraview in Ubuntu 10.04 (http://www.cfd-online.com/Forums/openfoam-installation/111076-unsuccessful-installaton-openfoam-1-6-paraview-ubuntu-10-04-a.html)

zandi December 26, 2012 13:22

Unsuccessful Installaton Of OpenFOAM-1.6 and Paraview in Ubuntu 10.04
 
Hi friends
I'm new in OpenFOAM
i want to install OpenFOAM 1.6 on LINUX 10.04
but when i want test the installations' files with this command:
"$HOME/OpenFOAM/OpenFOAM-1.6/bin/foamInstallationTest"
it shows these warnings and errors in the terminal:
--------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.3
User version : 4.4.3
Minimum required: 4.3.1

gcc 4.4.3
WARNING: Conflicting installations:
OpenFOAM settings : /home/linux/OpenFOAM/ThirdParty-1.6/gcc-4.3.3/platforms/linux64/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /bin/gzip
tar 1.22 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/linux/OpenFOAM/OpenFOAM-1.6/applications/bin/linux64GccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.
--------------------------------------------------------------------------
any helps would be appreciated.
please help me it is urgent.
thank you

nimasam December 26, 2012 14:34

do you mean OpenFOAM.1.6-ext, because OpenFOAM.1.6 is some how an old version, i recommend you to install latest version from here (http://www.openfoam.org/download/)

zandi December 26, 2012 15:08

Thank you very much Mr Sam. you ment this old openfoal can't be installed on this version of linux at all?

nimasam December 26, 2012 16:57

if you insist to install this version no matter why, then i feel you may want to try binary installation

zandi December 26, 2012 18:30

thank you i have installed 2.0.1 at last

wyldckat December 26, 2012 18:57

Greetings to all!

@Zandi: Gcc 4.4.3 will only work if you can use OpenFOAM 1.6.x (not 1.6-ext): http://www.openfoam.org/archive/1.6/download/git.php
For installing OpenFOAM 1.6.x you can also try the Nucleation installation scripts: http://code.google.com/p/nucleation/

OpenFOAM 1.6 has to be built with Gcc 4.3.3 or greater, but only in the Gcc 4.3 series.
In Ubuntu 10.04 you can install this series with this command:
Code:

sudo apt-get install gcc-4.3 g++-4.3 cpp-4.3
Then....
... I've seen now that you have already installed OpenFOAM 2.0.1... oh well :rolleyes:.

Best regards,
Bruno

zandi December 28, 2012 05:41

Thank you very much Bruno for useful reply. I would try it if is necessary in future:p
thank you all


All times are GMT -4. The time now is 22:08.