CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Unsuccessful Installaton Of OpenFOAM-1.6 and Paraview in Ubuntu 10.04

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 26, 2012, 13:22
Unhappy Unsuccessful Installaton Of OpenFOAM-1.6 and Paraview in Ubuntu 10.04
  #1
Senior Member
 
zandi's Avatar
 
Fatema Zandi Goharrizi
Join Date: Mar 2009
Posts: 132
Rep Power: 8
zandi is on a distinguished road
Hi friends
I'm new in OpenFOAM
i want to install OpenFOAM 1.6 on LINUX 10.04
but when i want test the installations' files with this command:
"$HOME/OpenFOAM/OpenFOAM-1.6/bin/foamInstallationTest"
it shows these warnings and errors in the terminal:
--------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.3
User version : 4.4.3
Minimum required: 4.3.1

gcc 4.4.3
WARNING: Conflicting installations:
OpenFOAM settings : /home/linux/OpenFOAM/ThirdParty-1.6/gcc-4.3.3/platforms/linux64/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /bin/gzip
tar 1.22 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/linux/OpenFOAM/OpenFOAM-1.6/applications/bin/linux64GccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.
--------------------------------------------------------------------------
any helps would be appreciated.
please help me it is urgent.
thank you
zandi is offline   Reply With Quote

Old   December 26, 2012, 14:34
Default
  #2
Senior Member
 
Nima Sam
Join Date: Sep 2009
Location: Tehran, Iran
Posts: 1,123
Blog Entries: 1
Rep Power: 14
nimasam is on a distinguished road
Send a message via Yahoo to nimasam
do you mean OpenFOAM.1.6-ext, because OpenFOAM.1.6 is some how an old version, i recommend you to install latest version from here (http://www.openfoam.org/download/)
__________________
Training Course on OpenFOAM at (http://www.isme.ir/)
My Weblog (http://openfoam.blogfa.com/)
nimasam is offline   Reply With Quote

Old   December 26, 2012, 15:08
Question
  #3
Senior Member
 
zandi's Avatar
 
Fatema Zandi Goharrizi
Join Date: Mar 2009
Posts: 132
Rep Power: 8
zandi is on a distinguished road
Thank you very much Mr Sam. you ment this old openfoal can't be installed on this version of linux at all?
zandi is offline   Reply With Quote

Old   December 26, 2012, 16:57
Default
  #4
Senior Member
 
Nima Sam
Join Date: Sep 2009
Location: Tehran, Iran
Posts: 1,123
Blog Entries: 1
Rep Power: 14
nimasam is on a distinguished road
Send a message via Yahoo to nimasam
if you insist to install this version no matter why, then i feel you may want to try binary installation
__________________
Training Course on OpenFOAM at (http://www.isme.ir/)
My Weblog (http://openfoam.blogfa.com/)
nimasam is offline   Reply With Quote

Old   December 26, 2012, 18:30
Talking
  #5
Senior Member
 
zandi's Avatar
 
Fatema Zandi Goharrizi
Join Date: Mar 2009
Posts: 132
Rep Power: 8
zandi is on a distinguished road
thank you i have installed 2.0.1 at last
zandi is offline   Reply With Quote

Old   December 26, 2012, 18:57
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings to all!

@Zandi: Gcc 4.4.3 will only work if you can use OpenFOAM 1.6.x (not 1.6-ext): http://www.openfoam.org/archive/1.6/download/git.php
For installing OpenFOAM 1.6.x you can also try the Nucleation installation scripts: http://code.google.com/p/nucleation/

OpenFOAM 1.6 has to be built with Gcc 4.3.3 or greater, but only in the Gcc 4.3 series.
In Ubuntu 10.04 you can install this series with this command:
Code:
sudo apt-get install gcc-4.3 g++-4.3 cpp-4.3
Then....
... I've seen now that you have already installed OpenFOAM 2.0.1... oh well .

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   December 28, 2012, 05:41
Default
  #7
Senior Member
 
zandi's Avatar
 
Fatema Zandi Goharrizi
Join Date: Mar 2009
Posts: 132
Rep Power: 8
zandi is on a distinguished road
Thank you very much Bruno for useful reply. I would try it if is necessary in future
thank you all
zandi is offline   Reply With Quote

Reply

Tags
linux 10.04, openfoam 1.6, openfoam error

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Install OpenFOAM on 64 Ubuntu 9.04 hansel OpenFOAM Installation 62 March 19, 2010 15:43
OpenFOAM 1.6 and ThirdParty Software Paraview dunlopjp OpenFOAM Installation 0 February 24, 2010 12:35
Thumbs up Successful Installaton Of OpenFOAM-1.6 and Paraview in Ubuntu 9.04 AlanR OpenFOAM Installation 8 December 18, 2009 12:14
Successful Installaton Of OpenFOAM-1.6 and Paraview in Ubuntu 9.04 AlanR OpenFOAM Installation 21 September 17, 2009 11:27
Adventure of fisrst openfoam installation on Ubuntu 710 jussi OpenFOAM Installation 0 April 24, 2008 14:25


All times are GMT -4. The time now is 08:17.