CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Error installing swak4Foam

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree17Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   March 18, 2014, 06:18
Default
  #101
Member
 
Sita Drost
Join Date: Mar 2009
Location: Arnhem, The Netherlands
Posts: 44
Rep Power: 7
sita is on a distinguished road
Dear Bernhard,

Sorry to bother you again. I had problems with compiling simpleFunctionObjects under OpenFOAM-1.6-ext, apparently due to an incomplete OF installation. Therefore, I decided to upgrade to foam-extend-3.0 with swak4foam_2.x. Installation of foam-extend-3.0 seems all right, but when I try to compile swak4foam, it terminates with errors like

------------------------------------------------------------------------------------
In file included from helpers/switchableNotImplemented.C:43:0:
helpers/switchableNotImplemented.H:47:19: fatal error: error.H: No such file or directory
In file included from helpers/printSwakVersion.C:43:0:
helpers/printSwakVersion.H:46:21: fatal error: Pstream.H: No such file or directory
In file included from helpers/DebugOStream.C:37:0:
helpers/DebugOStream.H:55:21: fatal error: Pstream.H: No such file or directorycompilation terminated.

compilation terminated.
compilation terminated.
make: *** [Make/linux64GccDPOpt/DebugOStream.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [Make/linux64GccDPOpt/switchableNotImplemented.o] Error 1
make: *** [Make/linux64GccDPOpt/printSwakVersion.o] Error 1
Parser library did not compile OK. No sense continuing as everything else depends on it

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard
----------------------------------------------------------------------------------------------

And yes, I read the README and searched the MessageBoard, but I couldn't find the same error (of course there are similar errors, but I'm afraid I'm not a sufficiently advanced OF user to figure out a solution from that...).

Thanks in advance for your help!

Best Sita
sita is offline   Reply With Quote

Old   March 19, 2014, 19:35
Default
  #102
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,754
Rep Power: 36
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by sita View Post
Dear Bernhard,

Sorry to bother you again. I had problems with compiling simpleFunctionObjects under OpenFOAM-1.6-ext, apparently due to an incomplete OF installation. Therefore, I decided to upgrade to foam-extend-3.0 with swak4foam_2.x. Installation of foam-extend-3.0 seems all right, but when I try to compile swak4foam, it terminates with errors like

------------------------------------------------------------------------------------
In file included from helpers/switchableNotImplemented.C:43:0:
helpers/switchableNotImplemented.H:47:19: fatal error: error.H: No such file or directory
In file included from helpers/printSwakVersion.C:43:0:
helpers/printSwakVersion.H:46:21: fatal error: Pstream.H: No such file or directory
In file included from helpers/DebugOStream.C:37:0:
helpers/DebugOStream.H:55:21: fatal error: Pstream.H: No such file or directorycompilation terminated.

compilation terminated.
compilation terminated.
make: *** [Make/linux64GccDPOpt/DebugOStream.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [Make/linux64GccDPOpt/switchableNotImplemented.o] Error 1
make: *** [Make/linux64GccDPOpt/printSwakVersion.o] Error 1
Parser library did not compile OK. No sense continuing as everything else depends on it

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard
----------------------------------------------------------------------------------------------

And yes, I read the README and searched the MessageBoard, but I couldn't find the same error (of course there are similar errors, but I'm afraid I'm not a sufficiently advanced OF user to figure out a solution from that...).

Thanks in advance for your help!

Best Sita
If error.H and Pstream.H are missing then there is something fundamental wrong. Check whether the link $FOAM_SRC/foam/lnInclude/error.H is there
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   March 22, 2014, 14:06
Default
  #103
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 6,997
Blog Entries: 32
Rep Power: 69
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings to all!

Quote:
Originally Posted by gschaider View Post
If error.H and Pstream.H are missing then there is something fundamental wrong. Check whether the link $FOAM_SRC/foam/lnInclude/error.H is there
I'm currently compiling a list of known errors and related solutions. This particular issue is now explained here: http://openfoamwiki.net/index.php/In...e_or_directory

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   March 24, 2014, 05:08
Default
  #104
Member
 
Sita Drost
Join Date: Mar 2009
Location: Arnhem, The Netherlands
Posts: 44
Rep Power: 7
sita is on a distinguished road
Hi Bernhard, Bruno,

Thanks for your help!
In the meantime I'm back at OpenFOAM-1.6-ext and simpleFunctionObjects, and I now see what's causing my problems there: files that are normally located in /usr/include (like <sys/cdefs.h>, etc.) are located in /usr/include/x86_64-linux-gnu on my system (Ubuntu 12.04 LTS, 64 bits).

So it seems to be not really OpenFOAM related, but maybe you can still help me: how do I tell my computer where to look for these files?

Kind regards,
Sita

Update: adding the correct path to Make/options seems to work, but gives the error below:

cc1plus: error: unrecognised debug output level "nu"
cc1plus: error: unrecognised debug output level "nu"cc1plus: error: unrecognised debug output level "nu"

make: *** [Make/linux64GccDPOpt/SolverInfo.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [Make/linux64GccDPOpt/simpleFunctionObject.o] Error 1
make: *** [Make/linux64GccDPOpt/simpleDataFunctionObject.o] Error 1
cc1plus: error: unrecognised debug output level "nu"
make: *** [Make/linux64GccDPOpt/timelineFunctionObject.o] Error 1

Last edited by sita; March 24, 2014 at 09:05. Reason: update
sita is offline   Reply With Quote

Old   March 25, 2014, 10:55
Default
  #105
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,754
Rep Power: 36
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by sita View Post
Hi Bernhard, Bruno,

Thanks for your help!
In the meantime I'm back at OpenFOAM-1.6-ext and simpleFunctionObjects, and I now see what's causing my problems there: files that are normally located in /usr/include (like <sys/cdefs.h>, etc.) are located in /usr/include/x86_64-linux-gnu on my system (Ubuntu 12.04 LTS, 64 bits).

So it seems to be not really OpenFOAM related, but maybe you can still help me: how do I tell my computer where to look for these files?

Kind regards,
Sita

Update: adding the correct path to Make/options seems to work, but gives the error below:

cc1plus: error: unrecognised debug output level "nu"
cc1plus: error: unrecognised debug output level "nu"cc1plus: error: unrecognised debug output level "nu"

make: *** [Make/linux64GccDPOpt/SolverInfo.o] Error 1
make: *** Waiting for unfinished jobs....
make: *** [Make/linux64GccDPOpt/simpleFunctionObject.o] Error 1
make: *** [Make/linux64GccDPOpt/simpleDataFunctionObject.o] Error 1
cc1plus: error: unrecognised debug output level "nu"
make: *** [Make/linux64GccDPOpt/timelineFunctionObject.o] Error 1
Look at the options your added (or the compiler command line that is printed). My guess is that there is somewhere a -Dnu there
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   March 28, 2014, 09:45
Default Error when installing swak4foam for foam extend 3.0
  #106
New Member
 
Miguel Nóbrega
Join Date: Jul 2012
Posts: 6
Rep Power: 4
mnobrega is on a distinguished road
this post was moved to a new Thread

Basic Error when installing swak4foam with foam extend 3.0

Last edited by mnobrega; March 30, 2014 at 09:03. Reason: moving to a new thread
mnobrega is offline   Reply With Quote

Old   March 31, 2014, 04:28
Default
  #107
Member
 
Sita Drost
Join Date: Mar 2009
Location: Arnhem, The Netherlands
Posts: 44
Rep Power: 7
sita is on a distinguished road
Great, everything seems to work now: foam-extend-3.0 and swak4foam-2.x both compiled without errors. I didn't try swak4foam yet, but foam-extend-3.0 runs without problems. Everyone, thanks for your help!

Sita
sita is offline   Reply With Quote

Old   May 16, 2014, 09:30
Default Swak4Foam 0.3.0 on foam-extend-3.0 and Opensuse 12.2
  #108
Senior Member
 
Markus Rehm
Join Date: Mar 2009
Location: Erlangen (Germany)
Posts: 169
Rep Power: 7
markusrehm is on a distinguished road
Hi,

I am struggeling with the installation of swak4Foam with foam-extend-3.0.

I used this source:
Code:
https://github.com/Unofficial-Extend-Project-Mirror/openfoam-extend-Breeder2.0-libraries-swak4Foam
and get the following error
Code:
/Allwmake 
Previously compiled for OpenFOAM 3.0
No file 'swakConfiguration'. Python etc won't work. See README for details
Checking swak4Foam-version and generating file
Swak version is 0.3.0
Bison is version 2.5
Flex is version 2.5.35 (Minor version: 35)
OpenFOAM-version: Major 3 Minor 0 Patch -1 (-1 == x)
No change to swak4FoamParsers/foamVersion4swak.H
WM_NCOMPPROCS 8 will cause race conditions with the grammars. Resetting to 3 for this library
SOURCE=repositories/SurfacesRepository.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3  -DNoRepository -ftemplate-depth-100 -IMake/linux64Gcc47DPOpt    -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/finiteVolume/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/sampling/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/fileFormats/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/triSurface/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/surfMesh/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/lagrangian/basic/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/meshTools/lnInclude -IlnInclude -I. -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64Gcc47DPOpt/SurfacesRepository.o
SOURCE=repositories/MeshesRepository.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3  -DNoRepository -ftemplate-depth-100 -IMake/linux64Gcc47DPOpt      -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/finiteVolume/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/sampling/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/fileFormats/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/triSurface/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/surfMesh/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/lagrangian/basic/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/meshTools/lnInclude -IlnInclude -I. -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64Gcc47DPOpt/MeshesRepository.o
SOURCE=repositories/GlobalVariablesRepository.C ;  g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3  -DNoRepository -ftemplate-depth-100 -IMake/linux64Gcc47DPOpt     -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/finiteVolume/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/sampling/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/fileFormats/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/triSurface/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/surfMesh/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/lagrangian/basic/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/meshTools/lnInclude -IlnInclude -I. -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude -I/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OSspecific/POSIX/lnInclude   -fPIC -c $SOURCE -o Make/linux64Gcc47DPOpt/GlobalVariablesRepository.o
repositories/SurfacesRepository.C:45:9: error: invalid use of template-name ‘Foam::surfaceWriter’ without an argument list
repositories/SurfacesRepository.C: In member function ‘Foam::sampledSurface& Foam::SurfacesRepository::getSurface(const Foam::dictionary&, const Foam::fvMesh&)’:
repositories/SurfacesRepository.C:169:21: error: ‘scalarSurfaceWriter’ was not declared in this scope
repositories/SurfacesRepository.C:169:40: error: template argument 1 is invalid
repositories/SurfacesRepository.C:169:51: error: invalid type in declaration before ‘(’ token
repositories/SurfacesRepository.C:170:17: error: ‘scalarSurfaceWriter’ is not a class or namespace
repositories/SurfacesRepository.C:182:26: error: base operand of ‘->’ is not a pointer
repositories/SurfacesRepository.C: In member function ‘virtual bool Foam::SurfacesRepository::writeData(Foam::Ostream&) const’:
repositories/SurfacesRepository.C:211:17: error: ‘scalarSurfaceWriter’ was not declared in this scope
repositories/SurfacesRepository.C:211:36: error: template argument 1 is invalid
repositories/SurfacesRepository.C:211:47: error: invalid type in declaration before ‘(’ token
repositories/SurfacesRepository.C:212:13: error: ‘scalarSurfaceWriter’ is not a class or namespace
repositories/SurfacesRepository.C:215:18: error: base operand of ‘->’ is not a pointer
repositories/MeshesRepository.C: In member function ‘Foam::fvMesh& Foam::MeshesRepository::addCoupledMesh(const Foam::word&, const Foam::word&, const Foam::word&)’:
repositories/MeshesRepository.C:189:55: error: ‘class Foam::HashPtrTable<Foam::fvMesh, Foam::word>’ has no member named ‘sortedToc’
repositories/MeshesRepository.C: In member function ‘Foam::scalar Foam::MeshesRepository::setTime(const Foam::word&, Foam::scalar, Foam::label)’:
repositories/MeshesRepository.C:299:59: error: no matching function for call to ‘Foam::HashTable<Foam::regIOobject*>::HashTable(Foam::HashTable<const Foam::regIOobject*, Foam::word, Foam::string::hash>)’
repositories/MeshesRepository.C:299:59: note: candidates are:
In file included from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.H:456:0,
                 from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashPtrTable.H:39,
                 from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/PtrMap.H:38,
                 from repositories/MeshesRepository.H:50,
                 from repositories/MeshesRepository.C:37:
/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.C:110:1: note: Foam::HashTable<T, Key, Hash>::HashTable(const Foam::Xfer<Foam::HashTable<T, Key, Hash> >&) [with T = Foam::regIOobject*; Key = Foam::word; Hash = Foam::string::hash]
/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.C:110:1: note:   no known conversion for argument 1 from ‘Foam::HashTable<const Foam::regIOobject*, Foam::word, Foam::string::hash>’ to ‘const Foam::Xfer<Foam::HashTable<Foam::regIOobject*> >&’
/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.C:84:1: note: Foam::HashTable<T, Key, Hash>::HashTable(const Foam::HashTable<T, Key, Hash>&) [with T = Foam::regIOobject*; Key = Foam::word; Hash = Foam::string::hash]
/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.C:84:1: note:   no known conversion for argument 1 from ‘Foam::HashTable<const Foam::regIOobject*, Foam::word, Foam::string::hash>’ to ‘const Foam::HashTable<Foam::regIOobject*>&’
In file included from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.C:646:0,
                 from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.H:456,
                 from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashPtrTable.H:39,
                 from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/PtrMap.H:38,
                 from repositories/MeshesRepository.H:50,
                 from repositories/MeshesRepository.C:37:
/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTableIO.C:33:1: note: Foam::HashTable<T, Key, Hash>::HashTable(Foam::Istream&, Foam::label) [with T = Foam::regIOobject*; Key = Foam::word; Hash = Foam::string::hash; Foam::label = int]
/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTableIO.C:33:1: note:   no known conversion for argument 1 from ‘Foam::HashTable<const Foam::regIOobject*, Foam::word, Foam::string::hash>’ to ‘Foam::Istream&’
In file included from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.H:456:0,
                 from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashPtrTable.H:39,
                 from /home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/PtrMap.H:38,
                 from repositories/MeshesRepository.H:50,
                 from repositories/MeshesRepository.C:37:
/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.C:62:1: note: Foam::HashTable<T, Key, Hash>::HashTable(Foam::label) [with T = Foam::regIOobject*; Key = Foam::word; Hash = Foam::string::hash; Foam::label = int]
/home/mrehm/OpenFOAM/OpenFOAM-extend-3.0/src/OpenFOAM/lnInclude/HashTable.C:62:1: note:   no known conversion for argument 1 from ‘Foam::HashTable<const Foam::regIOobject*, Foam::word, Foam::string::hash>’ to ‘Foam::label {aka int}’
make: *** [Make/linux64Gcc47DPOpt/SurfacesRepository.o] Fehler 1
make: *** Warte auf noch nicht beendete Prozesse...
make: *** [Make/linux64Gcc47DPOpt/MeshesRepository.o] Fehler 1
Parser library did not compile OK. No sense continuing as everything else depends on it

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard
Any help is appreciated.

Regards, Markus.
markusrehm is offline   Reply With Quote

Old   May 16, 2014, 15:24
Default
  #109
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 6,997
Blog Entries: 32
Rep Power: 69
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings Markus,

A few questions:
  1. What installation instructions did you follow for installing foam-extend 3.0? I ask this because the path you have is not the standard one.
  2. Are you certain that foam-extend 3.0 is properly installed and working?
  3. It's possible that your machine is very powerful and has triggered a race condition. To try and fix it, run the following command within the swak4Foam folder:
    Code:
    wclean all
    unset WM_NCOMPPROCS
    ./Allwmake > log.make 2>&1
    ./Allwmake > log.make 2>&1
    Essential the above commands will clean up the swak4Foam build, disable the multi-core building (takes a while longer to build, but at least it should work) and run Allwmake twice, so that at the end of the second run, you have a summary of the installation. Does this solve the problem?
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   May 19, 2014, 03:46
Default
  #110
Senior Member
 
Markus Rehm
Join Date: Mar 2009
Location: Erlangen (Germany)
Posts: 169
Rep Power: 7
markusrehm is on a distinguished road
Hi Bruno,

thank you very much for your hints. Unfortunately the error persists.
But you are right, I had some trouble installing the extend-3.0-Version and changed some folders. However, it does run fine up to now, except SWAK.

Maybe I should do a clean reinstall.

Thank you, anyway.

Regards, Markus.
markusrehm is offline   Reply With Quote

Old   May 20, 2014, 12:28
Default
  #111
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,754
Rep Power: 36
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by markusrehm View Post
Hi Bruno,

thank you very much for your hints. Unfortunately the error persists.
But you are right, I had some trouble installing the extend-3.0-Version and changed some folders. However, it does run fine up to now, except SWAK.

Maybe I should do a clean reinstall.

Thank you, anyway.

Regards, Markus.
My recommendation is to compile swak from the ./Allmake.stage5-script in the ThirdParty-folder of foam-extend-3

I notice that your compiler calls don't have -DFOAM_DEV. That is used by swak to distinguish between OpenFOAM and Foam-Extend (foam-extend should set this automatically)
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   June 4, 2014, 03:19
Unhappy Swak4Foam 0.2.3 installation error
  #112
New Member
 
Anonymous
Join Date: May 2013
Posts: 3
Rep Power: 3
Hi123 is on a distinguished road
Hi,

I am encountering problems in installing swak4Foam 0.2.3 for OF2.3.0.
Bison 2.7.12
Flex2.5.37
gcc 4.6.2

I have attached the texts that displayed while ./Allwmake it as a docx file.

Pls help me for the same.

Thanks in advance
Attached Files
File Type: docx make.docx (15.3 KB, 4 views)
Hi123 is offline   Reply With Quote

Old   June 4, 2014, 03:33
Default
  #113
Senior Member
 
Markus Rehm
Join Date: Mar 2009
Location: Erlangen (Germany)
Posts: 169
Rep Power: 7
markusrehm is on a distinguished road
Hi Bernhard,

thank's for the hint. That did help!
Both variables -DFOAM_DEV and -FOAM_DEV were not set. But after setting it manually it worked.

Regards, Markus.
markusrehm is offline   Reply With Quote

Old   June 4, 2014, 05:07
Default
  #114
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,754
Rep Power: 36
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by Hi123 View Post
Hi,

I am encountering problems in installing swak4Foam 0.2.3 for OF2.3.0.
Bison 2.7.12
Flex2.5.37
gcc 4.6.2

I have attached the texts that displayed while ./Allwmake it as a docx file.

Pls help me for the same.

Thanks in advance
0.2.3 is over a year old. It knows nothing about OF 2.3. Use the latest release version and if you still have problems we can talk
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   June 11, 2014, 04:08
Default Bison 2.3 and installation
  #115
New Member
 
Join Date: Jul 2013
Posts: 4
Rep Power: 3
Belki is on a distinguished road
Hello everyone,

as you might expect, I am also having problem installing swak4foam, on a cluster.
First of all, the versions installed are:
OpenFoam 2.1.0
Bison 2.3
Flex 2.5.35
swak4Foam 0.3.0

It compiles until it yields:
Quote:
../FieldValueExpressionParser.yy:467.25-29: syntax error, unexpected type, expecting string or identifier
mv: cannot stat `*.tab.cc': No such file or directory
sed: can't read location.hh: No such file or directory
mv: cannot stat `location.hh': No such file or directory
mv: cannot stat `stack.hh': No such file or directory
mv: cannot stat `position.hh': No such file or directory
sed: can't read FieldValueExpressionParser.tab.hh: No such file or directory
mv: cannot stat `*.hh': No such file or directory
g++: Make/linux64Gcc45DPOpt/FieldValueExpressionParser.C: No such file or directory
g++: no input files
make: *** [Make/linux64Gcc45DPOpt/FieldValueExpressionParser.o] Error 1
Parser library did not compile OK. No sense continuing as everything else depends on it

Requirements for Library not satisfied. I see no sense in going on
Check the README before you go on to ask. And search: Most likely your problem occured to 5 other people before and has been solved on the MessageBoard
I was thinking it could come from the version of Bison as it is a .yy file which gets an error but it is stated that only plugins are not supposed to work with the 2.3 version.
Any ideas on how to fix this?

Thanks in advance,

Regards,

Bruno
Belki is offline   Reply With Quote

Old   June 11, 2014, 04:41
Default
  #116
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,754
Rep Power: 36
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by Belki View Post
Hello everyone,

as you might expect, I am also having problem installing swak4foam, on a cluster.
First of all, the versions installed are:
OpenFoam 2.1.0
Bison 2.3
Flex 2.5.35
swak4Foam 0.3.0

It compiles until it yields:


I was thinking it could come from the version of Bison as it is a .yy file which gets an error but it is stated that only plugins are not supposed to work with the 2.3 version.
Any ideas on how to fix this?

Thanks in advance,

Regards,

Bruno
2.3 is too old to compile swak4Foam. But the script Libraries/Allwmake tests for that and ends with an error message. Seems like you set the variable USE_OLD_BISON to bypass that. Only chance to get swak to run is to install a newer version of bison (preferably 2.7, but NOT 3.0). The development version (the one you pull with hg http://openfoamwiki.net/index.php/Co...am#Development) has a script maintainanceScripts/compileRequirements.sh that compiles a version of bison that is used only for swak4Foam
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   June 11, 2014, 04:49
Default
  #117
New Member
 
Join Date: Jul 2013
Posts: 4
Rep Power: 3
Belki is on a distinguished road
Hello Bernhard,

Thank you very much for the quick answer.
Unfortuantely, I do not think I will be able to make the IT guys update the Bison version on the whole cluster as I am only a master thesis student but I might be able to put it on one of the work stations.
Hence, my next question:
Is Bison only used to compile swak4Foam and not used anymore once it is installed? i.e. could I compile swak4Foam on the only machine which has Bison 2.7 and then run a parallel case on other machines which have Bison 2.3?

Thanks again for your patience,

Regards,

Bruno
Belki is offline   Reply With Quote

Old   June 11, 2014, 04:58
Default
  #118
Assistant Moderator
 
Bernhard Gschaider
Join Date: Mar 2009
Posts: 3,754
Rep Power: 36
gschaider will become famous soon enoughgschaider will become famous soon enough
Quote:
Originally Posted by Belki View Post
Hello Bernhard,

Thank you very much for the quick answer.
Unfortuantely, I do not think I will be able to make the IT guys update the Bison version on the whole cluster as I am only a master thesis student but I might be able to put it on one of the work stations.
Hence, my next question:
Is Bison only used to compile swak4Foam and not used anymore once it is installed? i.e. could I compile swak4Foam on the only machine which has Bison 2.7 and then run a parallel case on other machines which have Bison 2.3?

Thanks again for your patience,

Regards,

Bruno
It's only needed for compilation. What the script described above does is compile it locally, install into the directory swak-sources and use it ONLY during compilation. No root-rights required for this.

If your admins also do not feel like installing mercurial: the last link in section "Tarballs" on the swak-page should get the current dev-version
__________________
Note: I don't use "Friend"-feature on this forum out of principle. Ah. And by the way: I'm not on Facebook either. So don't be offended if I don't accept your invitation/friend request
gschaider is offline   Reply With Quote

Old   June 11, 2014, 05:42
Default
  #119
New Member
 
Join Date: Jul 2013
Posts: 4
Rep Power: 3
Belki is on a distinguished road
Thank you, Bernhard.
Belki is offline   Reply With Quote

Reply

Tags
compile error, swak4foam

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
swak4foam newbie29 OpenFOAM Installation 71 July 2, 2014 17:57
groovyBC and funkySetFields married and got a kid named swak4Foam gschaider OpenFOAM 161 March 30, 2014 08:04
Installing swak4Foam to OpenFOAM in mac Kaquesang OpenFOAM Installation on Windows, Mac and other Unsupported Platforms 22 January 21, 2013 11:51
About installation of swak4Foam mmkr825 OpenFOAM Programming & Development 10 December 14, 2012 01:24
swak4Foam for calculating velocity transformations santoshgoku OpenFOAM 4 June 20, 2012 05:39


All times are GMT -4. The time now is 20:37.