CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFoam 2.1.x /2.2.0 compilation failed on Ubuntu 12.04/10 64bit (http://www.cfd-online.com/Forums/openfoam-installation/115187-openfoam-2-1-x-2-2-0-compilation-failed-ubuntu-12-04-10-64bit.html)

keepfit March 25, 2013 19:10

OpenFoam 2.1.x /2.2.0 compilation failed on Ubuntu 12.04/10 64bit
 
hi, Foamers,

I have been using OpenFOAM 2.1.1 for a while, now I wanna install OpenFOAM on a thinkpad x200 laptop.

So far I tried:

1) Fresh installed Ubuntu 12.10 64bit
Both OF 2.1.1 and OF 2.2.0 compilation failed according to the following installation guide:
http://openfoamwiki.net/index.php/In...M-2.1.1/Ubuntu

and
http://www.openfoam.org/download/source.php

2) So I removed the latest Ubuntu 12.10 system and replaced it with the Ubuntu 12.04.2 LTS (x64), which is same as the OS of my Desktop PC in which OF 2.1.1 is already installed from source pack

here is the first error for OF 2.2.0 compilation:

Quote:

.....
wmake libso mpi
/usr/bin/ld: error: --add-needed is not supported but is required for libdl.so.2 in /home/dao/OpenFOAM/ThirdParty-2.2.0/platforms/linux64Gcc/openmpi-1.6.3/lib64/libmpi.so
collect2: ld returned 1 exit status
make: *** [/home/dao/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64GccDPOpt/lib/openmpi-1.6.3/libPstream.so] Error 1
+ OSspecific/POSIX/Allwmake
'/home/dao/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64GccDPOpt/lib/libOSspecific.o' is up to date.
....
Should I change the "linux64Gcc" rules for c/c++, because there are a lot of "/usr/bin/ld: error:....... " errors.

Any hints or recommendation will be appreciated.

Greetings!

adhiraj March 26, 2013 09:31

Are you using gcc 4.7?

I had to add the flag "-fpermissive" to the file wmake/rules/linux64Gcc/c++.

Code:

c++FLAGS    = $(GFLAGS) $(c++WARN) $(c++OPT) $(c++DBUG) $(ptFLAGS) $(LIB_HEADER_DIRS) -fPIC -fpermissive
This was for OpenFOAM 1.7.1, so may be a bit different from 2.x.x though.
This was in Ubuntu 12.10 64 bit.

keepfit March 26, 2013 10:43

Quote:

Originally Posted by adhiraj (Post 416510)
Are you using gcc 4.7?

I had to add the flag "-fpermissive" to the file wmake/rules/linux64Gcc/c++.

Code:

c++FLAGS    = $(GFLAGS) $(c++WARN) $(c++OPT) $(c++DBUG) $(ptFLAGS) $(LIB_HEADER_DIRS) -fPIC -fpermissive
This was for OpenFOAM 1.7.1, so may be a bit different from 2.x.x though.
This was in Ubuntu 12.10 64 bit.

I reinstalled Ubuntu 12.04 LTS again!

but this time I just update the system and then Install OF without installing any other software.

Hoping it works.

PS: the gcc version is 4.6.3.


All times are GMT -4. The time now is 10:26.