CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Install OpenFoam1.71 on cluster without Root permission, help! (http://www.cfd-online.com/Forums/openfoam-installation/117218-install-openfoam1-71-cluster-without-root-permission-help.html)

ripperjack May 4, 2013 18:47

Install OpenFoam1.71 on cluster without Root permission, help!
 
Hi All,

I want to compile and install OF 1.71 on a cluster (RedHat 4.1.2-46), but I can not get the root permission on that cluster. Is it possible? How can I do? Many thank!

btw: I have successfully compiled and installed OF 1.7.1 on my PC following the instruction on the website, but I need root permission to install some pre-lib, which I can not do on the cluster. But I am sure the OF 1.71 was installed on that cluster before, so the pre-lib may have installed. I followed the same instruction on the website but I failed to compile OF. The guy who has the permission to do so is on vacation during this summer, but I need to use openfoam now! Could you guys help!

Regards

wyldckat May 4, 2013 20:12

Greetings ripperjack,

A few questions:
  1. Which Linux distribution, version and architecture do you have on the PC?
  2. Which architecture do you have on the cluster? You can check by running:
    Code:

    uname -m
  3. Which GCC, bison and flex versions does the cluster have? You can check with the following commands:
    Code:

    gcc --version
    bison --version
    flex --version

  4. You can also check if there are any other GCC version installed by typing "gcc" (without the quotes) and the pressing the Tab key a couple of times. With any luck, "gcc43" or "gcc44" will appear.
  5. Do you know if you have enough quota space (and file count) on the cluster? Because some clusters constrain the space available per user, as well as the number of files that user can have on the cluster.
Best regards,
Bruno

ripperjack May 4, 2013 20:34

Quote:

Originally Posted by wyldckat (Post 425250)
Greetings ripperjack,

A few questions:
  1. Which Linux distribution, version and architecture do you have on the PC?
  2. Which architecture do you have on the cluster? You can check by running:
    Code:

    uname -m
  3. Which GCC, bison and flex versions does the cluster have? You can check with the following commands:
    Code:

    gcc --version
    bison --version
    flex --version

  4. You can also check if there are any other GCC version installed by typing "gcc" (without the quotes) and the pressing the Tab key a couple of times. With any luck, "gcc43" or "gcc44" will appear.
  5. Do you know if you have enough quota space (and file count) on the cluster? Because some clusters constrain the space available per user, as well as the number of files that user can have on the cluster.
Best regards,
Bruno

Hi Bruno,

Thanks very much for your reply! The followings are the information on the cluster. I am sure that the space is enough for the OF, but I need to check the file count. I follow the instruction How to install OpenFOAM 1.7.1 on RHEL HPC 5.5 to install openfoam. What I can not do is to install some development libs mentioned in the above link, and I am not sure if these lib is installed or not on the cluster (e.g. I typed graphviz --version and it was said that command is not found....). Could you help? Many thanks!

btw: my PC is on Ubuntu, and I follow another instruction to install it.

Best regards,
Ping

Code:

uname -m
X86_64

uname -a
Linux login03 2.6.18-164.el5 #1 SMP Thu Sep 3 03:28:30 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

gcc --version
gcc (GCC) 4.1.2 20080704 (Red Hat 4.1.2-46)

bison --version
bison (GNU Bison) 2.3

flex --version
flex version 2.5.4

gcc34 --version
gcc34 (GCC) 3.4.6 20060404 (Red Hat 3.4.6-4)

gcc44 --version
gcc44 (GCC) 4.4.0 20090514 (Red Hat 4.4.0-6


wyldckat May 4, 2013 21:11

Hi Ping,

Since it's Ubuntu on the PC, it's unlikely that the build you have got in it will run on the cluster. The binaries are probably incompatible :(


OK, but if you have Gcc 4.4 on the cluster, then it's almost a given that you can easily install OpenFOAM 1.7.1 on the cluster.
And from what I can see, if you follow carefully the instructions on the link you indicated, you'll be able to install OpenFOAM without any problems.

As for the missing "graphviz" package: don't worry, that's only needed for ParaView, which you don't need to install on the cluster.

You just need to follow the instructions very carefully!
But there is one suggestion I would like to add - when running Allwmake, make it send the output into a log file, like this:
Code:

./Allwmake > make.log 2>&1
This way it'll be easier to diagnose the build if something goes wrong, since the output messages while building will be logged into the file "make.log". And remember: it's the first couple of error messages that you have to worry about, not the last ones!

And when they say:
Quote:

Originally Posted by http://consultancy.edvoncken.net/index.php/OpenFOAM
Source this bashrc file from your profile ...

What they mean is to add the following line to your "~/.bashrc" file:
Code:

source /usr/local/OpenFOAM/OpenFOAM-1.7.1/etc/bashrc
Best regards,
Bruno

ripperjack May 6, 2013 13:47

2 Attachment(s)
Quote:

Originally Posted by wyldckat (Post 425254)
Hi Ping,

Since it's Ubuntu on the PC, it's unlikely that the build you have got in it will run on the cluster. The binaries are probably incompatible :(


OK, but if you have Gcc 4.4 on the cluster, then it's almost a given that you can easily install OpenFOAM 1.7.1 on the cluster.
And from what I can see, if you follow carefully the instructions on the link you indicated, you'll be able to install OpenFOAM without any problems.

As for the missing "graphviz" package: don't worry, that's only needed for ParaView, which you don't need to install on the cluster.

You just need to follow the instructions very carefully!
But there is one suggestion I would like to add - when running Allwmake, make it send the output into a log file, like this:
Code:

./Allwmake > make.log 2>&1
This way it'll be easier to diagnose the build if something goes wrong, since the output messages while building will be logged into the file "make.log". And remember: it's the first couple of error messages that you have to worry about, not the last ones!

And when they say:

What they mean is to add the following line to your "~/.bashrc" file:
Code:

source /usr/local/OpenFOAM/OpenFOAM-1.7.1/etc/bashrc
Best regards,
Bruno

Hi Bruno,

Many thanks for your detailed instructions! I tried to compile it accordingly but it failed, I tried for many times and the errors are same, it seems that the 1st error is "configure: error: no vtf3.h found; check path for VTF3 package first...", I am so frustrated... I attached the make.log file, could you please help?

I do not know how to compress and split the log file to two tar.gz files, so I split it to two rar files and then each is compressed into tar.gz.....

Regards,
Ping

wyldckat May 6, 2013 17:16

Hi Ping,

Sorry, I should have been more explicit... the relevant error messages usually start with "Error ", including the space and without quotes.

The problem is this:
Code:

/usr/bin/ld: cannot find -liberty
Technically, the library "libiberty.so" is not being found.
If I remember correctly, it's the system package "glibc-devel" that has got this library... or maybe it's "binutils-devel".

Either way, right now I don't have the time to test this myself, but you can try the following steps:
  1. Edit the file "$HOME/OpenFOAM/OpenFOAM-1.7.1/wmake/rules/linux64Gcc/general".
  2. Change this line:
    Code:

    PROJECT_LIBS = -l$(WM_PROJECT) -liberty -ldl
    to this:
    Code:

    PROJECT_LIBS = -l$(WM_PROJECT) -ldl
  3. Save and close the file.
  4. Run Allwmake once again.
With any luck, this will allow OpenFOAM 1.7.1 to build without problems.

Best regards,
Bruno

ripperjack May 6, 2013 22:35

Quote:

Originally Posted by wyldckat (Post 425656)
Hi Ping,

Sorry, I should have been more explicit... the relevant error messages usually start with "Error ", including the space and without quotes.

The problem is this:
Code:

/usr/bin/ld: cannot find -liberty
Technically, the library "libiberty.so" is not being found.
If I remember correctly, it's the system package "glibc-devel" that has got this library... or maybe it's "binutils-devel".

Either way, right now I don't have the time to test this myself, but you can try the following steps:
  1. Edit the file "$HOME/OpenFOAM/OpenFOAM-1.7.1/wmake/rules/linux64Gcc/general".
  2. Change this line:
    Code:

    PROJECT_LIBS = -l$(WM_PROJECT) -liberty -ldl
    to this:
    Code:

    PROJECT_LIBS = -l$(WM_PROJECT) -ldl
  3. Save and close the file.
  4. Run Allwmake once again.
With any luck, this will allow OpenFOAM 1.7.1 to build without problems.

Best regards,
Bruno

Hi Bruno,

Many thanks! I followed your instruction and complied again. No error this time, finally! OF 1.7 runs fine on the cluster!!

Thanks again!

Best regards,
Ping

wyldckat May 7, 2013 16:46

Hi Ping,

I'm glad it worked!
I was hoping it would work, otherwise it would have been a bit difficult to figure out how to fix it :(

Best regards,
Bruno


All times are GMT -4. The time now is 06:44.