CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

openfoam-2.2.0 installation on cluster of Redhat 4.1.2-48

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes

Reply
 
LinkBack Thread Tools Display Modes
Old   June 9, 2013, 05:41
Unhappy openfoam-2.2.0 installation on cluster of Redhat 4.1.2-48
  #1
New Member
 
Zeng Qingyun
Join Date: Oct 2012
Posts: 8
Rep Power: 4
Chandler is on a distinguished road
Hi!
I want to install OpenFoam on a machine with Redhat 4.1.2, but the Gcc version of Redhat is 4.1.2. an other Gcc version is installed in path: /public/source/gcc-source/gcc-4.7.1/gcc_install/, but i dont know how to use it.

i try to install gcc-4.6.2 in the thirdparty directory, but after installation, i type "gcc --version", it showed gcc-4.1.2.
How can i do in this situation?

foamInstallationTest is shown as:

Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: ln0
OS: Linux version 2.6.18-194.el5
-------------------------------------------------------------------------------

Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /locallustre/home/caijiejin/OpenFOAM yes yes
$WM_PROJECT_USER_DIR ...e/caijiejin/OpenFOAM/caijiejin-2.2.0 no no
$WM_THIRD_PARTY_DIR .../caijiejin/OpenFOAM/ThirdParty-2.2.0 yes yes
-------------------------------------------------------------------------------

Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR ...me/caijiejin/OpenFOAM/OpenFOAM-2.2.0 yes yes yes
$FOAM_APPBIN ....2.0/platforms/linux64Gcc46DPOpt/bin no yes
$FOAM_SITE_APPBIN ....2.0/platforms/linux64Gcc46DPOpt/bin no no
$FOAM_USER_APPBIN ....2.0/platforms/linux64Gcc46DPOpt/bin no no
$WM_DIR ...jiejin/OpenFOAM/OpenFOAM-2.2.0/wmake yes yes yes
-------------------------------------------------------------------------------

Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ....2.0/platforms/linux64Gcc46DPOpt/lib no yes
$FOAM_SITE_LIBBIN ....2.0/platforms/linux64Gcc46DPOpt/lib no no
$FOAM_USER_LIBBIN ....2.0/platforms/linux64Gcc46DPOpt/lib no no
$MPI_ARCH_PATH ...platforms/linux64Gcc46/openmpi-1.6.3 no yes
-------------------------------------------------------------------------------

Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
flex /usr/bin/flex
ERROR: gcc version is too old for this release of OpenFOAM
User version : 4.1.2
Minimum required: 4.3.2
gcc 4.1.2 /usr/bin/gcc
gzip 1.3.5 /bin/gzip
tar 1.15.1 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /locallustre/home/caijiejin/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc46DPOpt/bin/icoFoam
current path :
CRITICAL ERROR
-------------------------------------------------------------------------------

Summary
-------------------------------------------------------------------------------
The system test has evoked 1 fatal error(s).
The foam installation contains 1 critical error(s).
Review the output for warning messages and consult
the installation guide for troubleshooting.
Done


anyone helps? Thank you!
Chandler is offline   Reply With Quote

Old   June 9, 2013, 07:08
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Zeng,

I have not tried the following instructions with CentOS 4.x, but you can try them out and let me know if anything goes wrong: http://openfoamwiki.net/index.php/In...HEL#CentOS_6.4

You might not want to follow the instructions for installing certain packages from step #1, but the rest should be OK.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 9, 2013, 22:51
Default
  #3
New Member
 
Zeng Qingyun
Join Date: Oct 2012
Posts: 8
Rep Power: 4
Chandler is on a distinguished road
thankful Bruno!

i successfully install openfoam-2.2.0 on cluster but no totally follow the tutorial you give. i checked the system again and found it is RedHat Enterprise Linux 5.5 x86_64, the command "module load openmpi-x86_64" can't be used on this cluster.
i follow the installation tutorial http://openfoamwiki.net/index.php/Installation/Linux/OpenFOAM-2.2.0/CentOS_SL_RHEL#CentOS_6.4 step #5 to #7 to build the gcc-4.6.2, and then build the thirdparty and openfoam.

Best regards,
Zeng
wyldckat likes this.
Chandler is offline   Reply With Quote

Old   June 25, 2013, 17:52
Default
  #4
Member
 
Avdeev Evgeniy
Join Date: Jan 2011
Location: Togliatty, Russia
Posts: 52
Blog Entries: 1
Rep Power: 12
j-avdeev will become famous soon enough
Send a message via Skype™ to j-avdeev
Hello.
I have similar situation. But gcc version is OK.
What is wrong?

Code:
$ foamInstallationTest 
Executing /home/avdeev/OpenFOAM/OpenFOAM-2.2.0/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell:              bash
Host:               mgt1
OS:                 Linux version 2.6.18-308.11.1.el5
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid      Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/avdeev/OpenFOAM                    yes       yes
$WM_PROJECT_USER_DIR /home/avdeev/OpenFOAM/avdeev-2.2.0       no        no
$WM_THIRD_PARTY_DIR  /home/avdeev/OpenFOAM/ThirdParty-2.2.0   yes       yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR      /home/avdeev/OpenFOAM/OpenFOAM-2.2.0     yes  yes  yes

$FOAM_APPBIN         ....2.0/platforms/linux64Gcc46DPOpt/bin  yes  yes  yes
$FOAM_SITE_APPBIN    ....2.0/platforms/linux64Gcc46DPOpt/bin  no        no
$FOAM_USER_APPBIN    ....2.0/platforms/linux64Gcc46DPOpt/bin  no        no
$WM_DIR              ...avdeev/OpenFOAM/OpenFOAM-2.2.0/wmake  yes  yes  yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory                Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN         ....2.0/platforms/linux64Gcc46DPOpt/lib  no        yes
$FOAM_SITE_LIBBIN    ....2.0/platforms/linux64Gcc46DPOpt/lib  no        no
$FOAM_USER_LIBBIN    ....2.0/platforms/linux64Gcc46DPOpt/lib  no        no
$MPI_ARCH_PATH       ...platforms/linux64Gcc46/openmpi-1.6.3  no        yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version   Location 
-------------------------------------------------------------------------------
flex               /usr/bin/flex                                            
gcc      4.6.1     ...M/ThirdParty-2.2.0/platforms/linux64/gcc-4.6.1/bin/gcc
gzip     1.3.5     /bin/gzip                                                
tar      1.15.1    /bin/tar                                                 
icoFoam           
WARNING:  Conflicting installations:
          OpenFOAM settings        : /home/avdeev/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc46DPOpt/bin/icoFoam
          current path             : 
          CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.
The foam installation contains 1 critical error(s).

Review the output for warning messages and consult
the installation guide for troubleshooting.

Done
Attached Files
File Type: zip make.log.zip (9.8 KB, 4 views)
j-avdeev is offline   Reply With Quote

Old   June 27, 2013, 17:37
Default
  #5
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Avdeev,

According to the "make.log" file, the very first error is this:
Code:
/home/avdeev/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/gcc-4.6.1/libexec/gcc/x86_64-unknown-linux-gnu/4.6.1/cc1: error while loading shared libraries: libmpfr.so.4: cannot open shared object file: No such file or directory
Which means that something very strange has happened, because GCC 4.6.1 could only have been build with success if you had built MPFR properly as well.

I'm guessing you simply ran the makeGcc46 script without verifying which exact versions of software were defined in OpenFOAM's "settings.sh" file. If this is the case, then follow these steps:
  1. Edit the file "$WM_PROJECT_DIR/etc/config/settings.sh".
  2. Search for this block of code:
    Code:
            gcc_version=gcc-4.6.1
            gmp_version=gmp-5.0.4
            mpfr_version=mpfr-3.1.0
            mpc_version=mpc-0.9
  3. Change the block to this:
    Code:
            gcc_version=gcc-4.6.1
            gmp_version=gmp-5.0.2
            mpfr_version=mpfr-3.0.1
            mpc_version=mpc-0.9
  4. Save and close the file.
  5. Start a new terminal.
  6. Run Allwmake once again and it should build everything properly.
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 28, 2013, 14:18
Default
  #6
Member
 
Avdeev Evgeniy
Join Date: Jan 2011
Location: Togliatty, Russia
Posts: 52
Blog Entries: 1
Rep Power: 12
j-avdeev will become famous soon enough
Send a message via Skype™ to j-avdeev
Yes, Bruno, you right - I simply ran the makeGcc46.

But making changes in settings.sh has no effect.

Anyway, after that I tryed to follow (http://openfoamwiki.net/index.php/In...HEL#CentOS_6.4) and everything working now.
Yes-yes, I would have to use this manual before asking here, but using external binUtils scare me a little - why it not included in thirdparty?

Thank you, Bruno!
wyldckat likes this.
j-avdeev is offline   Reply With Quote

Old   June 30, 2013, 02:01
Default
  #7
New Member
 
Manjura Maula Md. Nayamatullah
Join Date: May 2013
Posts: 21
Rep Power: 4
mmmn036 is on a distinguished road
Hello,

I had the same gcc version problem for installation of OpenFoam 2.2.0 in my cluster, which i solved through the instruction from weblink.

But I can not build the paraview and gives the following error-

ERROR: ParaView not found in /home/jzb292/OpenFOAM/ThirdParty-2.2.0/platforms/linux64Gcc45/paraview-3.12.0

I don't know what happened.

OpenFoam runs good.

Please help me out.

Thanks
Manjura
mmmn036 is offline   Reply With Quote

Old   June 30, 2013, 06:58
Default
  #8
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Manjura,

Run the following commands:
Code:
cd $WM_THIRD_PARTY_DIR
./makeParaView -qmake $(which qmake-qt4) > mkpv.log 2>&1
When it stops running, check the contents of the file "mkpv.log". If you do not understand why an error is showing up, please compress the file and attach it to your next post.
For example, you can compress the file with the following command:
Code:
gzip mkpv.log
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 30, 2013, 16:16
Default
  #9
New Member
 
Manjura Maula Md. Nayamatullah
Join Date: May 2013
Posts: 21
Rep Power: 4
mmmn036 is on a distinguished road
Thanks for reply.

I got the following message when i run- ./makeParaView -qmake $(which qmake-qt4) :

/usr/bin/which: no qmake-qt4 in (/home/jzb292/OpenFOAM/ThirdParty-2.2.0/platforms/linux64Gcc/gperftools-svn/bin:/home/jzb292/OpenFOAM/ThirdParty-2.2.0/platforms/linux64Gcc/paraview-3.12.0/bin:/home/jzb292/OpenFOAM/ThirdParty-2.2.0/platforms/linux64Gcc/openmpi-1.6.3/bin:/home/jzb292/OpenFOAM/jzb292-2.2.0/platforms/linux64GccDPOpt/bin:/home/jzb292/OpenFOAM/site/2.2.0/platforms/linux64GccDPOpt/bin:/home/jzb292/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64GccDPOpt/bin:/home/jzb292/OpenFOAM/OpenFOAM-2.2.0/bin:/home/jzb292/OpenFOAM/OpenFOAM-2.2.0/wmake:/home/jzb292/projects/gnuplot/bin:/home/jzb292/projects/git/bin:/share/apps/python/2.7.3/bin:/share/apps/cuda/5.0/bin:/share/apps/openmpi/1.6/bin:/share/apps/texlive/2012/bin/x86_64-linux:/opt/gridengine/bin/lx26-amd64:/usr/kerberos/bin:/usr/java/latest/bin:/share/apps/gcc/4.7.1/bin:/usr/local/bin:/bin:/usr/bin:/opt/ganglia/bin:/opt/ganglia/sbin:/usr/local/sbin/:/opt/openmpi/bin/:/opt/rocks/bin:/opt/rocks/sbin:/opt/sun-ct/bin:/home/jzb292/bin)
'-qmake' option requires an argument

usage: makeParaView [OPTION] [CMAKE-OPTION]
options:
-rebuild for repeated builds (-make -install) *use with caution*
-mesa with mesa (if not already enabled)
-mpi with mpi (if not already enabled)
-python with python (if not already enabled)
-cmake PATH with the cmake version corresponding to the cmake path given
-qmake PATH with the Qt version corresponding to the qmake path given
-qt with extra Qt gui support (if not already enabled)
-qt-VER with Qt version corresponding to
$WM_THIRD_PARTY_DIR/platforms/linux64Gcc/qt-VER/bin/qmake
-gcc force g++ instead of the value from $WM_CXX
-verbose verbose output in Makefiles
-version VER specify an alternative version (current value: 3.12.0)
-major VER specify an alternative major version for special builds
-mesa-include DIR
location of mesa headers (current value: /usr/include/GL)
-mesa-lib PATH path to mesa library (current value: /usr/lib64/libOSMesa.so)
-python-lib PATH path to python library (current value: none)
-help

The -no-FEATURE option can be disable these features (if not already disabled):
mesa mpi python qt

CMake options start with a capital letter and contain an '='.
For example,
makeParaView BUILD_TESTING=ON PARAVIEW_GENERATE_PROXY_DOCUMENTATION=OFF
to add tests and avoid building documentation

For finer control, the build stages can be selected or deselected individually:
-config -no-config
-make -no-make
-install -no-install


* Make and install paraview-3.12.0 located under
$WM_THIRD_PARTY_DIR/ParaView-3.12.0
-> $WM_THIRD_PARTY_DIR/platforms/linux64Gcc/paraview-3.12.0

Thanks for your help.

Manjra
mmmn036 is offline   Reply With Quote

Old   June 30, 2013, 17:49
Default
  #10
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Manjura,

My guess is that you did not follow step #1 properly, because the absence of qmake-qt4 indicates that you do not have installed the package "qt-devel".

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 30, 2013, 21:20
Default
  #11
New Member
 
Manjura Maula Md. Nayamatullah
Join Date: May 2013
Posts: 21
Rep Power: 4
mmmn036 is on a distinguished road
I do not have the administrator access to install the 'Development tools'.

How can i perform step-1?

Thanks
mmmn036 is offline   Reply With Quote

Old   July 1, 2013, 17:35
Default
  #12
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Manjura,

If you do not have administrative powers, then you either have to ask the administrator to install the packages or you can follow these instructions: http://openfoamwiki.net/index.php/In...HEL#CentOS_5.8 - It's for CentOS 5.8 and OpenFOAM 2.1.1, but you only need to follow from step #10.

Step #10 has the instructions for doing a custom build of Qt, then #11 indicates how to use this custom build of Qt for building ParaView.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 10, 2013, 09:24
Default
  #13
Member
 
Avdeev Evgeniy
Join Date: Jan 2011
Location: Togliatty, Russia
Posts: 52
Blog Entries: 1
Rep Power: 12
j-avdeev will become famous soon enough
Send a message via Skype™ to j-avdeev
I've tryed to perform step #10 (http://openfoamwiki.net/index.php/In...HEL#CentOS_5.8)
but it finished with error
Code:
...
Basic XLib functionality test failed!
 You might need to modify the include and library search paths by editing
 QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in /home/avdeev/OpenFOAM/ThirdParty-2.2.0/qt-everywhere-opensource-src-4.6.4/mkspecs/linux-g++-64.
Error building: Qt-4.6.4
some googling shows, that I need install from sources
build-dep qt4-qmake
right?
Attached Files
File Type: zip mkqt.log.zip (16.4 KB, 5 views)
j-avdeev is offline   Reply With Quote

Old   July 10, 2013, 17:17
Default
  #14
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Avdeev,

That error is familiar... If I remember correctly and by looking into your log file, I would say that you didn't do these two command lines properly:
Code:
#fix the defaults for Qt not to use gcc or g++ by default
sed -i -e 's/= gcc/= gcc44/' qt-everywhere-opensource-src-4.6.4/mkspecs/common/g++.conf
sed -i -e 's/= g++/= g++44/' qt-everywhere-opensource-src-4.6.4/mkspecs/common/g++.conf
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   July 12, 2013, 06:47
Default
  #15
Member
 
Avdeev Evgeniy
Join Date: Jan 2011
Location: Togliatty, Russia
Posts: 52
Blog Entries: 1
Rep Power: 12
j-avdeev will become famous soon enough
Send a message via Skype™ to j-avdeev
Bruno, yes, error was in g++.conf file. I've ran "sed ..." script more than one time and it was g++4444 instead of g++44. It's corrected.

But now another error:

Code:
...
Error: Symbian SDK registry key not found
Error: failed to find epoc root
...
mkqt.log.zip

Last edited by j-avdeev; July 12, 2013 at 17:41.
j-avdeev is offline   Reply With Quote

Old   July 12, 2013, 17:29
Default
  #16
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Avdeev,

a 21MB log file... I forgot how big Qt really is!

OK, the error you got was in fact:
Quote:
Code:
/home/avdeev/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/gcc-4.5.2/lib/gcc/x86_64-unknown-linux-gnu/4.5.2/../../../../include/c++/4.5.2/bits/stl_list.h:1435: undefined reference to `std::_List_node_base::_M_hook(std::_List_node_base*)'
collect2: ld returned 1 exit status
Well this is very confusing... "g++44" would mean that you should be using Gcc 4.4, but the error message clearly is referring to Gcc 4.5.2.
OK, after reading the past posts, I've managed to figure out that you were following the instructions for CentOS 6.4.
But why are you building the custom Qt?


Anyway, it took me a while to deduce this, but I think these steps should fix the problem:
  1. Once again, tdit the file "qt-everywhere-opensource-src-4.6.4/mkspecs/common/g++.conf" with a text editor.
  2. Now, you should see that there are several occurrences of "gcc", "g++", "g++44" and "gcc44".
  3. But since you have the custom built Gcc 4.5.2 from the instructions for CentOS 6.4, then you should remove all "44" from "g++44" and "gcc44". This way you will only have "gcc" and "g++", which will make sure that you are only using Gcc/G++ 4.5.2.
  4. Save the file.
  5. Try building Qt 4.6.4 once again!
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   October 23, 2013, 23:38
Default
  #17
Member
 
Yijiu Jiang
Join Date: Jan 2013
Location: Texas, US
Posts: 30
Rep Power: 4
y_jiang is on a distinguished road
Hi Bruno,

I've already build OF on our x86_64 redhat linux cluster. But I got some problems when building paraview. Basically I just followed the instruction here
http://openfoamwiki.net/index.php/In...HEL#CentOS_6.4
However I don't have the access to to administrator. So I just skip the 1st step. I used custom built Gcc 4.5.2 compiled OF. When I tried to build paraview, I think I need to do a custom build of both CMake 2.8 and Qt 4.6 or higher. There's no problem when I built CMake. But when I tried to build Qt following step 10 here http://openfoamwiki.net/index.php/In...HEL#CentOS_5.8
When I conducting ./getQt, the terminal showed me the following message:

Code:
downloading qt-everywhere-opensource-src-4.6.4.tar.gz from http://releases.qt-project.org/qt4/s...c-4.6.4.tar.gz
--2013-10-23 22:15:16--  http://releases.qt-project.org/qt4/s...c-4.6.4.tar.gz
Resolving releases.qt-project.org... 77.86.229.90
Connecting to releases.qt-project.org|77.86.229.90|:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://download.qt-project.org/ [following]
--2013-10-23 22:15:16--  http://download.qt-project.org/
Resolving download.qt-project.org... 77.86.229.90
Connecting to download.qt-project.org|77.86.229.90|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3196 (3.1K) [text/html]
Saving to: qt-everywhere-opensource-src-4.6.4.tar.gz

100%[=====================================>] 3,196       --.-K/s   in 0s      

2013-10-23 22:15:16 (224 MB/s) - qt-everywhere-opensource-src-4.6.4.tar.gz saved [3196/3196]

unpack download/qt-everywhere-opensource-src-4.6.4.tar.gz

gzip: stdin: not in gzip format
tar: Child returned status 1
tar: Error is not recoverable: exiting now
Which means qt-everywhere-opensource-src-4.6.4.tar.gz cannot be extracted. Then, I went to download dir using file to check the file type of qt-everywhere-opensource-src-4.6.4.tar.gz. It showed me this:
Code:
qt-everywhere-opensource-src-4.6.4.tar.gz: HTML document text
Since the file type here is not correct I am wondering is the source address which is given in the instruction is not available? Or is there any other reason may lead to this error? Thanks

Anyone has the same problem?

Last edited by wyldckat; October 26, 2013 at 10:50. Reason: Added [CODE][/CODE]
y_jiang is offline   Reply With Quote

Old   October 24, 2013, 05:47
Default
  #18
Member
 
Eysteinn Helgason
Join Date: Sep 2009
Location: Gothenburg, Sweden
Posts: 52
Rep Power: 7
eysteinn is on a distinguished road
Quote:
Originally Posted by y_jiang View Post
downloading qt-everywhere-opensource-src-4.6.4.tar.gz from http://releases.qt-project.org/qt4/s...c-4.6.4.tar.gz
This link doesn't work.
Maybe you can edit getQt to use this link instead? :
http://download.qt-project.org/archi...c-4.6.4.tar.gz

/Eysteinn
eysteinn is offline   Reply With Quote

Old   October 24, 2013, 13:20
Default
  #19
Member
 
Yijiu Jiang
Join Date: Jan 2013
Location: Texas, US
Posts: 30
Rep Power: 4
y_jiang is on a distinguished road
Quote:
Originally Posted by eysteinn View Post
This link doesn't work.
Maybe you can edit getQt to use this link instead? :
http://download.qt-project.org/archi...c-4.6.4.tar.gz

/Eysteinn
Thanks Eysteinn. This link works. I have built Qt 4.6.4.
However, when I conduct the 11 step here http://openfoamwiki.net/index.php/In...HEL#CentOS_6.4

It shows me this:

[jaq526@takara PV3Readers]$ wmSET $FOAM_SETTINGS
Cannot open configuration file /home/jaq526/OpenFOAM/ThirdParty-2.2.0/platforms/linux64Gcc/openmpi-1.6.3/share/openmpi/mpicc-wrapper-data.txt
Error parsing data file mpicc: Not found

Is there any suggested solution for this problem?

Thanks
JYJ
y_jiang is offline   Reply With Quote

Old   October 26, 2013, 10:49
Default
  #20
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,251
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings to all!

I completely forgot to update the getQt script... I'll fix this later today.

@JYJ: OK, since you don't have root permissions, then I need to know something: in step #4, did you use the option "WM_MPLIB=SYSTEMOPENMPI"?
Because if you did, then you shouldn't have

By the way, try running this command:
Code:
which mpirun
What does it give you?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Reply

Tags
clusters, installation

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error while compiling OpenFOAM on Redhat cluster feiqunali OpenFOAM Installation 3 October 13, 2013 03:30
OpenFOAM 2.2.0 installation on scientific-linux kulkarni Harshawardhan OpenFOAM Installation 1 March 20, 2013 14:38
OpenFOAM 1.7 installation on Redhat linux maxims OpenFOAM Installation 2 November 30, 2012 05:29
OpenFoam 2.0.0 installation Jan_Peters OpenFOAM Installation 86 April 27, 2012 05:32
Parallel cluster solving with OpenFoam? P2P Cluster? hornig OpenFOAM Programming & Development 8 December 5, 2010 17:06


All times are GMT -4. The time now is 05:43.