CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Error by OpenFOAM 2.2.1 installation (http://www.cfd-online.com/Forums/openfoam-installation/123472-error-openfoam-2-2-1-installation.html)

Mirage12 September 13, 2013 07:21

Error by OpenFOAM 2.2.1 installation
 
Hallo Foamers :)

I wanted to install the last released version of OpeFOAM (2.2.1) butafter typing :

Code:

                sudo apt-get update
i got some error
Error :
Code:

Err http://www.openfoam.org precise Release.gpg
  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)
Ign http://www.openfoam.org precise Release             
Ign http://www.openfoam.org precise/main TranslationIndex 
Err http://www.openfoam.org precise/main amd64 Packages   
  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)
Err http://www.openfoam.org precise/main i386 Packages   
  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)
Err http://www.openfoam.org precise/main Translation-en_IN
  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)
Err http://www.openfoam.org precise/main Translation-en
  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)
Hit http://sgposd03.apac.bosch.com precise Release.gpg
Hit http://sgposd03.apac.bosch.com precise-updates Release.gpg
Hit http://sgposd03.apac.bosch.com precise-security Release.gpg
Hit http://sgposd03.apac.bosch.com precise Release.gpg
Hit http://sgposd03.apac.bosch.com precise Release.gpg
Hit http://sgposd03.apac.bosch.com ./ Release.gpg
Hit http://sgposd03.apac.bosch.com precise Release.gpg
Hit http://sgposd03.apac.bosch.com precise Release.gpg
Hit http://sgposd03.apac.bosch.com precise Release
Hit http://sgposd03.apac.bosch.com precise-updates Release
Hit http://sgposd03.apac.bosch.com precise-security Release                     
Hit http://sgposd03.apac.bosch.com precise Release                               
Hit http://sgposd03.apac.bosch.com precise Release                               
Hit http://sgposd03.apac.bosch.com ./ Release                                   
Hit http://sgposd03.apac.bosch.com precise Release                               
Hit http://sgposd03.apac.bosch.com precise Release                               
Hit http://sgposd03.apac.bosch.com precise/main amd64 Packages                   
Hit http://sgposd03.apac.bosch.com precise/restricted amd64 Packages
Hit http://sgposd03.apac.bosch.com precise/universe amd64 Packages
Hit http://sgposd03.apac.bosch.com precise/main i386 Packages
Hit http://sgposd03.apac.bosch.com precise/restricted i386 Packages
Hit http://sgposd03.apac.bosch.com precise/universe i386 Packages
Ign http://sgposd03.apac.bosch.com precise/main TranslationIndex
Ign http://sgposd03.apac.bosch.com precise/restricted TranslationIndex
Ign http://sgposd03.apac.bosch.com precise/universe TranslationIndex
Hit http://sgposd03.apac.bosch.com precise-updates/main amd64 Packages
Hit http://sgposd03.apac.bosch.com precise-updates/restricted amd64 Packages
Hit http://sgposd03.apac.bosch.com precise-updates/universe amd64 Packages
Hit http://sgposd03.apac.bosch.com precise-updates/main i386 Packages
Hit http://sgposd03.apac.bosch.com precise-updates/restricted i386 Packages
Hit http://sgposd03.apac.bosch.com precise-updates/universe i386 Packages
Ign http://sgposd03.apac.bosch.com precise-updates/main TranslationIndex
Ign http://sgposd03.apac.bosch.com precise-updates/restricted TranslationIndex
Ign http://sgposd03.apac.bosch.com precise-updates/universe TranslationIndex
Hit http://sgposd03.apac.bosch.com precise-security/main amd64 Packages
Hit http://sgposd03.apac.bosch.com precise-security/restricted amd64 Packages
Hit http://sgposd03.apac.bosch.com precise-security/universe amd64 Packages
Hit http://sgposd03.apac.bosch.com precise-security/main i386 Packages
Hit http://sgposd03.apac.bosch.com precise-security/restricted i386 Packages
Hit http://sgposd03.apac.bosch.com precise-security/universe i386 Packages
Ign http://sgposd03.apac.bosch.com precise-security/main TranslationIndex
Ign http://sgposd03.apac.bosch.com precise-security/restricted TranslationIndex
Ign http://sgposd03.apac.bosch.com precise-security/universe TranslationIndex
Hit http://sgposd03.apac.bosch.com precise/multiverse amd64 Packages
Hit http://sgposd03.apac.bosch.com precise/multiverse i386 Packages
Ign http://sgposd03.apac.bosch.com precise/multiverse TranslationIndex
Hit http://sgposd03.apac.bosch.com precise/main amd64 Packages
Hit http://sgposd03.apac.bosch.com precise/main i386 Packages
Ign http://sgposd03.apac.bosch.com precise/main TranslationIndex
Hit http://sgposd03.apac.bosch.com ./ Packages           
Hit http://sgposd03.apac.bosch.com precise/main amd64 Packages
Hit http://sgposd03.apac.bosch.com precise/main i386 Packages
Ign http://sgposd03.apac.bosch.com precise/main TranslationIndex
Hit http://sgposd03.apac.bosch.com precise/partner amd64 Packages
Hit http://sgposd03.apac.bosch.com precise/partner i386 Packages
Ign http://sgposd03.apac.bosch.com precise/partner TranslationIndex
Ign http://sgposd03.apac.bosch.com ./ Translation-en_IN   
Ign http://sgposd03.apac.bosch.com ./ Translation-en
Ign http://sgposd03.apac.bosch.com precise/main Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise/main Translation-en
Ign http://sgposd03.apac.bosch.com precise/restricted Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise/restricted Translation-en
Ign http://sgposd03.apac.bosch.com precise/universe Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise/universe Translation-en
Ign http://sgposd03.apac.bosch.com precise-updates/main Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise-updates/main Translation-en
Ign http://sgposd03.apac.bosch.com precise-updates/restricted Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise-updates/restricted Translation-en
Ign http://sgposd03.apac.bosch.com precise-updates/universe Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise-updates/universe Translation-en
Ign http://sgposd03.apac.bosch.com precise-security/main Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise-security/main Translation-en
Ign http://sgposd03.apac.bosch.com precise-security/restricted Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise-security/restricted Translation-en
Ign http://sgposd03.apac.bosch.com precise-security/universe Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise-security/universe Translation-en
Ign http://sgposd03.apac.bosch.com precise/multiverse Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise/multiverse Translation-en
Ign http://sgposd03.apac.bosch.com precise/main Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise/main Translation-en
Ign http://sgposd03.apac.bosch.com precise/main Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise/main Translation-en
Ign http://sgposd03.apac.bosch.com precise/partner Translation-en_IN
Ign http://sgposd03.apac.bosch.com precise/partner Translation-en
W: Failed to fetch http://www.openfoam.org/download/ubuntu/dists/precise/Release.gpg  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://www.openfoam.org/download/ubuntu/dists/precise/main/binary-amd64/Packages  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://www.openfoam.org/download/ubuntu/dists/precise/main/binary-i386/Packages  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://www.openfoam.org/download/ubuntu/dists/precise/main/i18n/Translation-en_IN  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)

W: Failed to fetch http://www.openfoam.org/download/ubuntu/dists/precise/main/i18n/Translation-en  Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)

E: Some index files failed to download. They have been ignored, or old ones used instead.

so i downloaded openfoam221_0-1_i386.deb from source forge and wanted to install openFoam from the package.

after moving openfoam221_0-1_i386.deb to /var/cache/apt/archives/ i typed in the terminal
Code:

sudo dpkg --install openfoam221_0-1_i386.deb
but i got this error :
Code:

Selecting previously unselected package openfoam221:i386.
dpkg: error processing openfoam221_0-1_i386.deb (--install):
 openfoam221:i386 0-1 (Multi-Arch: no) is not co-installable with openfoam221:amd64 0-1 (Multi-Arch: no) which is currently installed
Errors were encountered while processing:
 openfoam221_0-1_i386.deb

so i tried to follow the instructions of this Link http://www.openfoam.org/download/source.php to install OF221.

but i had this problm :
Code:

No command 'setenv' found
I used this Link to solve the probleme ...but i am not able to use ./Allwmake

here what i did :

Code:

abm5kor@BMH301562:/opt/OpenFOAM$ setenv FOAM_INST_DIR /data/app/OpenFOAM
No command 'setenv' found, did you mean:
 Command 'netenv' from package 'netenv' (universe)
setenv: command not found
abm5kor@BMH301562:/opt/OpenFOAM$ sudo apt-get install tcsh
[sudo] password for abm5kor:
Reading package lists... Done
Building dependency tree     
Reading state information... Done
tcsh is already the newest version.
The following packages were automatically installed and are no longer required:
  python-configglue paraview-doc gir1.2-indicate-0.7 linux-headers-3.2.0-40 linux-headers-3.2.0-41 linux-headers-3.2.0-36
  firefox-globalmenu python-ubuntuone-storageprotocol libgl2ps0 python-protobuf libvtk5.8 python-vtk linux-headers-3.2.0-40-generic
  tcl8.5 python-twisted-names tk8.5 libpq5 python-support protobuf-compiler python-dirspec libprotoc7
  linux-headers-3.2.0-41-generic linux-headers-3.2.0-36-generic tcl-vtk libnetcdf6
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
abm5kor@BMH301562:/opt/OpenFOAM$ tcsh
BMH301562:/opt/OpenFOAM> setenv FOAM_INST_DIR /data/app/OpenFOAM
BMH301562:/opt/OpenFOAM> foamDotFile=$FOAM_INST_DIR/OpenFOAM-2.2.1/etc/cshrc
foamDotFile=/data/app/OpenFOAM/OpenFOAM-2.2.1/etc/cshrc: Command not found.
BMH301562:/opt/OpenFOAM> if ( -f $foamDotFile ) source $foamDotFile
foamDotFile: Undefined variable.
BMH301562:/opt/OpenFOAM> if ( -f $foamDotFile ) source $foamDotFile
foamDotFile: Undefined variable.
BMH301562:/opt/OpenFOAM> exit
exit
abm5kor@BMH301562:/opt/OpenFOAM$ if ( -f $foamDotFile ) source $foamDotFile
bash: syntax error near unexpected token `source'
abm5kor@BMH301562:/opt/OpenFOAM$ ./Allwmake.
bash: ./Allwmake.: No such file or directory
abm5kor@BMH301562:/opt/OpenFOAM$ cd OpenFOAM-2.2.1/
abm5kor@BMH301562:/opt/OpenFOAM/OpenFOAM-2.2.1$ ./Allwmake
./Allwmake: 4: ./Allwmake: wmakeCheckPwd: not found
Error: Current directory is not $WM_PROJECT_DIR
    The environment variables are inconsistent with the installation.
    Check the OpenFOAM entries in your dot-files and source them.
abm5kor@BMH301562:/opt/OpenFOAM/OpenFOAM-2.2.1$ cd ..
abm5kor@BMH301562:/opt/OpenFOAM$ ls
OpenFOAM-2.2.1  OpenFOAM-2.2.1.tgz  ThirdParty-2.2.1  ThirdParty-2.2.1.tgz

i don't know what should i do ......
SOS
need ur help
Thx:)

alexeym September 13, 2013 07:37

It seems that you have a problem with apt sources (or DNS):

Code:

Something wicked happened resolving 'www.openfoam.org:http' (-5 - No address associated with hostname)
Don't remember exactly where Ubuntu stores it, something like /etc/apt/sources.lst or /etc/apt/sources.lst.d. Can you post its content?

Mirage12 September 13, 2013 07:50

Hello alex :)

here :

deb http://www.openfoam.org/download/ubuntu precise main

what should i change in this file ?
Shoul i add
deb www.openfoam.org:http precise main
in the openfoam.list file ?
thx :)

Mirage12 September 13, 2013 09:00

SOS:confused::confused::confused::confused:

alexeym September 13, 2013 09:22

Quote:

Originally Posted by Mirage12 (Post 451531)
SOS:confused::confused::confused::confused:

1. There's a possibility that you had temporal problem with DNS and if you run apt-get update now everything will be OK.

2. If you'd like to install OpenFOAM compiling it from sources then do the bash part (i.e. source $HOME/OpenFOAM/OpenFOAM-2.2.1/etc/bashrc). AFAIK in Ubuntu by default you'll get bash as your shell. Even if you install tcsh it will not become default shell automatically.

Mirage12 September 13, 2013 09:27

what do you mean with :
Quote:

There's a possibility that you had temporal problem with DNS and if you run apt-get update now everything will be OK
Shoul i add
deb www.openfoam.org:http precise main
in the openfoam.list file ?

alexeym September 13, 2013 09:30

Quote:

Originally Posted by Mirage12 (Post 451539)
Shoul i add
deb www.openfoam.org:http precise main
in the openfoam.list file ?

No. The entry in the sources file is correct.
To be sure you can delete old file and create it again with something like:

Code:

$ sudo rm /etc/apt/sources.list.d/openfoam.list
$ sudo sh -c "echo deb http://www.openfoam.org/download/ubuntu $VERS main > /etc/apt/sources.list.d/openfoam.list"


Mirage12 September 13, 2013 09:41

i still have the same problem.... :eek:

wyldckat September 13, 2013 10:41

Greetings to all!

@Amin: To install a deb package directly, for example, run this command as root:
Code:

dpkg -i openfoam221_0-1_i386.deb
As for not accessing the outside network, it's likely that you are using VirtualBox, correct? Either that or your network connection has a constraint for not accessing outside of the internal network.

As for sourcing the "bashrc" file, here's some reading material: Advanced tips for working with the OpenFOAM shell environment

Best regards,
Bruno

Maimouna October 11, 2013 09:44

Ckeck if any error
 
1 Attachment(s)
Hi,
I just new in OpenFOAM.
I installed the latest version of OpenFOAM 2.2.1 and ParaView 3.12.0. Every thing was ok, but I am worry about running if it is working properly or not ( snapshot screen was attached). Could you please look at snapshot screen and let me know if any problem with running.

Cheers

wyldckat October 11, 2013 14:39

Greetings Maimouna and welcome to the forum!

From the screen-shot you shared, it seems to be working just fine.

Best regards,
Bruno

Maimouna October 13, 2013 07:03

Quote:

Originally Posted by wyldckat (Post 456418)
Greetings Maimouna and welcome to the forum!

From the screen-shot you shared, it seems to be working just fine.

Best regards,
Bruno

Dear wyldckat
many thanks for your reply. I hope everything will be fine.

Cheers

Maimouna October 13, 2013 10:35

Quote:

Originally Posted by Maimouna (Post 456642)
Dear wyldckat
many thanks for your reply. I hope everything will be fine.

Cheers

I would like to ask about OpenFoam videos. Where I can find some?
I found some in youtube. But are there any room of OpenFoam and how to use paraFoam in this forum?

Best regards

wyldckat October 13, 2013 14:43

Hi Maimouna,

The main OpenFOAM is here: http://www.cfd-online.com/Forums/openfoam/
From there you can see all of the sub-forums.

These threads explain how to use the forums:
And I know there was a thread about videos made in the effort to support science and engineering by the Indian government... ah, it's this one: http://www.cfd-online.com/Forums/ope...tutorials.html

Best regards,
Bruno

Sherlock_1812 November 28, 2013 03:48

Greetings Bruno,

I wanted to re-install OF2.2.2. So i uninstalled it by doing rm -rf openfoam222 (the same for paraview) in the /opt directory. When I try to install it again, it says
Code:

openfoam222 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Have I uninstalled it correctly? Did I miss something?

Do I need to change some other file?

Thanks in advance.

wyldckat November 29, 2013 15:15

Greetings Srivaths,

Yes, you uninstalled it incorrectly :). You should have used the same installation command, with the "remove" option instead of "install" ;)
In other words:
Code:

sudo apt-get remove openfoam222 paraviewopenfoam3120
Best regards,
Bruno

Sherlock_1812 November 30, 2013 02:53

Thanks Bruno. I did that and have started afresh.


All times are GMT -4. The time now is 11:32.