CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   wmake error swak4Foam in openfoam 2.1.1 (http://www.cfd-online.com/Forums/openfoam-installation/124348-wmake-error-swak4foam-openfoam-2-1-1-a.html)

sicfred October 2, 2013 16:07

wmake error swak4Foam in openfoam 2.1.1
 
Hi!

I'm trying to install swak4Foam in openfoam 2.1.1 in a ubuntu 10.04 machine.

After using the command ./Allwmake I received the next message:

Code:

elias@elias-laptop:/opt/openfoam211/src/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
Swak version is 0.2.4
Bison is version 2.4.1
Flex is version 2.5.35 (Minor version: 35)
OpenFOAM-version: Major 2 Minor 1 Patch 1 (-1 == x)
./Allwmake: línea 60: swak4FoamParsers/foamVersion4swak.H.tmp: Permiso denegado
No swak4FoamParsers/foamVersion4swak.H. Generated
mv: no se puede efectuar `stat' sobre «swak4FoamParsers/foamVersion4swak.H.tmp»: No existe el fichero o el directorio
mkdir: no se puede crear el directorio «linux64GccDPOpt»: Permiso denegado
/bin/sh: linux64GccDPOpt/options: No existe el fichero o el directorio
make: *** [linux64GccDPOpt/options] Error 1
/opt/openfoam211/wmake/MakefileFiles:40: linux64GccDPOpt/options: No existe el fichero o el directorio
make: *** No hay ninguna regla para construir el objetivo «linux64GccDPOpt/options».  Alto.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created in /opt/openfoam211/src/swak4Foam/Libraries/swak4FoamParsers
Parser library did not compile OK. No sense continuing as everything else depends on it
Requirements for Library not satisfied. I see no sense in going on

Any help please??

gschaider October 2, 2013 16:28

Quote:

Originally Posted by sicfred (Post 454753)
Hi!

I'm trying to install swak4Foam in openfoam 2.1.1 in a ubuntu 10.04 machine.

After using the command ./Allwmake I received the next message:

Code:

elias@elias-laptop:/opt/openfoam211/src/swak4Foam$ ./Allwmake
No 'swakConfiguration'. Python etc won't work
Checking swak4Foam-version and generating file
Swak version is 0.2.4
Bison is version 2.4.1
Flex is version 2.5.35 (Minor version: 35)
OpenFOAM-version: Major 2 Minor 1 Patch 1 (-1 == x)
./Allwmake: línea 60: swak4FoamParsers/foamVersion4swak.H.tmp: Permiso denegado
No swak4FoamParsers/foamVersion4swak.H. Generated
mv: no se puede efectuar `stat' sobre «swak4FoamParsers/foamVersion4swak.H.tmp»: No existe el fichero o el directorio
mkdir: no se puede crear el directorio «linux64GccDPOpt»: Permiso denegado
/bin/sh: linux64GccDPOpt/options: No existe el fichero o el directorio
make: *** [linux64GccDPOpt/options] Error 1
/opt/openfoam211/wmake/MakefileFiles:40: linux64GccDPOpt/options: No existe el fichero o el directorio
make: *** No hay ninguna regla para construir el objetivo «linux64GccDPOpt/options».  Alto.
wmake error: file 'Make/linux64GccDPOpt/objectFiles' could not be created in /opt/openfoam211/src/swak4Foam/Libraries/swak4FoamParsers
Parser library did not compile OK. No sense continuing as everything else depends on it
Requirements for Library not satisfied. I see no sense in going on

Any help please??

Why do Ubuntu-users always assume that everyone speaks their language? I'm really tempted to answer in german in such cases ....
I'm sure there is a way to switch the default locale to english, then reproduce the error then switch back to your language (I personally keep my terminal language to english: that way if I have a problem I can immediately google the error message).

Anyway: I guess "Permiso denegado" is spanish for "permission denied". It seems that you don't have write permissions to the directory. Probably because you unpacked it as root and are now trying to compile it as regular you. Either unpack the sources as you or change the ownership with the chown-command

sicfred October 2, 2013 17:56

That was fast!!!!
Sorry for the spanish text, I just changed it for future problems.
I did what you said "unpack the sources as no-root" and it worked, so thank you!!

I also want to thank you all the work you have done with swak4Foam and pyFoam, you are making openfoam a little bit more user friendly

nanavati January 23, 2015 06:05

Quote:

Originally Posted by gschaider (Post 454758)
Why do Ubuntu-users always assume that everyone speaks their language? I'm really tempted to answer in german in such cases ....
I'm sure there is a way to switch the default locale to english, then reproduce the error then switch back to your language (I personally keep my terminal language to english: that way if I have a problem I can immediately google the error message).

Anyway: I guess "Permiso denegado" is spanish for "permission denied". It seems that you don't have write permissions to the directory. Probably because you unpacked it as root and are now trying to compile it as regular you. Either unpack the sources as you or change the ownership with the chown-command


thanks a lot :)

i was also facing the same error while installing swak4Foam in OF-2.2.2

"permission denied"

as the package was unpacked as root user and i tried to build it as a local user.

later on i unpacked it as a local user and build was succesfull.

many thanks.


All times are GMT -4. The time now is 05:47.