CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Problem compiling Paraview (Thirdparty)

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 7, 2013, 16:48
Default Problem compiling Paraview (Thirdparty)
  #1
Senior Member
 
Tobi's Avatar
 
Tobias Holzmann
Join Date: Oct 2010
Location: Leoben (Austria)
Posts: 1,089
Blog Entries: 6
Rep Power: 19
Tobi will become famous soon enough
Send a message via ICQ to Tobi Send a message via Skype™ to Tobi
Hi all,

I try to compile paraview-3.12.0 which comes with the thirdparty.
While compilation I get the following error message:

Code:
-- Configuring development install...
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
OPENGL_gl_LIBRARY (ADVANCED)
    linked by target "vtkVolumeRendering" in directory /home/shor-ty/OpenFOAM/ThirdParty-2.2.x/ParaView-3.12.0/VTK/VolumeRendering
    linked by target "vtkWidgets" in directory /home/shor-ty/OpenFOAM/ThirdParty-2.2.x/ParaView-3.12.0/VTK/Widgets
    linked by target "vtkParallel" in directory /home/shor-ty/OpenFOAM/ThirdParty-2.2.x/ParaView-3.12.0/VTK/Parallel
    linked by target "vtkPVVTKExtensions" in directory /home/shor-ty/OpenFOAM/ThirdParty-2.2.x/ParaView-3.12.0/ParaViewCore/VTKExtensions
    linked by target "PointSprite_Rendering" in directory /home/shor-ty/OpenFOAM/ThirdParty-2.2.x/ParaView-3.12.0/Plugins/PointSprite/Rendering

-- Configuring incomplete, errors occurred!
Here is the first error I got in the logfile:
Code:
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /home/shor-ty/OpenFOAM/ThirdParty-2.2.x/platforms/linux64/gcc-4.7.2/bin/gcc
-- Check for working C compiler: /home/shor-ty/OpenFOAM/ThirdParty-2.2.x/platforms/linux64/gcc-4.7.2/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /home/shor-ty/OpenFOAM/ThirdParty-2.2.x/platforms/linux64/gcc-4.7.2/bin/g++
-- Check for working CXX compiler: /home/shor-ty/OpenFOAM/ThirdParty-2.2.x/platforms/linux64/gcc-4.7.2/bin/g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Found Git: /usr/bin/git
-- Determined Source Version from file : 3.12.0
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt4: /usr/bin/qmake (found suitable version "4.8.1", required is "4.6.0")
CMake Warning at CMakeLists.txt:110 (MESSAGE):
  Warning: You are using Qt 4.8.1.  Officially supported version is Qt 4.6

Thanks in advance
Tobi
Tobi is offline   Reply With Quote

Old   October 11, 2013, 18:30
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Tobi,

I don't know if you've already fixed this problem or not, but if not, I'm able to give a better suggestion/solution/fix if I knew which Linux Distribution and version you are using in this case

In addition, are you certain that you've already installed the correct graphics card drivers?

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   April 8, 2014, 15:21
Default
  #3
New Member
 
johny
Join Date: Jul 2010
Posts: 28
Rep Power: 7
johny is on a distinguished road
Hi Bruno,

Could you please help me out? I've the same problem as Tobi. Error messages are appended to this mail.

My linux version is

Code:
:~$ lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu Trusty Tahr (development branch)
Release:    14.04
Codename:    trusty
How do I know whether I've the right video drivers. Invoking the command

Code:
:~$ lshw -c video
WARNING: you should run this program as super-user.
  *-display               
       description: VGA compatible controller
       product: G96 [GeForce 9500 GT]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=nouveau latency=0
       resources: irq:43 memory:fd000000-fdffffff memory:e0000000-efffffff memory:fa000000-fbffffff ioport:cc00(size=128) memory:fea80000-feafffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
Cheers,
J



Code:
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
OPENGL_gl_LIBRARY (ADVANCED)
    linked by target "vtkVolumeRendering" in directory /home/rinoy/OpenFOAM/ThirdParty-2.2.0/ParaView-3.12.0/VTK/VolumeRendering
    linked by target "vtkWidgets" in directory /home/rinoy/OpenFOAM/ThirdParty-2.2.0/ParaView-3.12.0/VTK/Widgets
    linked by target "vtkParallel" in directory /home/rinoy/OpenFOAM/ThirdParty-2.2.0/ParaView-3.12.0/VTK/Parallel
    linked by target "vtkPVVTKExtensions" in directory /home/rinoy/OpenFOAM/ThirdParty-2.2.0/ParaView-3.12.0/ParaViewCore/VTKExtensions
    linked by target "PointSprite_Rendering" in directory /home/rinoy/OpenFOAM/ThirdParty-2.2.0/ParaView-3.12.0/Plugins/PointSprite/Rendering

-- Configuring incomplete, errors occurred!
    Starting make
make: *** No targets specified and no makefile found.  Stop.
Command exited with non-zero status 2
0.00user 0.00system 0:00.00elapsed 75%CPU (0avgtext+0avgdata 1048maxresident)k
0inputs+0outputs (0major+314minor)pagefaults 0swaps
    Done make
    Installing ParaView to /home/rinoy/OpenFOAM/ThirdParty-2.2.0/platforms/linux64Gcc45/paraview-3.12.0
make: *** No rule to make target `install'.  Stop.
    ---
    Installation complete for paraview-3.12.0
    Set environment variables:

        export ParaView_DIR=/home/rinoy/OpenFOAM/ThirdParty-2.2.0/platforms/linux64Gcc45/paraview-3.12.0
        export PATH=$ParaView_DIR/bin:$PATH
        export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.12
    ---

Done
Quote:
Originally Posted by wyldckat View Post
Hi Tobi,

I don't know if you've already fixed this problem or not, but if not, I'm able to give a better suggestion/solution/fix if I knew which Linux Distribution and version you are using in this case

In addition, are you certain that you've already installed the correct graphics card drivers?

Best regards,
Bruno

Last edited by wyldckat; April 8, 2014 at 15:36. Reason: Added [CODE][/CODE]
johny is offline   Reply With Quote

Old   April 8, 2014, 15:41
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Johny,

You're using the Nouveau drivers, which are open source. I don't know how good they are nowadays, but my suggestion is that you install the NVidia drivers (not open source ), which officially support 3D performance with NVidia graphics cards.

After you've managed to install the NVidia drivers, the makeParaView or makeParaView4 scripts should work as intended.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   April 10, 2014, 12:43
Default
  #5
New Member
 
johny
Join Date: Jul 2010
Posts: 28
Rep Power: 7
johny is on a distinguished road
Hi Bruno,

Thanks for the reply. Its getting more confusing when it comes to find the right driver for my computer. Could you please let me know which one is the right NVIDIA driver for my processor and version of ubuntu. And if you direct me where to find it would also be great help.

~$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G96 [GeForce 9500 GT] (rev a1)

~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
Codename: trusty

Looking forward to your reply.

Cheers,
J




Quote:
Originally Posted by wyldckat View Post
Greetings Johny,

You're using the Nouveau drivers, which are open source. I don't know how good they are nowadays, but my suggestion is that you install the NVidia drivers (not open source ), which officially support 3D performance with NVidia graphics cards.

After you've managed to install the NVidia drivers, the makeParaView or makeParaView4 scripts should work as intended.

Best regards,
Bruno
johny is offline   Reply With Quote

Old   April 10, 2014, 16:10
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Johny,

Ubuntu 14.04 is still in beta stage, so it's probably not yet very stable.
But anyway, this page should explain how to install the official NVidia drivers for Ubuntu: http://askubuntu.com/a/307478
The actual driver model needed for your card should automatically be installed this way.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   April 11, 2014, 05:25
Default
  #7
New Member
 
johny
Join Date: Jul 2010
Posts: 28
Rep Power: 7
johny is on a distinguished road
Hi Bruno,
Thanks again for the quick reply. It was pretty difficult to still get the drivers installed and as you said I thought it would be a better idea to start do do the whole process in a new installation.
I installed the new stable version of ubuntu

Code:
:~$ lsb-release -a
No command 'lsb-release' found, did you mean:
 Command 'lsb_release' from package 'lsb-release' (main)
lsb-release: command not found
rinoy@bryan:~$ lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 13.10
Release:    13.10
Codename:    saucy
Installed the nvidia drivers picking up the instruction from the link you provided


Code:
~$ lshw -c video
WARNING: you should run this program as super-user.
  *-display               
       description: VGA compatible controller
       product: G96 [GeForce 9500 GT]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:16 memory:fd000000-fdffffff memory:e0000000-efffffff memory:fa000000-fbffffff ioport:cc00(size=128) memory:fea80000-feafffff
WARNING: output may be incomplete or inaccurate, you should run this program as super-user.
Now I was following the instructions in the link below to install OpenFOAM
http://openfoamwiki.net/index.php/In...M-2.2.0/Ubuntu

After completing the step 8 with the command
wmSET $FOAM_SETTINGS

I still get the error as below

Code:
Warning in /home/user/OpenFOAM/OpenFOAM-2.2.0/etc/config/settings.sh:
    Cannot find /home/user/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/gcc-4.5.2 installation.
    Please install this compiler version or if you wish to use the system compiler,
    change the 'foamCompiler' setting to 'system'
I found the gcc-4.5.2 was located in the folder /home/user/OpenFOAM/ThirdParty-2.2.0/ INSTEAD OF /home/user/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/
I moved the gcc-4.5.2 to /home/user/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/

And then as expected there was no error and continued till building the openFOAM without any issues.

The build log has errors(seeming due to the change I made above) as follows...
Code:
 ollect2: error: ld returned 1 exit status
make[2]: *** [/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc45DPOpt/bin/MRFMultiphaseInterFoam] Error 1
make[1]: *** [multiphaseInterFoam] Error 2
/home/rinoy/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/gcc-4.5.2/bin/ld: this linker was not configured to use sysroots
collect2: error: ld returned 1 exit status
make[2]: *** [/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc45DPOpt/bin/twoLiquidMixingFoam] Error 1
make[1]: *** [twoLiquidMixingFoam] Error 2
+ wmake libso phaseModel
/home/rinoy/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/gcc-4.5.2/bin/ld: this linker was not configured to use sysroots
collect2: error: ld returned 1 exit status
make[2]: *** [/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc45DPOpt/lib/libphaseModel.so] Error 1
make[2]: Target `libso' not remade because of errors.
+ wmake libso interfacialModels
/home/rinoy/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/gcc-4.5.2/bin/ld: this linker was not configured to use sysroots
collect2: error: ld returned 1 exit status
make[2]: *** [/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc45DPOpt/lib/libEulerianInterfacialModels.so] Error 1
make[2]: Target `libso' not remade because of errors.
+ wmake libso kineticTheoryModels
/home/rinoy/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/gcc-4.5.2/bin/ld: this linker was not configured to use sysroots
collect2: error: ld returned 1 exit status
make[2]: *** [/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc45DPOpt/lib/libkineticTheoryModel.so] Error 1
make[2]: Target `libso' not remade because of errors.
+ wmake
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -O3  -DNoRepository -ftemplate-depth-100 -I/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/src/finiteVolume/lnInclude -I/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/src/transportModels/incompressible/lnInclude -IturbulenceModel -IkineticTheoryModels/lnInclude -IinterfacialModels/lnInclude -IphaseModel/lnInclude -Iaveraging -IlnInclude -I. -I/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/src/OpenFOAM/lnInclude -I/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/src/OSspecific/POSIX/lnInclude   -fPIC -Xlinker --add-needed -Xlinker --no-as-needed Make/linux64Gcc45DPOpt/twoPhaseEulerFoam.o -L/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc45DPOpt/lib \
             -lEulerianInterfacialModels -lfiniteVolume -lmeshTools -lincompressibleTransportModels -lphaseModel -lkineticTheoryModel -lOpenFOAM -ldl   -lm -o /home/rinoy/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc45DPOpt/bin/twoPhaseEulerFoam
/home/rinoy/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/gcc-4.5.2/bin/ld: this linker was not configured to use sysroots
collect2: error: ld returned 1 exit status
make[2]: *** [/home/rinoy/OpenFOAM/OpenFOAM-2.2.0/platforms/linux64Gcc45DPOpt/bin/twoPhaseEulerFoam] Error 1
make[1]: *** [twoPhaseEulerFoam] Error 2
make[1]: Target `application' not remade because of errors.
make: *** [multiphase] Error 2
make: Target `application' not remade because of errors.
Could you please tell me how to proceed now?

Cheers,
J


Quote:
Originally Posted by wyldckat View Post
Hi Johny,

Ubuntu 14.04 is still in beta stage, so it's probably not yet very stable.
But anyway, this page should explain how to install the official NVidia drivers for Ubuntu: http://askubuntu.com/a/307478
The actual driver model needed for your card should automatically be installed this way.

Best regards,
Bruno

Last edited by wyldckat; April 13, 2014 at 15:24. Reason: Added [CODE][/CODE]
johny is offline   Reply With Quote

Old   April 13, 2014, 15:32
Default
  #8
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Johny,

I'm glad the NVidia drivers have been installed with success. But I think you got lost in the instructions for installing OpenFOAM, because:
Quote:
Originally Posted by johny View Post
Now I was following the instructions in the link below to install OpenFOAM
http://openfoamwiki.net/index.php/In...M-2.2.0/Ubuntu

After completing the step 8 with the command
wmSET $FOAM_SETTINGS

I still get the error as below

Code:
Warning in /home/user/OpenFOAM/OpenFOAM-2.2.0/etc/config/settings.sh:
    Cannot find /home/user/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/gcc-4.5.2 installation.
    Please install this compiler version or if you wish to use the system compiler,
    change the 'foamCompiler' setting to 'system'
I found the gcc-4.5.2 was located in the folder /home/user/OpenFOAM/ThirdParty-2.2.0/ INSTEAD OF /home/user/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/
I moved the gcc-4.5.2 to /home/user/OpenFOAM/ThirdParty-2.2.0/platforms/linux64/
  1. You're using Ubuntu 13.10, therefore you should be following the instructions that start at the respective section of the same name! But from your description, you accidentally followed the instructions that are meant for Ubuntu 10.04!!
  2. I suggest that you go for OpenFOAM 2.2.2, instead of 2.2.0: http://openfoamwiki.net/index.php/In...u#Ubuntu_13.10
  3. If the instructions don't mention anything about moving "gcc-4.5.2", then you should not have move it either
    Because what you actually did was move the source code folder and not the installation of GCC toolkit.
If you follow the instructions on the section "Ubuntu 13.10", you should not have any of these problems and possibly no problems whatsoever!
Please be very careful in following the instructions, since any mistake, no matter how small, can result it not reaching a successful installation

You might ask why this is so hard and detailed. The answer is simple: because OpenFOAM is at a similar level of detail, therefore you should learn to keep a very close attention to all details when installing and using OpenFOAM

Best regards,
Bruno

Last edited by wyldckat; April 13, 2014 at 16:07. Reason: fixed typo
wyldckat is offline   Reply With Quote

Old   April 15, 2014, 14:56
Default
  #9
New Member
 
johny
Join Date: Jul 2010
Posts: 28
Rep Power: 7
johny is on a distinguished road
Hi Bruno,

The complete OF installation works now :-)
Thanks a lot.

Cheers,
J



Quote:
Originally Posted by wyldckat View Post
Hi Johny,

I'm glad the NVidia drivers have been installed with success. But I think you got lost in the instructions for installing OpenFOAM, because:

  1. You're using Ubuntu 13.10, therefore you should be following the instructions that start at the respective section of the same name! But from your description, you accidentally followed the instructions that are meant for Ubuntu 10.04!!
  2. I suggest that you go for OpenFOAM 2.2.2, instead of 2.2.0: http://openfoamwiki.net/index.php/In...u#Ubuntu_13.10
  3. If the instructions don't mention anything about moving "gcc-4.5.2", then you should not have move it either
    Because what you actually did was move the source code folder and not the installation of GCC toolkit.
If you follow the instructions on the section "Ubuntu 13.10", you should not have any of these problems and possibly no problems whatsoever!
Please be very careful in following the instructions, since any mistake, no matter how small, can result it not reaching a successful installation

You might ask why this is so hard and detailed. The answer is simple: because OpenFOAM is at a similar level of detail, therefore you should learn to keep a very close attention to all details when installing and using OpenFOAM

Best regards,
Bruno
johny is offline   Reply With Quote

Old   April 16, 2014, 22:31
Default
  #10
New Member
 
johny
Join Date: Jul 2010
Posts: 28
Rep Power: 7
johny is on a distinguished road
Hi Bruno,

I got yet another problem. Right after my installation I had opened an stl geometry and viewed it properly in paraview. I don't know what changes I made, but now I simply can't view the same stl file. The file opens and instead of a 3D geometry I see just a line. I'm sure its some settings issue. Could you please provide some insight? Please see the screenshot.

Cheers,
J








Quote:
Originally Posted by johny View Post
Hi Bruno,

The complete OF installation works now :-)
Thanks a lot.

Cheers,
J
Attached Images
File Type: jpg screenshot.jpg (40.1 KB, 2 views)
johny is offline   Reply With Quote

Old   April 17, 2014, 07:59
Default
  #11
New Member
 
johny
Join Date: Jul 2010
Posts: 28
Rep Power: 7
johny is on a distinguished road
Hi Bruno,

I figured it out that the stl file was in the plain text format and after conversion to binary it worked. But still wondering how it worked couple of days ago after which the file was never altered. Anyway now it works.

Cheers,
J



Quote:
Originally Posted by johny View Post
Hi Bruno,

The complete OF installation works now :-)
Thanks a lot.

Cheers,
J
johny is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem switching from terminal to paraView Maxime Thomas OpenFOAM Paraview & paraFoam 10 October 4, 2014 10:59
Problem with paraView starting PS87 OpenFOAM Paraview & paraFoam 1 August 2, 2012 15:28
Paraview fliter problem (surface flow) (segmentation fault) maysmech OpenFOAM 1 October 6, 2011 11:01
paraview split screen problem ziemowitzima OpenFOAM Paraview & paraFoam 1 March 16, 2011 15:07
Problem with Paraview graphics Ronnfors OpenFOAM 8 November 4, 2009 13:49


All times are GMT -4. The time now is 14:15.