CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OF 2.2.1 installation error on dependencies in Ubuntu 12.04 (http://www.cfd-online.com/Forums/openfoam-installation/124591-2-2-1-installation-error-dependencies-ubuntu-12-04-a.html)

immortality October 8, 2013 18:13

OF 2.2.1 installation error on dependencies in Ubuntu 12.04
 
this error is shown when I want to install 2.2.1 version of OF.
Code:

ehsan@Ehsan:~$ sudo apt-get install openfoam221
Reading package lists... Done
Building dependency tree     
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 openfoam221 : Depends: g++ but it is not installable
              Depends: libreadline-dev but it is not installable
              Depends: libopenmpi1.3 but it is not going to be installed
              Depends: libptscotch-5.1 but it is not going to be installed
              Depends: flex
              Depends: libscotch-dev but it is not going to be installed
              Depends: libopenmpi-dev but it is not going to be installed
              Depends: libxt-dev but it is not going to be installed
              Depends: openmpi-bin but it is not going to be installed
              Recommends: libptscotch-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

how can solve broken packages?

skyinventorbt October 9, 2013 00:25

OpenFOAM 2.2.1 for Ubuntu 12.04
 
I have installed and found this way is best for Ubuntu12.04 :)

Simple solution for Ubuntu 12.04 !!

Based on architecture i.e. u must have 64bit so download these two
-------------------------------------------------------------------------------------------------------------
http://www.openfoam.org/download/ubu..._0-1_amd64.deb
---------------------------------------------------------------------------------------------------------------
http://www.openfoam.org/download/ubu..._0-1_amd64.deb
----------------------------------------------------------------------------------------------------------------

Use this syntax to install(In terminal type and press enter)
  • dpkg -i openfoam221_0-1_amd64.deb
  • dpkg -i paraviewopenfoam3120_0-1_amd64.deb
--
KANNAN

immortality October 9, 2013 02:37

hi Kannan
Thanks for quick reply,
Can install paravaiew 14 instead of 13?

immortality October 9, 2013 06:09

I followed what you said,but it has some troubles:
Code:

root@Ehsan:~/Desktop# dpkg -i openfoam221_0-1_amd64.deb
Selecting previously unselected package openfoam221.
(Reading database ... 183847 files and directories currently installed.)
Unpacking openfoam221 (from openfoam221_0-1_amd64.deb) ...
dpkg: dependency problems prevent configuration of openfoam221:
 openfoam221 depends on csh; however:
  Package csh is not installed.
 openfoam221 depends on g++; however:
  Package g++ is not installed.
 openfoam221 depends on libreadline-dev; however:
  Package libreadline-dev is not installed.
 openfoam221 depends on libopenmpi1.3; however:
  Package libopenmpi1.3 is not installed.
 openfoam221 depends on libptscotch-5.1; however:
  Package libptscotch-5.1 is not installed.
 openfoam221 depends on libscotch-5.1; however:
  Package libscotch-5.1 is not installed.
 openfoam221 depends on binutils-dev; however:
  Package binutils-dev is not installed.
 openfoam221 depends on flex; however:
  Package flex is not installed.
 openfoam221 depends on libscotch-dev; however:
  Package libscotch-dev is not installed.
 openfoam221 depends on libopenmpi-dev; however:
  Package libopenmpi-dev is not installed.
 openfoam221 depends on libxt-dev; however:
  Package libxt-dev is not installed.
 openfoam221 depends on openmpi-bin; however:
  Package openmpi-bin is not installed.
dpkg: error processing openfoam221 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 openfoam221


skyinventorbt October 9, 2013 07:36

Dear Eshan,
Yesterday one of my friend(Who does not know what OpenFOAM is and wants to learn it) also installed by the method I said. He did not find any error like this, as he said.

I never use paraview from the second package i.e. paraviewopenfoam221.
Instead I use paraview 4.0.1(Latest Version)

Please see this link

http://askubuntu.com/questions/14024...t-dependencies

--
KANNAN

immortality October 9, 2013 10:46

thanks,OpenFOAM installed correctly but paraview shows some errors:
Code:

root@Ehsan:~/Desktop# dpkg -i paraviewopenfoam3120_0-1_amd64.deb
Selecting previously unselected package paraviewopenfoam3120.
(Reading database ... 246741 files and directories currently installed.)
Unpacking paraviewopenfoam3120 (from paraviewopenfoam3120_0-1_amd64.deb) ...
dpkg: dependency problems prevent configuration of paraviewopenfoam3120:
 paraviewopenfoam3120 depends on qt4-dev-tools; however:
  Package qt4-dev-tools is not installed.
dpkg: error processing paraviewopenfoam3120 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 paraviewopenfoam3120


immortality October 9, 2013 11:19

I used this command:
Code:

sudo apt-get -f install
now the error on paraview is this:
Code:

root@Ehsan:~# dpkg -i paraviewopenfoam3120_0-1_amd64.deb
dpkg: error processing paraviewopenfoam3120_0-1_amd64.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 paraviewopenfoam3120_0-1_amd64.deb

is there any comment?

skyinventorbt October 10, 2013 00:32

qt4 using apt-get
 
Quote:

Originally Posted by immortality (Post 455952)
thanks,OpenFOAM installed correctly but paraview shows some errors:
Code:

root@Ehsan:~/Desktop# dpkg -i paraviewopenfoam3120_0-1_amd64.deb
Selecting previously unselected package paraviewopenfoam3120.
(Reading database ... 246741 files and directories currently installed.)
Unpacking paraviewopenfoam3120 (from paraviewopenfoam3120_0-1_amd64.deb) ...
dpkg: dependency problems prevent configuration of paraviewopenfoam3120:
 paraviewopenfoam3120 depends on qt4-dev-tools; however:
  Package qt4-dev-tools is not installed.
dpkg: error processing paraviewopenfoam3120 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 paraviewopenfoam3120


Dear Eshan,

You can install qt4-dev-tools using apt-get
and then try
dpkg -i paraviewopenfoam3120_0-1_amd64.deb

--
KANNAN

wyldckat October 19, 2013 15:17

Greetings to all!

Most of the installation problems reported on this thread should be fixed if you follow the instructions on this post: http://www.cfd-online.com/Forums/lou...tml#post457831 - post #6

Best regards,
Bruno


All times are GMT -4. The time now is 07:30.