CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   OpenSUSE OpenFOAM-2.2.2-1.x86_64.rpm fails (

DrUlMe October 21, 2013 12:30

OpenSUSE OpenFOAM-2.2.2-1.x86_64.rpm fails
Sorry, for such an error message,
but on my machines the installation for OpenSUSE 12.3 / 64bit fails:
sudo rpm -i
results in a:
error: unpacking of archive failed on file /opt/OpenFOAM-2.2.2/OpenFOAM-2.2.2.gtgz;52644682: cpio: read failed - Keine Daten verfügbar
error: OpenFOAM-2.2.2-1.x86_64: install failed

I tried several hosts for download (all the same size) and i got the content of the rpm.
Perhaps something was not included, as it should be. Fedora rpm is 10MB bigger.

Thanks in advance


wyldckat October 21, 2013 16:36

Greetings Ulf and welcome to the forum!

:eek: Well something went very wrong on their side. I've reported this just now here:

If you're in a hurry to get OpenFOAM 2.2.2 to work on openSUSE 12.3, I suggest you try these instructions:

Best regards,

DrUlMe October 22, 2013 12:35

i586 works now - x86_64 still not to install
Thanks Bruno (and Sergio and Henry),
that was very fast!

The i586 suse version seems to be ok and installs.
But but the x86_64 has still an issue, only later:


rpm2cpio  OpenFOAM-2.2.2-1.x86_64.rpm | cpio -t
  cpio: verfrühtes Ende der Datei (file ends to early)

I tried to upgrade the issue in Mantis, but found no possibity to change it without getting a new entry. So i try it this way again, sorry.:rolleyes:

Best regards


wyldckat October 22, 2013 17:30

Hi Ulf,

That bug report was closed and only the original poster can reopen it :(

I was able to reproduce the same error you got! Feel free to create a new bug report yourself, so that you can reopen it later on, if necessary ;)

Best regards,

DrUlMe October 22, 2013 19:20

Thanks Bruno,

this issue has now an own bug report:

All times are GMT -4. The time now is 16:20.