CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFOAM 2.2.2 on a server (no X) (http://www.cfd-online.com/Forums/openfoam-installation/125325-openfoam-2-2-2-server-no-x.html)

Aco October 23, 2013 08:39

OpenFOAM 2.2.2 on a server (no X)
 
Hi,
I'm having trouble compiling OpenFOAM and ParaView on a mchine with no Qt and X. I want to set OpenFOAM and ParaView on the server and access the results via ParaView remotely.
I'm following the instructions here: http://www.openfoam.org/download/source.php
OpenFOAM builds OK. The problem arises when trying to compile ParaView. In $WM_THIRD_PARTY_DIR/makeParaView I set withQT=false. It then doesn't build the gui support. The problem arises when it starts to build TestingDemo. Here's the output:
Code:

Scanning dependencies of target TestingDemo
[ 86%] Building CXX object Qt/Testing/Examples/CMakeFiles/TestingDemo.dir/TestingDemo.cxx.o
[ 86%] Building CXX object Qt/Testing/Examples/CMakeFiles/TestingDemo.dir/moc_TestingDemo.cxx.o
Linking CXX executable ../../../bin/TestingDemo
[ 86%] Built target TestingDemo
[ 86%] Building CXX object Qt/Widgets/CMakeFiles/pqWidgets.dir/pqHelpWindow.cxx.o
/temp/saso/OpenFOAM/ThirdParty-2.2.2/ParaView-3.12.0/Qt/Widgets/pqHelpWindow.cxx:36:23: fatal error: QHelpEngine: No such file or directory
compilation terminated.
make[2]: *** [Qt/Widgets/CMakeFiles/pqWidgets.dir/pqHelpWindow.cxx.o] Error 1
make[1]: *** [Qt/Widgets/CMakeFiles/pqWidgets.dir/all] Error 2
make: *** [all] Error 2
    ---
    Installation complete for paraview-3.12.0
    Set environment variables:

        export ParaView_DIR=/temp/saso//OpenFOAM/ThirdParty-2.2.2/platforms/linux64Gcc/paraview-3.12.0
        export PATH=$ParaView_DIR/bin:$PATH
        export PV_PLUGIN_PATH=$FOAM_LIBBIN/paraview-3.12
    ---

Done

It's trying to access things which aren't being compiled.
What am I to do?

Thanks,
Sasha

Tobi October 23, 2013 10:17

Hi Sasha,

for the GUI I think PV needs the QT libraries.
You can compile it by yourself and set the path to it.

I would use the source code of the official homepage or the binaries.

Regards
Tobi

Aco October 23, 2013 11:28

Quote:

Originally Posted by Tobi (Post 458549)
for the GUI I think PV needs the QT libraries.
You can compile it by yourself and set the path to it.

That's the thing. I don't want to compile the GUI on the server. I'll use the GUI on the local machine.

Regards,
Sasha

Tobi October 23, 2013 12:15

Hi,

so you would compile PV on the server use the GUI on your local machine?

Why dont you compile PV with QT on your local machine ? (thats the way I do)

Aco October 23, 2013 12:31

I'd compile PV on both (remote and local) and run it as server/client. If I'd compile only on local then I'd have to copy OpenFOAM files back and forth all the time to view the results.

Regards,
Sasha

Tobi October 24, 2013 12:34

Hi Sasha,

if you solve this problem please let me know how to do it.

wyldckat October 26, 2013 14:56

Greetings to all!

I haven't done this in a long time (since 1.6.x). And I know I saw a report on the bug tracker about this... ah, here we go: http://www.openfoam.org/mantisbt/view.php?id=793 (edit: changes necessary are shown in the "Steps To Reproduce" section)

I'm going to try and have a go at this today or tomorrow and I'll report back.

Best regards,
Bruno

wyldckat October 27, 2013 05:11

Report part 1:
  • I've tested on a virtual machine with Ubuntu 12.04 i686 and used the following settings at the end of the file "etc/tools/ParaViewFunctions":
    Code:

            addCMakeVariable  "VTK_OPENGL_HAS_OSMESA=ON"
            //addCMakeVariable  "OSMESA_INCLUDE_DIR=$MESA_INCLUDE"
            //addCMakeVariable  "OSMESA_LIBRARY=$MESA_LIBRARY"

            addCMakeVariable  "PARAVIEW_BUILD_QT_GUI=OFF"
            //addCMakeVariable  "OPENGL_INCLUDE_DIR=/usr/include/GL"
            addCMakeVariable  "OPENGL_gl_LIBRARY="
            //addCMakeVariable  "OPENGL_glu_LIBRARY=/usr/lib64/lib/libGLU.so"
            addCMakeVariable  "VTK_USE_X=OFF"

    This way CMake did the effort of finding the necessary libraries, although the entry "OPENGL_gl_LIBRARY" must be defined as empty, as per indication here: http://vtk.org/Bug/view.php?id=12620
  • I used the following command:
    Code:

    ./makeParaView -mesa-lib /usr/lib/i386-linux-gnu/libOSMesa.so -mesa-include /usr/include/GL -no-qt > make.log 2>&1
    This way I kept a record of the build process inside the file "make.log".
I'll edit this post once I have finished building OpenFOAM 2.2.2 and tested the reported bug at http://www.openfoam.org/mantisbt/view.php?id=793

------------------------------------

Report part 2:
Follow the instructions on my comment on the bug report - http://www.openfoam.org/mantisbt/view.php?id=793 - and you're good to go!

Aco October 28, 2013 10:09

Thank you for this Bruno.

Regards,
Sasha


All times are GMT -4. The time now is 07:57.