CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

bashrc error for OpenFOAM-1.6-ext

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By Maimouna

Reply
 
LinkBack Thread Tools Display Modes
Old   December 30, 2013, 11:33
Default bashrc error for OpenFOAM-1.6-ext
  #1
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Dear foamers,

I worked in two versions of OpenFOAM (OF-2.2.2 and OF-1.6-ext). They were working fine. But the problem that I faced two days ago was with OF-1.6-ext bashrc, when I started terminal with aliasis of16ext directly it gives me this error
bash: /home/maimouna/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc: No such file or directory
I tried to change it many times. The aliasis of222 works fine but the problem with of16ext.

I got this problem after I tried to install foam-extend-3.0. Even I commit
# source $HOME/OpenFOAM/foam-extend-3.0/etc/bashrc.

The problem is still there. I didn't change anything in bashrc file.
My bashrc file is attacled.

Regards
Maimouna is offline   Reply With Quote

Old   December 30, 2013, 11:36
Default
  #2
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Sorry, I got error in attachement. Anyway, this is my bashrc file

Code:
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# ... or force ignoredups and ignorespace
HISTCONTROL=ignoredups:ignorespace

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi





 # enable autocomplete in gnuplot
alias gnuplot="rlwrap -a -c -b\"\\\"\\\"\\\'\\\'\" gnuplot" 


# source /opt/openfoam222/etc/bashrc
# source $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc

 alias of222='. /opt/openfoam222/etc/bashrc'
 alias of16ext='. $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc'
 alias paraFoam='paraFoam -builtin'



# source /home/maimouna/OpenFOAMExt/OpenFOAM-1.6-ext/etc/bashrc
# /home/maimouna/OpenFOAMExt/OpenFOAM-1.6-ext/ThirdParty/packages/scotch-5.1.10b
# export PV_PLUGIN_PATH=/opt/openfoam210/platforms/linux64GccDPOpt/lib/paraview-3.12
# source $HOME/OpenFOAM/foam-extend-3.0/etc/bashrc

Last edited by wyldckat; December 30, 2013 at 12:17. Reason: Added [CODE][/CODE]
Maimouna is offline   Reply With Quote

Old   December 30, 2013, 12:19
Default
  #3
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Maimouna,
  1. What were the exacts steps you've taken to try and install foam-extend-3.0?
  2. Does the folder "/home/maimouna/OpenFOAM/OpenFOAM-1.6-ext" still exist?
Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   December 31, 2013, 06:48
Default
  #4
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

1. to install foam-extend-3.0, I followed steps given in
http://openfoamwiki.net/index.php/Installation/Linux/foam-extend-3.0/Ubuntu#Ubuntu_12.04

2. Yes, the folder "/home/maimouna/OpenFOAM/OpenFOAM-1.6-ext" still exists, but not working. It gives error that posted in #1.

Regards
Maimouna is offline   Reply With Quote

Old   December 31, 2013, 14:27
Default
  #5
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Maimouna,

I think you caught the instructions while I was still preparing them. At the beginning of the instructions there was a warning text indicating that the instructions were still being written

And it's possible that you followed the instructions without working on a new terminal with a clean environment, which could have lead to the damaged installation.

Right now, the instructions for foam-extend-3.0 are finished and tested, although I still am going to do some adjustments to them. But you can already follow them now: http://openfoamwiki.net/index.php/In...u#Ubuntu_12.04


By the way, does this file exist:
Code:
/home/maimouna/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc
? Because if it doesn't, then that's why it's not working.

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   January 1, 2014, 10:12
Default
  #6
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

/home/maimouna/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc exists.
I committed
Code:
# source /home/maimouna/foam/foam-extend-3.0/etc/bashrc
but the bash error still there.

Code:
bash: /home/maimouna/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc: No such file or directory.
My bashrc file is shown below
Code:
# ~/.bashrc: executed by bash(1) for non-login shells.
# see /usr/share/doc/bash/examples/startup-files (in the package bash-doc)
# for examples

# If not running interactively, don't do anything
[ -z "$PS1" ] && return

# don't put duplicate lines in the history. See bash(1) for more options
# ... or force ignoredups and ignorespace
HISTCONTROL=ignoredups:ignorespace

# append to the history file, don't overwrite it
shopt -s histappend

# for setting history length see HISTSIZE and HISTFILESIZE in bash(1)
HISTSIZE=1000
HISTFILESIZE=2000

# check the window size after each command and, if necessary,
# update the values of LINES and COLUMNS.
shopt -s checkwinsize

# make less more friendly for non-text input files, see lesspipe(1)
[ -x /usr/bin/lesspipe ] && eval "$(SHELL=/bin/sh lesspipe)"

# set variable identifying the chroot you work in (used in the prompt below)
if [ -z "$debian_chroot" ] && [ -r /etc/debian_chroot ]; then
    debian_chroot=$(cat /etc/debian_chroot)
fi

# set a fancy prompt (non-color, unless we know we "want" color)
case "$TERM" in
    xterm-color) color_prompt=yes;;
esac

# uncomment for a colored prompt, if the terminal has the capability; turned
# off by default to not distract the user: the focus in a terminal window
# should be on the output of commands, not on the prompt
#force_color_prompt=yes

if [ -n "$force_color_prompt" ]; then
    if [ -x /usr/bin/tput ] && tput setaf 1 >&/dev/null; then
    # We have color support; assume it's compliant with Ecma-48
    # (ISO/IEC-6429). (Lack of such support is extremely rare, and such
    # a case would tend to support setf rather than setaf.)
    color_prompt=yes
    else
    color_prompt=
    fi
fi

if [ "$color_prompt" = yes ]; then
    PS1='${debian_chroot:+($debian_chroot)}\[\033[01;32m\]\u@\h\[\033[00m\]:\[\033[01;34m\]\w\[\033[00m\]\$ '
else
    PS1='${debian_chroot:+($debian_chroot)}\u@\h:\w\$ '
fi
unset color_prompt force_color_prompt

# If this is an xterm set the title to user@host:dir
case "$TERM" in
xterm*|rxvt*)
    PS1="\[\e]0;${debian_chroot:+($debian_chroot)}\u@\h: \w\a\]$PS1"
    ;;
*)
    ;;
esac

# enable color support of ls and also add handy aliases
if [ -x /usr/bin/dircolors ]; then
    test -r ~/.dircolors && eval "$(dircolors -b ~/.dircolors)" || eval "$(dircolors -b)"
    alias ls='ls --color=auto'
    #alias dir='dir --color=auto'
    #alias vdir='vdir --color=auto'

    alias grep='grep --color=auto'
    alias fgrep='fgrep --color=auto'
    alias egrep='egrep --color=auto'
fi

# some more ls aliases
alias ll='ls -alF'
alias la='ls -A'
alias l='ls -CF'

# Alias definitions.
# You may want to put all your additions into a separate file like
# ~/.bash_aliases, instead of adding them here directly.
# See /usr/share/doc/bash-doc/examples in the bash-doc package.

if [ -f ~/.bash_aliases ]; then
    . ~/.bash_aliases
fi

# enable programmable completion features (you don't need to enable
# this, if it's already enabled in /etc/bash.bashrc and /etc/profile
# sources /etc/bash.bashrc).
if [ -f /etc/bash_completion ] && ! shopt -oq posix; then
    . /etc/bash_completion
fi





 # enable autocomplete in gnuplot
alias gnuplot="rlwrap -a -c -b\"\\\"\\\"\\\'\\\'\" gnuplot" 


# source /opt/openfoam222/etc/bashrc
# source $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc

 alias of222='. /opt/openfoam222/etc/bashrc'
 alias of16ext='. $HOME/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc'
 alias paraFoam='paraFoam -builtin'



# source /home/maimouna/OpenFOAMExt/OpenFOAM-1.6-ext/etc/bashrc
# /home/maimouna/OpenFOAMExt/OpenFOAM-1.6-ext/ThirdParty/packages/scotch-5.1.10b
# export PV_PLUGIN_PATH=/opt/openfoam210/platforms/linux64GccDPOpt/lib/paraview-3.12
# source $HOME/OpenFOAM/foam-extend-3.0/etc/bashrc
# source /home/maimouna/foam/foam-extend-3.0/etc/bashrc
source /home/maimouna/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc
even I committed aliases the error still there.

Many thanks for your help.

Last edited by wyldckat; January 1, 2014 at 10:25. Reason: Added [CODE][/CODE]
Maimouna is offline   Reply With Quote

Old   January 1, 2014, 10:35
Default
  #7
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Maimouna,

Just a little note first: please post code using the "[CODE]" markers, as explained in one of the links in my signature.


OK, now let's fix one problem at a time:
  1. Edit your "~/.bashrc" file and remove the last line you have got now, namely this line:
    Code:
    source /home/maimouna/OpenFOAM/OpenFOAM-1.6-ext/etc/bashrc
  2. Add this line to "~/.bashrc" file:
    Code:
    alias fe30='source $HOME/foam/foam-extend-3.0/etc/bashrc'
  3. Start a new terminal.
  4. Run this command:
    Code:
    fe30
    If it gives an error message, let me know what error it gives you.
  5. Start another terminal and run these commands:
    Code:
    set -x
    of16ext > env16ext.log 2>&1
    set +x
    gzip env16ext.log
    And attach to your next post the file "env16ext.log.gz".
With this information, I should be able to guide you better.

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   January 2, 2014, 11:03
Default
  #8
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Hi Bruno,

when I run fe30, it gives

Code:
maimouna@maimouna-desktop:~$ fe30 
Sourcing: /home/maimouna/foam/foam-extend-3.0/etc/settings.sh
  Environment variables defined for OpenMPI:
    OPENMPI_BIN_DIR       : /usr/bin
    OPENMPI_LIB_DIR       : /usr/lib/openmpi/lib
    OPENMPI_INCLUDE_DIR   : /usr/lib/openmpi/include /usr/lib/openmpi/include/openmpi
    OPENMPI_COMPILE_FLAGS : -I/usr/lib/openmpi/include -I/usr/lib/openmpi/include/openmpi -pthread
    OPENMPI_LINK_FLAGS    : -pthread -L/usr/lib/openmpi/lib -lmpi -lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl

    MPI_HOME              : /usr
    MPI_ARCH_PATH         : /usr
    OPAL_PREFIX           : /usr
    PINC                  : -I/usr/lib/openmpi/include -I/usr/lib/openmpi/include/openmpi -pthread
    PLIBS                 : -pthread -L/usr/lib/openmpi/lib -lmpi -lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/mesquite-2.1.2/platforms/linux64Gcc46DPOpt/etc/mesquite-2.1.2.sh
    MESQUITE_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/mesquite-2.1.2/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/metis-5.1.0/platforms/linux64Gcc46DPOpt/etc/metis-5.1.0.sh
    METIS_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/metis-5.1.0/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/parmetis-4.0.3/platforms/linux64Gcc46DPOpt/etc/parmetis-4.0.3.sh
    PARMETIS_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/parmetis-4.0.3/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/ParMGridGen-1.0/platforms/linux64Gcc46DPOpt/etc/ParMGridGen-1.0.sh
    PARMGRIDGEN_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/ParMGridGen-1.0/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/libccmio-2.6.1/platforms/linux64Gcc46DPOpt/etc/libccmio-2.6.1.sh
    LIBCCMIO_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/libccmio-2.6.1/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/scotch-6.0.0/platforms/linux64Gcc46DPOpt/etc/scotch-6.0.0.sh
    SCOTCH_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/scotch-6.0.0/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/cmake-2.8.12/platforms/linux64Gcc46DPOpt/etc/cmake-2.8.12.sh
    CMAKE_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/cmake-2.8.12/platforms/linux64Gcc46DPOpt
    M4_DIR is initialized to: 
    BISON_DIR is initialized to: 
    FLEX_DIR is initialized to: 
    ZOLTAN_DIR is initialized to: 
    PYTHON_DIR is initialized to: 
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/PyFoam-0.6.1/platforms/noarch/etc/PyFoam-0.6.1.sh
    PYFOAM_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/PyFoam-0.6.1/platforms/noarch
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/hwloc-1.7.2/platforms/linux64Gcc46DPOpt/etc/hwloc-1.7.2.sh
    HWLOC_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/hwloc-1.7.2/platforms/linux64Gcc46DPOpt
    QT_DIR is initialized to: /usr
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/ParaView-4.0.1/platforms/linux64Gcc46DPOpt/etc/ParaView-4.0.1.sh
    PARAVIEW_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/ParaView-4.0.1/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/etc/aliases.sh
maimouna@maimouna-desktop:~$
it seems to me it is working fine. Am I right?

I attached env16ext.log.gz file.

Warm regards
Maimouna
Attached Files
File Type: gz env16ext.log.gz (109 Bytes, 2 views)

Last edited by wyldckat; January 2, 2014 at 19:38. Reason: missing [/CODE]
Maimouna is offline   Reply With Quote

Old   January 2, 2014, 16:06
Default
  #9
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

foam-extend-3.0 works fine itself. But, when I run fe30, I face problem with paraview

Code:
maimouna@maimouna-desktop:~/foam/foam-extend-3.0/tutorials/incompressible/icoFoam/cavity$ paraFoam
unknown option/argument: '-builtin'

usage: paraFoam [OPTION]
options:
  -case   dir    specify alternative case directory
  -region name   specify mesh region name
  -touch         only create the .foam or .foam file
  -nativeReader  use the paraview native reader for OpenFOAM

* start paraview  with the OpenFOAM libraries

maimouna@maimouna-desktop:~/foam/foam-extend-3.0/tutorials/incompressible/icoFoam/cavity$
I tried the solutions given in
http://www.cfd-online.com/Forums/blo...-openfoam.html

but the error still there. Also, I tried to install Ubuntu paraview

Code:
sudo apt-get paraview
but still the same.
Many thanks in advanced.
Maimouna is offline   Reply With Quote

Old   January 2, 2014, 19:44
Default
  #10
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Maimouna,

Regarding foam-extend 3.0 - try these commands, which will modify the internal option for extend's paraFoam:
Code:
foam

sed -i -e 's=nativeReader=builtin=g' bin/paraFoam
From now on, it should no longer complain about not knowing what "builtin" is


Regarding 1.6-ext: I'm sorry to say, but it seems that the installation of 1.6-ext is too damaged. You'll have to reinstall it again.
Nonetheless, since you now have got foam-extend 3.0 working, I think that you no longer need 1.6-ext.

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   January 6, 2014, 11:56
Default
  #11
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

many thanks for your reply. At the mean time, I'll work on foam-extend 3.0.

I applied
foam sed -i -e 's=nativeReader=builtin=g' bin/paraFoam
but still doesn't give me any positive result.

Warm regards
Maimouna is offline   Reply With Quote

Old   January 10, 2014, 15:58
Default
  #12
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Quick answer - This is incorrect:
Quote:
Originally Posted by Maimouna View Post
foam sed -i -e 's=nativeReader=builtin=g' bin/paraFoam
This is correct:
Code:
foam
sed -i -e 's=nativeReader=builtin=g' bin/paraFoam
Notice that foam is a command in its own line and sed is another command in its own line
wyldckat is online now   Reply With Quote

Old   January 13, 2014, 06:28
Default
  #13
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

yah, I did what you posted before

foam sed -i -e 's=nativeReader=builtin=g' bin/paraFoam but by typing mistake, they are coming in the same line. I did that two commands in two separated lines. Anyway, that is not solve the problem yet. Even, paraFoam in fe30 alias give me the following error

[QUOTE]bash: /home/maimouna/home/maimouna/foam/ParaView-3.10.1-Linux-x86_64/bin/paraview: No such file or directory[/QUOTE]

How can I solve that please?

Many thanks in advanced.
Maimouna is offline   Reply With Quote

Old   January 13, 2014, 18:27
Default
  #14
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Maimouna,

Something isn't right. The fe30 alias is associated to foam-extend-3.0, for which it should be using ParaView 4.0.1, not ParaView 3.10.1.

Try this:
  1. Start a new terminal or window.
  2. Run: paraFoam
    • If it does not say something like "file not found", then it means that some OpenFOAM environment is being activated, when it should not.
  3. If it did say something like "file not found", then run: fe30
  4. Then run: paraFoam
    • Does it give you the same error?
Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   January 14, 2014, 05:46
Default
  #15
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,
the following shows what did I get in my terminal by following that previous four steps
Code:
maimouna@maimouna-desktop:~$ paraFoam
bash: /home/maimouna/home/maimouna/foam/ParaView-3.10.1-Linux-x86_64/bin/paraview: No such file or directory
maimouna@maimouna-desktop:~$ fe30 
Sourcing: /home/maimouna/foam/foam-extend-3.0/etc/settings.sh
  Environment variables defined for OpenMPI:
    OPENMPI_BIN_DIR       : /usr/bin
    OPENMPI_LIB_DIR       : /usr/lib/openmpi/lib
    OPENMPI_INCLUDE_DIR   : /usr/lib/openmpi/include /usr/lib/openmpi/include/openmpi
    OPENMPI_COMPILE_FLAGS : -I/usr/lib/openmpi/include -I/usr/lib/openmpi/include/openmpi -pthread
    OPENMPI_LINK_FLAGS    : -pthread -L/usr/lib/openmpi/lib -lmpi -lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl

    MPI_HOME              : /usr
    MPI_ARCH_PATH         : /usr
    OPAL_PREFIX           : /usr
    PINC                  : -I/usr/lib/openmpi/include -I/usr/lib/openmpi/include/openmpi -pthread
    PLIBS                 : -pthread -L/usr/lib/openmpi/lib -lmpi -lopen-rte -lopen-pal -ldl -Wl,--export-dynamic -lnsl -lutil -lm -ldl
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/mesquite-2.1.2/platforms/linux64Gcc46DPOpt/etc/mesquite-2.1.2.sh
    MESQUITE_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/mesquite-2.1.2/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/metis-5.1.0/platforms/linux64Gcc46DPOpt/etc/metis-5.1.0.sh
    METIS_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/metis-5.1.0/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/parmetis-4.0.3/platforms/linux64Gcc46DPOpt/etc/parmetis-4.0.3.sh
    PARMETIS_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/parmetis-4.0.3/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/ParMGridGen-1.0/platforms/linux64Gcc46DPOpt/etc/ParMGridGen-1.0.sh
    PARMGRIDGEN_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/ParMGridGen-1.0/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/libccmio-2.6.1/platforms/linux64Gcc46DPOpt/etc/libccmio-2.6.1.sh
    LIBCCMIO_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/libccmio-2.6.1/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/scotch-6.0.0/platforms/linux64Gcc46DPOpt/etc/scotch-6.0.0.sh
    SCOTCH_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/scotch-6.0.0/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/cmake-2.8.12/platforms/linux64Gcc46DPOpt/etc/cmake-2.8.12.sh
    CMAKE_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/cmake-2.8.12/platforms/linux64Gcc46DPOpt
    M4_DIR is initialized to: 
    BISON_DIR is initialized to: 
    FLEX_DIR is initialized to: 
    ZOLTAN_DIR is initialized to: 
    PYTHON_DIR is initialized to: 
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/PyFoam-0.6.1/platforms/noarch/etc/PyFoam-0.6.1.sh
    PYFOAM_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/PyFoam-0.6.1/platforms/noarch
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/hwloc-1.7.2/platforms/linux64Gcc46DPOpt/etc/hwloc-1.7.2.sh
    HWLOC_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/hwloc-1.7.2/platforms/linux64Gcc46DPOpt
    QT_DIR is initialized to: /usr
Sourcing: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/ParaView-4.0.1/platforms/linux64Gcc46DPOpt/etc/ParaView-4.0.1.sh
    PARAVIEW_DIR is initialized to: /home/maimouna/foam/foam-extend-3.0/ThirdParty/packages/ParaView-4.0.1/platforms/linux64Gcc46DPOpt
Sourcing: /home/maimouna/foam/foam-extend-3.0/etc/aliases.sh
maimouna@maimouna-desktop:~$ paraFoam
bash: /home/maimouna/home/maimouna/foam/ParaView-3.10.1-Linux-x86_64/bin/paraview: No such file or directory
maimouna@maimouna-desktop:~$
Best regards
Maimouna is offline   Reply With Quote

Old   January 16, 2014, 16:10
Default
  #16
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,253
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Maimouna,

Something very strange is going on... OK, try these commands and tell me what they give you:
Code:
which paraFoam
alias paraFoam
They should make it easier to understand what's happening.

Best regards,
Bruno
wyldckat is online now   Reply With Quote

Old   January 17, 2014, 07:03
Default
  #17
Senior Member
 
ok
Join Date: Oct 2013
Posts: 256
Rep Power: 4
Maimouna is on a distinguished road
Dear Bruno,

many thanks for your reply. To avoid all that problem that I found, I remove foam directory which contains foam-extend-3.0
Code:
sudo rm -rf foam
and install it again. It works fine now itself.

I didn't go back to OpenFOAM-1.6-ext at the mean time because I think foam-extend-3.0 more general with all important tutorials that I need at least thesedays.

Best regards
wyldckat likes this.
Maimouna is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM 1.6 ext fportela OpenFOAM Installation 11 December 26, 2013 19:55
difference in 'make axial mesh' for OF 2.1 & OF 1.6 EXT Rocky4 OpenFOAM Mesh Utilities 0 November 17, 2012 17:48
Solver Compiling error - OF 1.6 ext. raditz OpenFOAM Programming & Development 8 November 4, 2012 10:53
OpenFOAM 1.6 ext - Compilation errors - Fedora 17(32bit) toolpost OpenFOAM Installation 15 September 21, 2012 09:38
installing OF 1.6 ext yhaomin2007 OpenFOAM Installation 3 September 11, 2012 16:52


All times are GMT -4. The time now is 05:50.