CFD Online URL
[Sponsors]
Home > Forums > OpenFOAM Installation

foam-extend-3.0 installed error in Ubuntu about ThirdParty AllMake.stage4

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree2Likes
  • 2 Post By mbeaudoin

Reply
 
LinkBack Thread Tools Display Modes
Old   January 8, 2014, 04:28
Default foam-extend-3.0 installed error in Ubuntu about ThirdParty AllMake.stage4
  #1
New Member
 
hua1015's Avatar
 
Hua
Join Date: May 2012
Posts: 20
Rep Power: 4
hua1015 is on a distinguished road
Hi,dear foamer,
Ubuntu_13.10, for x86_64,install foam-extend-3.0,follow http://openfoamwiki.net/index.php/In...u#Ubuntu_13.10 step by step;
but fail in ThirdParty allMake.stage4.
anyone has ideas?
here is the first error:

Generating moc_pqXYChartDisplayPanel.cxx
[ 87%] [ 87%] Generating moc_pqXYChartOptionsEditor.cxx
[ 87%] [ 87%] Generating ui_pqAbortAnimation.h
Generating ui_pqAboutDialog.h
[ 88%] [ 88%] Generating ui_pqAnimationSettings.h
Generating ui_pqApplicationOptions.h
uic: Error in line 115, column 61 : Unexpected attribute alignment
File '/home/junhuapan/foam/foam-extend-3.0/ThirdParty/rpmBuild/BUILD/ParaView-v4.0.1-source/Qt/Components/Resources/UI/pqApplicationOptions.ui' is not valid
make[2]: *** [Qt/Components/ui_pqApplicationOptions.h] Error 1
make[2]: *** Waiting for unfinished jobs....
make[1]: *** [Qt/Components/CMakeFiles/pqComponents.dir/all] Error 2
hua1015 is offline   Reply With Quote

Old   January 8, 2014, 07:40
Default
  #2
New Member
 
hua1015's Avatar
 
Hua
Join Date: May 2012
Posts: 20
Rep Power: 4
hua1015 is on a distinguished road
I have solved this problem.
Just do ./AllMake.stage4 again.
hua1015 is offline   Reply With Quote

Old   January 22, 2014, 12:06
Default
  #3
New Member
 
Santiago Lopez Castano
Join Date: Nov 2012
Posts: 12
Rep Power: 4
Santiago is on a distinguished road
I'm having the same issue

How did you fixed it???
Santiago is offline   Reply With Quote

Old   January 22, 2014, 19:36
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,512
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings to all!

@Santiago: Did you try what Hua said in post #2? Namely:
Quote:
Originally Posted by hua1015 View Post
Just do ./AllMake.stage4 again.
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   January 30, 2014, 16:19
Default
  #5
Member
 
Miro
Join Date: Jan 2013
Location: Europe
Posts: 46
Rep Power: 3
miro2000 is on a distinguished road
I'm having the same problem. I tried to compile again, but the problem is still there.
I am also having the same problem on OF 1.6-ext.

- miro

e: file: .../ThirdParty/rpmBuild/BUILD/ParaView-v4.0.1-source/Qt/Components/Resources/UI/pqApplicationOptions.ui' is not valid
miro2000 is offline   Reply With Quote

Old   February 2, 2014, 15:55
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,512
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Greetings to all!

Since I'm unable to replicate this problem, please provide the following information:
  1. From inside the folder "ThirdParty", what does this file contain:
    Code:
    rpmBuild/BUILD/ParaView-v4.0.1-source/buildObj/Qt/Components/ui_pqApplicationOptions.h
  2. What does this command give you:
    Code:
    uic -v
  3. What do these commands give you:
    Code:
    gcc --version
    g++ --version
    ld --version
With this information, I should be able to try and replicate the same error.


Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   February 2, 2014, 17:38
Default
  #7
Member
 
Miro
Join Date: Jan 2013
Location: Europe
Posts: 46
Rep Power: 3
miro2000 is on a distinguished road
Code:
rpmBuild/BUILD/ParaView-v4.0.1-source/buildObj/Qt/Components/ui_pqApplicationOptions.h
I have no such file.

Code:
uic -v
Qt User Interface Compiler version 4.7.4

Code:
gcc --version; g++ --version; ld --version
gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
g++ (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
GNU ld (GNU Binutils for Ubuntu) 2.22



I think I messed something up with the environment variables. Is there a way to list them all?

Thank you very much
miro2000 is offline   Reply With Quote

Old   February 2, 2014, 19:18
Default
  #8
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,512
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
If you run this command:
Code:
export
It will show the whole shell environment.
wyldckat is offline   Reply With Quote

Old   February 3, 2014, 18:43
Default
  #9
Member
 
Miro
Join Date: Jan 2013
Location: Europe
Posts: 46
Rep Power: 3
miro2000 is on a distinguished road
Well, environment variables seem correct, which is bad news.

Is there a way to completely remove OF-3.0 from my system (all traces of it), so I could install it again? I think that is my best bet.

Regards
- miro
miro2000 is offline   Reply With Quote

Old   February 4, 2014, 15:27
Default
  #10
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 7,512
Blog Entries: 33
Rep Power: 74
wyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the roughwyldckat is a jewel in the rough
Hi Miro,

Well, the simplest way to uninstall is likely this one:
Code:
cd ~/foam
rm -r foam-extend-3.0
Then start a new terminal, to ensure you have a clean shell environment.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   February 4, 2014, 15:51
Default
  #11
Senior Member
 
Martin Beaudoin
Join Date: Mar 2009
Posts: 328
Rep Power: 12
mbeaudoin will become famous soon enough
Hello,

> Qt User Interface Compiler version 4.7.4

I have the same problem on a Centos system.

Basically, ParaView 4.0.1 will not compile with Qt 4.7.4, even if you try it 10 times...

Still, I was able to compile ParaView 4.0.1 with Qt 4.8.5, the latest stable release for Qt4.

So if your Ubuntu installation is offering a newer version than Qt 4.7.4, just install this newer version instead , including the corresponding Qt dev packages. Then use this system-installed version of Qt to compile ParaView 4.0.1.

Otherwise, wait a little bit, I will propose an upgrade to Qt 4.8.5 with the appropriate .spec file for the ThirdParty packages.

Martin


Quote:
Originally Posted by miro2000 View Post
Code:
rpmBuild/BUILD/ParaView-v4.0.1-source/buildObj/Qt/Components/ui_pqApplicationOptions.h
I have no such file.

Code:
uic -v
Qt User Interface Compiler version 4.7.4

Code:
gcc --version; g++ --version; ld --version
gcc (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
g++ (Ubuntu/Linaro 4.6.3-1ubuntu5) 4.6.3
GNU ld (GNU Binutils for Ubuntu) 2.22



I think I messed something up with the environment variables. Is there a way to list them all?

Thank you very much
wyldckat and miro2000 like this.
mbeaudoin is offline   Reply With Quote

Old   February 8, 2014, 10:24
Default
  #12
Member
 
Miro
Join Date: Jan 2013
Location: Europe
Posts: 46
Rep Power: 3
miro2000 is on a distinguished road
This solved the problem. Thank you very much.
miro2000 is offline   Reply With Quote

Old   February 19, 2014, 05:10
Default
  #13
New Member
 
Ola Widlund
Join Date: Jun 2011
Location: Sweden
Posts: 13
Rep Power: 5
Ola Widlund is on a distinguished road
Hi Martin,

I tried your bugfix branch for qt 4.8.5 yersterday. It works fine, but I noticed you forgot to do the version change in Allclean.stage4.

Best regards,

Ola



Quote:
Originally Posted by mbeaudoin View Post
Hello,

> Qt User Interface Compiler version 4.7.4

I have the same problem on a Centos system.

Basically, ParaView 4.0.1 will not compile with Qt 4.7.4, even if you try it 10 times...

Still, I was able to compile ParaView 4.0.1 with Qt 4.8.5, the latest stable release for Qt4.

So if your Ubuntu installation is offering a newer version than Qt 4.7.4, just install this newer version instead , including the corresponding Qt dev packages. Then use this system-installed version of Qt to compile ParaView 4.0.1.

Otherwise, wait a little bit, I will propose an upgrade to Qt 4.8.5 with the appropriate .spec file for the ThirdParty packages.

Martin
Ola Widlund is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
error message with modeling a cube with a hold at the center hsingtzu OpenFOAM Native Meshers: blockMesh 2 March 14, 2012 11:56
mesh airfoil NACA0012 anand_30 OpenFOAM Meshing & Mesh Conversion 12 December 12, 2011 05:16
BlockMesh FOAM warning gaottino OpenFOAM Native Meshers: blockMesh 7 July 19, 2010 15:11
Axisymmetrical mesh Rasmus Gjesing (Gjesing) OpenFOAM Native Meshers: blockMesh 10 April 2, 2007 15:00
Import gmsh msh to Foam adorean Open Source Meshers: Gmsh, Netgen, CGNS, ... 24 April 27, 2005 09:19


All times are GMT -4. The time now is 18:53.