CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Paraview crash

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 3, 2014, 12:51
Default Paraview crash
  #1
New Member
 
Niklas Andersson
Join Date: Jan 2014
Posts: 2
Rep Power: 0
Nixlax is on a distinguished road
Hi im new to OpenFOAM and I'm having some problem with Paraview. When i try to start it it always crashes and forces me to log out.

Im using Centos 6.4 with 64 bit system , x86_64 architecture, and i used this guide to install it.
http://openfoamwiki.net/index.php/In....2/CentOS_SL_R
The para view that was installed is "ParaView-3.12.0".

I have only tried one tutorial with icoFOAM and everything seams to work until i write
paraFoam. Then i begins to start up Paraview but then the program crash and my user is logged out.

I have tried to open paraview on it own but i has the same problem, crash and log out. I have also tried to download and extract a later version of paraview "ParaView-4.1.0-Linux-64bit". It works fine but then i cant access my data from OpenFOAM.

Thanks in advance
Niklas

Sorry for low info. I'm new to Linux if there is any more info you need please write how to get it and i will get it straight ahead.
Nixlax is offline   Reply With Quote

Old   February 4, 2014, 12:23
Default
  #2
New Member
 
Krishna
Join Date: Jun 2012
Posts: 27
Blog Entries: 1
Rep Power: 4
rkc.cfd is on a distinguished road
HI the following steps still work for pre compiled Paraview -

http://www.cfd-online.com/Forums/blo...-openfoam.html

Also which OpenFOAM vesion are you using?

Cheers
rkc.cfd is offline   Reply With Quote

Old   February 4, 2014, 16:16
Default
  #3
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,117
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings to all!

@Niklas: Your description indicates that the X.org manager crashes, which manages the desktop graphics. This usually means that the correct graphics card drivers are not installed, because ParaView requires some heavy-duty 3D graphics card capabilities... in other words, needs OpenGL.

I suggest that you search online for information on how to install the official drivers for your graphics card for CentOS and/or RHEL.

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   February 10, 2014, 09:29
Default
  #4
New Member
 
Niklas Andersson
Join Date: Jan 2014
Posts: 2
Rep Power: 0
Nixlax is on a distinguished road
Thanks for the answers. I was a little bit restless and thought i had done something wrong during the installation and decided to reinstall the OS. Doing this i got some harddrive problem... Anyway thanks again for the answers too bad i cant test if that would have solved it.

After fixing my harddrive i decided to go for windows 8.1 with a virtial machine running centOS instead of dualbooting again.

Now i got a new problem. When try to do step 12 in the installation guide I get these errors:

Linking CXX static library libCTestLib.a
[ 98%] Built target CTestLib
make: *** [all] Error 2

real 0m26.133s
user 1m23.468s
sys 0m12.907s
Error building: cmake-2.8.3

Any idea how to solve it?

I use VMware Player and i installed CentOS 6.4. First thing after installing it i did a "yum
update".

edit* When that was done i tried to install Openfoam with this guide
http://sourceforge.net/apps/mediawik...itle=Main_Page
I was able to intall all OpenFOAM applications but it compain on network connection when i tried to install OpenFOAM with this command line "python centFOAM.py --OF20". My network connection is working fine so guess there was something els that was disturbing it.

So finally i followed this guide instead.

http://openfoamwiki.net/index.php/In...CentOS_SL_RHEL

Could it be my first installation of OF aplications that is disturbing my new one?
Thanks in advance
Niklas
Nixlax is offline   Reply With Quote

Old   February 15, 2014, 18:21
Default
  #5
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,117
Blog Entries: 34
Rep Power: 83
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Niklas,

That's a strange error... I've tested just now on a virtual machine and I didn't get the same problem.
OK, try running these commands:
Code:
cd $WM_THIRD_PARTY_DIR
./makeCmake > makeCMake.log
gzip makeCMake.log
Then attach the file "makeCMake.log.gz" to your next post.
I ask this because I think there is something more before that error message, that could indicate the real reason for not being able to build CMake.

edit: If you still want to install CentFOAM, read this post: Problem with using paraFoam post #2

Best regards,
Bruno

Last edited by wyldckat; February 15, 2014 at 19:27. Reason: see "edit:"
wyldckat is offline   Reply With Quote

Reply

Tags
centos 6.4, crash, paraview 3.12

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paraview launch & crash problems dancfd ParaView 3 January 17, 2013 13:04
ParaView Subwindow Crash Emre Turkoz OpenFOAM Bugs 3 January 22, 2011 15:33
paraFoam reader for OpenFOAM 1.6 smart OpenFOAM Installation 13 November 16, 2009 22:41
Paraview crash after opening OF case gfilip OpenFOAM Installation 4 October 14, 2009 14:46
Both paraview and paraFoam crash on Redhat Linux WS v4 64bit sek OpenFOAM Paraview & paraFoam 4 August 17, 2006 16:26


All times are GMT -4. The time now is 01:28.