CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Installation of foam-extend-3.0 (http://www.cfd-online.com/Forums/openfoam-installation/129810-installation-foam-extend-3-0-a.html)

dowlee February 13, 2014 10:13

Installation of foam-extend-3.0
 
Hi, I am installing foam-extend-3.0 under my debian-6.0 (sqeeze, 64bit) operating system. When I chosen the system installed QT4 in default, then a error triggered by QT4,as follows,

:confused:------------------- -------------------------------------------
CMake Error at /home/liweiwei/foam/foam-extend-3.0/ThirdParty/packages/cmake-2.8.12/platforms/linux64GccDPOpt/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
Could NOT find Qt4: Found unsuitable version "4.6.3", but required is at
least "4.7.0" (found /usr/bin/qmake)
Call Stack (most recent call first):
/home/liweiwei/foam/foam-extend-3.0/ThirdParty/packages/cmake-2.8.12/platforms/linux64GccDPOpt/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:313 (_FPHSA_FAILURE_MESSAGE)
/home/liweiwei/foam/foam-extend-3.0/ThirdParty/packages/cmake-2.8.12/platforms/linux64GccDPOpt/share/cmake-2.8/Modules/FindQt4.cmake:1393 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
VTK/GUISupport/Qt/CMakeLists.txt:57 (find_package)
:confused:-----------------------------------------------------------

then in the foam/foam-extend-3.0/etc/prefs.sh, I comment "export QT_THIRD_PARTY=1" and uncomment "export QT_DIR=path_to_system_installed_qt" and "export QT_BIN_DIR=$QT_DIR/bin". But during the installation, another error exsits as follows.

:confused:-----------------------------------------------------------
/usr/bin/ld: cannot find -lXrender
collect2: ld returned 1 exit status
make[1]: *** [../../../../lib/libQtWebKit.so.4.7.4] Error 1
make[1]: Leaving directory `/home/liweiwei/foam/foam-extend-3.0/ThirdParty/rpmBuild/BUILD/qt-everywhere-opensource-src-4.7.4/src/3rdparty/webkit/WebCore'
make: *** [sub-webkit-make_default-ordered] Error 2
error: Bad exit status from /home/liweiwei/foam/foam-extend-3.0/ThirdParty/rpmBuild/tmp/rpm-tmp.S6IXF7 (%build)

RPM build errors:
Bad exit status from /home/liweiwei/foam/foam-extend-3.0/ThirdParty/rpmBuild/tmp/rpm-tmp.S6IXF7 (%build)
Installing package: qt-everywhere-opensource-src-4.7.4
Uninstalling qt-everywhere-opensource-src-4.7.4 using RPM: qt-everywhere-opensource-src-4.7.4-linux64GccDPOpt.x86_64
Installing qt-everywhere-opensource-src-4.7.4 using RPM file: /home/liweiwei/foam/foam-extend-3.0/ThirdParty/rpmBuild/RPMS/x86_64/qt-everywhere-opensource-src-4.7.4-linux64GccDPOpt.x86_64.rpm
error: open of /home/liweiwei/foam/foam-extend-3.0/ThirdParty/rpmBuild/RPMS/x86_64/qt-everywhere-opensource-src-4.7.4-linux64GccDPOpt.x86_64.rpm failed: No such file or directory
Done installing package

WARNING:
WARNING: Skipping the installation of ParaView-4.0.1.
WARNING: Please make sure the QT_BIN_DIR environment variable properly
WARNING: initialized in the file prefs.sh or prefs.csh
WARNING: The command $QT_BIN_DIR/qmake needs to be valid
WARNING:
========================================
Done ThirdParty AllMake: Stage4
========================================
:confused:---------------------------------------------------------

Should I update QT4 to the version of 4.7.4 in my system directly? But openfoam-1.6-ext is already installed in my debian OS. If I update it, Will this impact openfoam-1.6-ext?

hjasak February 14, 2014 05:29

I think I've seen this recently - we had to change the version of qt for PV-4.0.1.

Let me have a look; alternatively, please just update the qt version or download binary Paraview. I mostly use the built-in-reader because it supports decomposed run post-processing.

Apologies for inconvenience; the rest of the code should work fine.
Hrv

dowlee February 18, 2014 14:43

Thanks very much. I don`t have root privilege for my office PC. So I don`t update the QT. But Before I have already installed of-1.6-ext, I use foam-extend-3.0 to run the simulation, then use paraFoam in of-1.6-ext to do post-process.

wyldckat March 2, 2014 06:46

Greetings to all!

@dowlee: Just a reminder that you can update your current "foam-extend-3.0" folder (as of 17th of February), you should be able to build Qt 4.8.5 and ParaView 4.0.1 with success. To update, try running these commands:
Code:

cd $WM_PROJECT_DIR
git pull

cd ThirdParty
./AllMake.pre > log.AllMake 2>&1

cd ..
source etc/bashrc
./Allwmake > make.log 2>&1

Best regards,
Bruno


All times are GMT -4. The time now is 13:36.