CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Prolem installing OpenFOAM Ver 2.3.0 source in Ubuntu 13.1.0 on VMware (http://www.cfd-online.com/Forums/openfoam-installation/131144-prolem-installing-openfoam-ver-2-3-0-source-ubuntu-13-1-0-vmware.html)

zandi March 10, 2014 06:27

Prolem installing OpenFOAM Ver 2.3.0 source in Ubuntu 13.1.0 on VMware
 
Hi friends
I use VMware (virtual machine) for ubuntu 13.1.0 and want to install OpenFOAM 2.3.0 source?
afther extracting the files as said in manual (http://www.openfoam.org/download/) and afther enter command {sudo su -} and this comand for installation {apt-get install build-essential flex bison cmake zlib1g-dev qt4-dev-tools libqt4-dev gnuplot libreadline-dev libncurses-dev libxt-dev} I get these lines of information without any installed program..

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libqt4-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libqt4-dbus
Package cmake is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
Package flex is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
Package bison is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
Package qt4-dev-tools is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
qtchooser
E: Unable to locate package build-essential
E: Package 'cmake' has no installation candidate
E: Package 'flex' has no installation candidate
E: Package 'bison' has no installation candidate
E: Unable to locate package zlib1g-dev
E: Package 'qt4-dev-tools' has no installation candidate
E: Package 'libqt4-dev' has no installation candidate
E: Unable to locate package gnuplot
E: Unable to locate package libreadline-dev
E: Unable to locate package libncurses-dev
E: Unable to locate package libxt-dev
E: Unable to locate package libopenmpi-dev
E: Unable to locate package openmpi-bin
E: Unable to locate package libboost-system-dev
E: Unable to locate package libboost-thread-dev
E: Unable to locate package libgmp-dev
E: Unable to locate package libmpfr-dev


could any one help me please? i'm a new user of ubuntu and linux with no experience of linux

before installing source pack i wanted to install deb pack but it also has problem

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package openfoam230


please help me

wyldckat March 10, 2014 16:09

Quick answers:
  1. First update your Ubuntu installation. It can be done as simple as running:
    Code:

    sudo apt-get update
    sudo apt-get upgrade

  2. Make sure you have the universe repository turned on, as explained here: http://openfoamwiki.net/index.php/FA..._on_Ubuntu_.3F
  3. Detailed installation instructions for installing OpenFOAM 2.3.0 on Ubuntu 13.10 can be found here: http://openfoamwiki.net/index.php/In...u#Ubuntu_13.10
  4. Answers here on the forum can take as long as 1 week to 1 month or even more. If you get any answers sooner than that, consider yourself lucky ;).

zandi March 11, 2014 10:15

it was proxy
 
thank you
but I found at last the problem . it is about my place proxy server and i did it finally and it is ok. it couldn't connect the server for download through the terminal due to proxy. i asked my server assistant to allow me to use internet without proxy for a half day and now i have openFoam.
but i wonder i may have problems future in each steps of my project!!
thanks

Annier March 25, 2014 07:50

thank you very much
 
Quote:

Originally Posted by wyldckat (Post 479204)
Quick answers:
  1. First update your Ubuntu installation. It can be done as simple as running:
    Code:

    sudo apt-get update
    sudo apt-get upgrade

  2. Make sure you have the universe repository turned on, as explained here: http://openfoamwiki.net/index.php/FA..._on_Ubuntu_.3F
  3. Detailed installation instructions for installing OpenFOAM 2.3.0 on Ubuntu 13.10 can be found here: http://openfoamwiki.net/index.php/In...u#Ubuntu_13.10
  4. Answers here on the forum can take as long as 1 week to 1 month or even more. If you get any answers sooner than that, consider yourself lucky ;).

dear bruno,
the installation guidelines are very much helpful. i installed OpeFoam 2.3.x in Ubuntu 12.04 as per the suggestion given in http://openfoamwiki.net/index.php/Installation/Linux/OpenFOAM-2.3.0/Ubuntu#Ubuntu_13.10
When installing i checked the cmake version and it was 2.8.10. maybe the update and upgrade command installed this version in the computer. so, i could install paraview 4.1.0 bypassing the step 10 in the guideline:

Quote:

Step 10.
Ubuntu 12.04 comes with CMake 2.8.7, but ParaView 4.1.0 needs CMake 2.8.8 or newer series. Therefore, we'll need to do a custom build:
cd
$WM_THIRD_PARTY_DIR
wget "https://raw.github.com/wyldckat/scripts4OpenFOAM3rdParty/master/getCmake" sed -i -e 's=version}\.3=version}.12.1=' getCmake
chmod +x getCmake
./getCmake
./makeCmake
wmSET $FOAM_SETTINGS
thanking you
yours
anil kunwar

wyldckat March 30, 2014 13:31

Greetings Annier,

Quote:

Originally Posted by Annier (Post 481990)
i installed OpeFoam 2.3.x in Ubuntu 12.04 as per the suggestion given in http://openfoamwiki.net/index.php/Installation/Linux/OpenFOAM-2.3.0/Ubuntu#Ubuntu_13.10
When installing i checked the cmake version and it was 2.8.10. maybe the update and upgrade command installed this version in the computer.

Thanks for sharing your findings. :)

Although, from your description, it seems that you are using Ubuntu 13.04, because that's the only Ubuntu version that provides CMake 2.8.10. And even though you provided the link for the section aimed at Ubuntu 13.10, you've followed the instructions meant for Ubuntu 12.04...

Anyway, I didn't write the instructions for Ubuntu 13.04, because the support time for this version ended back in January 2014: https://wiki.ubuntu.com/Releases
Oddly enough, the support for 12.10 only ends in April 2014... apparently because it's being used as a development reference for the upcoming 14.04 LTS.

Best regards,
Bruno

Annier March 31, 2014 03:57

the ubuntu version is 12.04
 
Hi Bruno,
the ubuntu version for my context is Ubuntu 12.04 LTS.
Yours
Anil Kunwar


All times are GMT -4. The time now is 22:53.