CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Paraview 4.1.0 cmake compiling error CUDA Convolution Driver (http://www.cfd-online.com/Forums/openfoam-installation/132036-paraview-4-1-0-cmake-compiling-error-cuda-convolution-driver.html)

Juan Carlos March 24, 2014 21:06

Paraview 4.1.0 cmake compiling error CUDA Convolution Driver
 
Hi, All

I'm trying to build ParaView 4.1.0 from source on debian 7.0 64 bits

I'm currently using the makeParaview script that is included in OpenFOAM 2.3

When running ccmake, I get this error:

error: #error -- unsupported GNU version! gcc 4.7 and up are not supported!

CMake Error at cuda compile generated CUDA ConvolutionDriver.cu.o.cmake: 206

Thanks for reading

Juan C.

Code

In file included from /usr/lib/nvidia-cuda-toolkit/include/cuda_runtime.h:59:0,
from <command-line>:0:
/usr/include/host_config.h:82:2: error: #error -- unsupported GNU version! gcc 4.7 and up are not supported!
CMake Error at cuda_compile_generated_CUDAConvolutionDriver.cu.o. cmake:206 (message):
Error generating
/home/juan/OpenFOAM/ThirdParty-2.3.0/build/linux64Gcc/ParaView-4.1.0/Plugins/SciberQuestToolKit/SciberQuest/CMakeFiles/cuda_compile.dir//./cuda_compile_generated_CUDAConvolutionDriver.cu.o


make[2]: *** [Plugins/SciberQuestToolKit/SciberQuest/CMakeFiles/cuda_compile.dir/./cuda_compile_generated_CUDAConvolutionDriver.cu.o] Error 1
make[1]: *** [Plugins/SciberQuestToolKit/SciberQuest/CMakeFiles/vtkSciberQuest.dir/all] Error 2
make: *** [all] Error 2
---

wyldckat March 30, 2014 14:39

Greetings Juan,

I hope you're referring to the script makeParaView4, as the script makeParaView is meant for ParaView 3.12.0.

Well, this is a tricky situation. It depends on a few details:
  1. Do you want to build ParaView with CUDA support?
  2. If #1 is yes, then can you update the CUDA version you have installed?
  3. If #1 is yes and #2 is no, are you using a custom GCC 4.7 build or are you using Debian's GCC?
    • If you're using Debian's GCC, then you should upgrade CUDA as well.
If #1 is no... then try editing the file "ParaView-4.1.0/Plugins/SciberQuestToolKit/SciberQuest/CMakeLists.txt" and find these two lines:
Code:

if (CUDA_FOUND AND SQTK_CUDA)
if (SQTK_CUDA AND CUDA_FOUND)

And replace them with:
Code:

if (OFF AND SQTK_CUDA)
if (SQTK_CUDA AND OFF)

And then run makeParaView4 once again.

Best regards,
Bruno

Juan Carlos April 11, 2014 18:04

Greetings Bruno,
I’m apologize for my delay to answer your comments about installation of
Paraview 4.1
I will try to implement your recommendations as soon as possible.
Best regards,
Juan C.

Juan Carlos April 17, 2014 13:37

Hi, Bruno
I followed your statements about installation of Paraview 4.1.
In my particular case. I decided to build ParaView without CUDA support, to do that I modified the file “CmakeLists.txt” as you comment.
Fortunately these changes made that Paraview works properly.
Thanks for your help.
Best regards,
Juan C.


All times are GMT -4. The time now is 04:10.