CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Paraview running slowly after installation of OF 2.3 on Ubuntu 14

Register Blogs Members List Search Today's Posts Mark Forums Read

Like Tree1Likes
  • 1 Post By marluc

Reply
 
LinkBack Thread Tools Display Modes
Old   May 18, 2014, 03:23
Default Paraview running slowly after installation of OF 2.3 on Ubuntu 14
  #1
Member
 
Luca
Join Date: Mar 2011
Location: Germany
Posts: 38
Rep Power: 6
marluc is on a distinguished road
Dear All,

I hope this is the right place where to post this question.

I just installed OF 2.3 on Ubuntu 14.04 and everything went right. But when I started Paraview I realized that it is running quite slowly and the quality of the visualized mesh is not so good. The main problem is when I zoom in and out, even with a simple mesh like the cavity case.
I have an integrated graphic board on my laptop but I didn't have the problem when I was running OF on Ubuntu 12.04 (just few days ago).

Can someone help me with suggestions?

Thank you in advance.
Luca
marluc is offline   Reply With Quote

Old   May 18, 2014, 12:40
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Greetings Luca,

A few questions:
  1. Did you install the specific drivers for the integrated graphics on your laptop? Ubuntu usually doesn't install the official ones, as it tries to use the open-source ones by default. Unfortunately, the open-source drivers mostly are unable to fully interact with the graphics cards and won't give the best performance in most cases.
  2. What integrated graphics GPU does you laptop have? Because unfortunately there are some Intel GPUs that have incomplete features or incomplete drivers for Linux.
  3. Try installing the ParaView version that is available for Ubuntu, not the one that comes with OpenFOAM. After installing it:
    1. Launch ParaView from the taskbar and/or start menu, instead of the terminal.
    2. Then on the command line, from within the folder of the cavity tutorial, run:
      Code:
      paraFoam -builtin -touch
      it will create a ".foam" file for you.
    3. OpenFOAM that file in the ParaView you opened via taskbar/start menu.
    Does this version perform better?
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   May 18, 2014, 13:03
Default
  #3
Member
 
Luca
Join Date: Mar 2011
Location: Germany
Posts: 38
Rep Power: 6
marluc is on a distinguished road
Dear Bruno,

thank you very much for your quick answer.

I have a VGA compatible Intel controller (i915) installed on my laptop.

00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
Subsystem: Dell Device 0410
Flags: bus master, fast devsel, latency 0, IRQ 42
Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
Memory at e0000000 (64-bit, prefetchable) [size=256M]
I/O ports at 60b0 [size=8]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915

I am following your instructions now. I have downloaded the Paraview Deb package for Ubuntu. Do I simply have to install it without deleting the version I have installed with OpenFOAM?

Moreover, what seems strange to me is that I didn't have this problem while running Paraview with Ubuntu 12.04 from USB stick.

Thank you again for your assistance.
Luca

Last edited by marluc; May 18, 2014 at 13:12. Reason: Incomplete reply
marluc is offline   Reply With Quote

Old   May 18, 2014, 13:42
Default
  #4
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Luca,

No need to uninstall the other ParaView version. This is why I mentioned you to launch ParaView from the taskbar/start menu, as this should use the Ubuntu version of ParaView.

As for the Ubuntu on USB: you didn't specify what kind of installation was on the USB version. It's possible that the USB version was a Live version that had good enough drivers for that GPU.
Or perhaps the problem is that Ubuntu 14.04 you have installed is over-using Compiz, which is a 3D dynamic desktop composition, which provides a neat interaction with the desktop, but can wreak havoc on OpenGL intensive applications, such as ParaView. The version on the USB drive possibly was not using Compiz, hence there not being any problems.

You might want to try installing XFCE or LXDE, which do not use Compiz. If you search online for them, you should be able to find several tutorials on how to use them on Ubuntu. This will replace the desktop interface for a more old-school interface (similar to Windows XP and older).

As for installing the correct drivers, is should also just be a matter of searching online for "i915 graphics on Ubuntu 14.04".

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   May 18, 2014, 14:56
Default
  #5
Member
 
Luca
Join Date: Mar 2011
Location: Germany
Posts: 38
Rep Power: 6
marluc is on a distinguished road
Dear Bruno,

I've tried everything but without success, i.e.:
- upgrading i915
- installing Paraview for Ubuntu
- Installing Gnome Classic Desktop (without Compiz)

Do you have other ideas or do you think that I should downgrade to Ubuntu 12.04?

Thank a lot for your help and patience.
Luca
marluc is offline   Reply With Quote

Old   May 18, 2014, 16:32
Default
  #6
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Luca,

It looks like it's a really annoying bug in Ubuntu 14.04 that affects a lot of people, across all graphics cards. If you search online for:
Code:
ubuntu 14.04 slow graphics
you'll find several questions and answers on this topic.

After a quick search:
  • Installing "Gnome Classic Desktop" should have solved the problem, but... are you certain that you're using it without Compiz?
  • How exactly did you upgrade the drivers for the integrated graphics?
Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   May 18, 2014, 17:43
Default
  #7
Member
 
Luca
Join Date: Mar 2011
Location: Germany
Posts: 38
Rep Power: 6
marluc is on a distinguished road
Dear Bruno,

first of all I really appreciate your help and interest.

Now, I installed Gnome-Flashback which allows me to choose between Gnome(Compiz) and Gnome(Metacity) at login. The last runs with Compiz disabled as confirmed with
Code:
ps aux | grep compiz
I downloaded and installed the upgrades for my Intel integrated graphic card directly from the intel website:
https://01.org/linuxgraphics/downloa...er-1.0.5-linux

It seems that the topic is also applicable to Ubuntu 14.04 but I didn't completely understood the warning message of the related link and I am a little bit scared of the possible consequences.

Luca

Last edited by marluc; May 18, 2014 at 17:53. Reason: incomplete reply
marluc is offline   Reply With Quote

Old   May 18, 2014, 18:05
Default
  #8
Member
 
Luca
Join Date: Mar 2011
Location: Germany
Posts: 38
Rep Power: 6
marluc is on a distinguished road
I also tried the solution proposed in your last post but again without success.
The zoom does not work properly and also the mesh looks bad.

Anyway, Paraview works but with more complicated mesh it is impossible to rotate or zoom.

Luca
marluc is offline   Reply With Quote

Old   June 8, 2014, 15:55
Default
  #9
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Luca,

I don't know if you've managed to solve this issue, but I've done a bit more searching on this topic. And my conclusion is that the best solution would be to switch back to Ubuntu 12.04.
Official support for Ubuntu 12.04 by Canonical is provided till April 2017, so it's a good choice for having a stable and properly working installation

The other possibility is to wait a few more months, in hope that this issue is solved in Ubuntu 14.04 in the next few months...

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 8, 2014, 18:05
Default
  #10
Member
 
Luca
Join Date: Mar 2011
Location: Germany
Posts: 38
Rep Power: 6
marluc is on a distinguished road
Dear Bruno,

thank you very much for your reply and time spent for looking at a possible solution to my problem.

Actually I already switched back to Ubuntu 12.04. Now the mesh is perfectly displayed in Paraview but the mouse zooming is slow. It is a curse...

It seems that my graphic card is running correctly. I am therefore still looking for a possible solution of this damned problem.

Any advice from your side is absolutely welcome!

Thanks again,
Luca
marluc is offline   Reply With Quote

Old   June 9, 2014, 07:08
Default
  #11
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 8,301
Blog Entries: 34
Rep Power: 84
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Hi Luca,

Mmm... there is a default setting in ParaView for only performing a full render after 2 seconds have passed since the last 3D interaction. Have a look in menu "Edit -> Settings", then on the dialogue box that shows up, go to the "Render View" branch on the left and configure "Lock Interactive Render" on the right to "0". Then click in the OK button and you should no longer have issues with the zooming.

In addition, there are 2 ways to zoom:
  1. Hold right-click and then move the mouse.
  2. Roll the scroll button.
I suspect that the scroll button controls may be slower due to mouse configuration.

If you still have issues, I'll need a good detailed description of the steps you're taking, size of the mesh you're loading and what you see, because... well, I can't see what you're seeing

Best regards,
Bruno
wyldckat is offline   Reply With Quote

Old   June 9, 2014, 08:33
Default
  #12
Member
 
Luca
Join Date: Mar 2011
Location: Germany
Posts: 38
Rep Power: 6
marluc is on a distinguished road
Dear Bruno,

and...yes...it works with the right mouse button pressed!! Actually I didn't know that way of zooming with Paraview...Thank you very much for the hint!!!!!

The zoom with the roll button is still very slow, even with the "Lock Interactive Render" set to "0".

But it doesn't matter...I will learn to use the other way of zooming

As usual many, many thanks.
Luca
wyldckat likes this.
marluc is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Paraview refuses to start after installation of OpenFoam flotus1 OpenFOAM Installation 12 March 6, 2014 15:42
CFX11 + Fortran compiler ? Mohan CFX 20 March 30, 2011 18:56
Statically Compiling OpenFOAM Issues herzfeldd OpenFOAM Installation 21 January 6, 2009 10:38
64bitrhel5 OF installation instructions mirko OpenFOAM Installation 2 August 12, 2008 18:07
Could anyone please help me in running the paraview in my Ubuntu system chanduksekhar OpenFOAM Paraview & paraFoam 2 February 6, 2006 10:13


All times are GMT -4. The time now is 08:13.