CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

foam-extend-3.1

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 9, 2014, 08:03
Default foam-extend-3.1
  #1
Member
 
Ashwani
Join Date: Sep 2013
Location: Hyderabad
Posts: 82
Rep Power: 3
AshwaniAssam is on a distinguished road
Hi all,

While trying to compile foam-extend-3.1 following the instruction given in doc/buildInstructions/Ubuntu/Ubuntu_14.04, most of the solvers got compliled. For dbns dolver under compressible flow, I am getting following error.
Quote:
g++ -m64 -Dlinux64 -DWM_DP -Wall -Wextra -Wno-unused-parameter -Wold-style-cast -Wnon-virtual-dtor -O3 -DNoRepository -ftemplate-depth-200 -I/home/ashwani/foam/foam-extend-3.1/src/finiteVolume/lnInclude -I/home/ashwani/foam/foam-extend-3.1/src/thermophysicalModels/basic/lnInclude -I/home/ashwani/foam/foam-extend-3.1/src/thermophysicalModels/specie/lnInclude -I/home/ashwani/foam/foam-extend-3.1/src/turbulenceModels/compressible/turbulenceModel -I/home/ashwani/foam/foam-extend-3.1/src/dbns/lnInclude -IlnInclude -I. -I/home/ashwani/foam/foam-extend-3.1/src/foam/lnInclude -I/home/ashwani/foam/foam-extend-3.1/src/OSspecific/POSIX/lnInclude -fPIC -Xlinker --add-needed -Xlinker --no-as-needed Make/linux64GccDPOpt/dbnsTurbFoam.o -L/home/ashwani/foam/foam-extend-3.1/lib/linux64GccDPOpt \
-lfiniteVolume -lbasicThermophysicalModels -lspecie -lcompressibleTurbulenceModel -lcompressibleRASModels -lcompressibleLESModels -ldbns -lfoam -liberty -ldl -lrt -lm -o /home/ashwani/foam/foam-extend-3.1/applications/bin/linux64GccDPOpt/dbnsTurbFoam
/usr/bin/ld: cannot find -ldbns
collect2: error: ld returned 1 exit status
When I ran ./foamInstallationTest I got the following error:

Quote:
Executing ./foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: ashwani-Lenovo-E4430
OS: Linux version 3.13.0-30-generic
-------------------------------------------------------------------------------


Checking main foam-extend env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/ashwani/foam yes yes
$WM_PROJECT_USER_DIR /home/ashwani/foam/ashwani-3.1 no no
$WM_THIRD_PARTY_DIR ...wani/foam/foam-extend-3.1/ThirdParty yes yes
-------------------------------------------------------------------------------


Checking the foam-extend env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/ashwani/foam/foam-extend-3.1 yes yes yes

$FOAM_APPBIN ...3.1/applications/bin/linux64GccDPOpt no yes
$FOAM_SITE_APPBIN ...ni/foam/site/3.1/bin/linux64GccDPOpt no no
$FOAM_USER_APPBIN ...3.1/applications/bin/linux64GccDPOpt no no
$WM_DIR /home/ashwani/foam/foam-extend-3.1/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the foam-extend env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN .../foam-extend-3.1/lib/linux64GccDPOpt no yes
$FOAM_SITE_LIBBIN ...ni/foam/site/3.1/lib/linux64GccDPOpt no no
$FOAM_USER_LIBBIN ...foam/ashwani-3.1/lib/linux64GccDPOpt no no
$MPI_ARCH_PATH /usr yes no yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of foam-extend
Supplied version: 4.3.3
User version : 4.8.2
Minimum required: 4.3.1

gcc 4.8.2
WARNING: Conflicting installations:
foam-extend settings : /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.6 /bin/gzip
tar 1.27.1 /bin/tar
icoFoam
WARNING: Conflicting installations:
foam-extend settings : /home/ashwani/foam/foam-extend-3.1/applications/bin/linux64GccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------


Summary
-------------------------------------------------------------------------------
Base configuration ok.

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.
Can anyone please help. I have OpenFOAM 2.3.0 also installed via source on the same machine. And I using aliases to switch between the two. I am able to run other solvers within foam-extend-3-1.
AshwaniAssam is offline   Reply With Quote

Old   July 15, 2014, 07:30
Default
  #2
New Member
 
Jens
Join Date: Apr 2014
Posts: 26
Rep Power: 3
jensi_t is on a distinguished road
Hi Ashwani,

i've a similar problem with dbns on a sles cluster. I didn't solve it yet but i think that it has s.th. to do with the ThirdParty applications. Some of them create libraries in the usr/bin/ directory by default which needs root permission. E.g. for mesquite I tried to change the prefix as I don't have root access. It didn't help..
For you perhaps compiling ThirdParty as root helps.
If you or someone else found the answer please post it as fast as possible .

Thank you,
Jens
jensi_t is offline   Reply With Quote

Old   July 23, 2014, 08:59
Default
  #3
New Member
 
Jens
Join Date: Apr 2014
Posts: 26
Rep Power: 3
jensi_t is on a distinguished road
Hi,

i still didn't solve the problem. ext 3.1 works on my local suse(gcc4.8.1) machine so perhaps the compiler i use is too old (gcc 4.5.0). DId you try to update it? When I compile the src/dbns libraries I got the following error:

ThirdParty/packages/ParMGridGen-1.0/platforms/linux64GccDPOpt/lib/libMGridGen.so: undefined reference to `memcpy@GLIBC_2.14'

A colleague said that this also indicates a gcc problem.

Hope someone can help us.

Cheers,
Jens
jensi_t is offline   Reply With Quote

Old   August 1, 2014, 08:02
Default
  #4
New Member
 
Jens
Join Date: Apr 2014
Posts: 26
Rep Power: 3
jensi_t is on a distinguished road
Hey guys,

this is my last try. Does anybody know why ParMGridGen is asking for GLIBC_2.14. I successfully compiled fe31 on an CentOS 6.3 cluster where
ldd --version gives ldd (GNU libc) 2.12
so 2.14 shouldn't be required (SLES System has 2.11.1).

Thanks for your help!

Jens
jensi_t is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
error message with modeling a cube with a hold at the center hsingtzu OpenFOAM Native Meshers: blockMesh 2 March 14, 2012 10:56
mesh airfoil NACA0012 anand_30 OpenFOAM Meshing & Mesh Conversion 12 December 12, 2011 05:16
BlockMesh FOAM warning gaottino OpenFOAM Native Meshers: blockMesh 7 July 19, 2010 14:11
Axisymmetrical mesh Rasmus Gjesing (Gjesing) OpenFOAM Native Meshers: blockMesh 10 April 2, 2007 14:00
Import gmsh msh to Foam adorean Open Source Meshers: Gmsh, Netgen, CGNS, ... 24 April 27, 2005 08:19


All times are GMT -4. The time now is 15:06.