CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Flex problem when building OpenFOam 3.0.x

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 20, 2015, 09:18
Default Flex problem when building OpenFOam 3.0.x
  #1
Senior Member
 
BastiL
Join Date: Mar 2009
Posts: 488
Rep Power: 12
bastil is on a distinguished road
Hello,

I have loaded the latest OpenFOAM 3.0.x and I try to install it using system openmpi (1.10), system gcc (4.9.3) and system flex (2.6.0) on Gentoo x86_64.

When building the applications I ran in flex issues which I thought where resolved years ago:

Code:
undefined reference to `yyFlexLexer::yywrap()
This happens for many apps like ansysToFoam and prevents lots of applications to be build afterwards. I tried an older flex out of the 2.5.x-series as well but I get the same issue. I don't know how to fix this issue.
bastil is offline   Reply With Quote

Old   December 20, 2015, 18:20
Default
  #2
Super Moderator
 
Bruno Santos
Join Date: Mar 2009
Location: Lisbon, Portugal
Posts: 9,531
Blog Entries: 39
Rep Power: 97
wyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nicewyldckat is just really nice
Quick answer: See the posts from this thread, as the same issue occurs on ArchLinux and the 2 part solution is given there in 2 posts of mine: Building OpenFOAM 3.0 on ArchLinux
wyldckat is offline   Reply With Quote

Old   December 23, 2015, 05:39
Default
  #3
Senior Member
 
BastiL
Join Date: Mar 2009
Posts: 488
Rep Power: 12
bastil is on a distinguished road
Thanks. Downgrading flex followed by a complete rebuild solved the issue.
bastil is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Map of the OpenFOAM Forum - Understanding where to post your questions! wyldckat OpenFOAM 5 April 11, 2016 11:48
Can OpenFoam solve this problem? salazardetroya OpenFOAM Running, Solving & CFD 1 July 29, 2015 22:34
Problem when installing Openfoam 2.0.x with mac giovaniharyadi OpenFOAM Installation 0 March 24, 2012 19:45
OpenFOAM 1.7.1 installation problem on Fedora 14 armonica OpenFOAM Installation 16 March 31, 2011 13:16
OpenFOAM Install problem masb OpenFOAM 3 May 25, 2009 11:32


All times are GMT -4. The time now is 00:38.