CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFOAM Install Script

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 27, 2009, 10:42
Default here is the output #deb cdr
  #21
amz
Guest
 
Posts: n/a
here is the output

#deb cdrom:[Ubuntu 8.10 _Intrepid Ibex_ - Release i386 (20081029.5)]/ intrepid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://au.archive.ubuntu.com/ubuntu/ intrepid main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ intrepid main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://au.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted
deb-src http://au.archive.ubuntu.com/ubuntu/ intrepid-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://au.archive.ubuntu.com/ubuntu/ intrepid universe
deb-src http://au.archive.ubuntu.com/ubuntu/ intrepid universe
deb http://au.archive.ubuntu.com/ubuntu/ intrepid-updates universe
deb-src http://au.archive.ubuntu.com/ubuntu/ intrepid-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://au.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ intrepid multiverse
deb http://au.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse
deb-src http://au.archive.ubuntu.com/ubuntu/ intrepid-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://au.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse
# deb-src http://au.archive.ubuntu.com/ubuntu/ intrepid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
# deb http://archive.canonical.com/ubuntu intrepid partner
# deb-src http://archive.canonical.com/ubuntu intrepid partner

# Line commented out by installer because it failed to verify:
#deb http://security.ubuntu.com/ubuntu intrepid-security main restricted
# Line commented out by installer because it failed to verify:
#deb-src http://security.ubuntu.com/ubuntu intrepid-security main restricted
# Line commented out by installer because it failed to verify:
#deb http://security.ubuntu.com/ubuntu intrepid-security universe
# Line commented out by installer because it failed to verify:
#deb-src http://security.ubuntu.com/ubuntu intrepid-security universe
# Line commented out by installer because it failed to verify:
#deb http://security.ubuntu.com/ubuntu intrepid-security multiverse
# Line commented out by installer because it failed to verify:
#deb-src http://security.ubuntu.com/ubuntu intrepid-security multiverse
  Reply With Quote

Old   January 27, 2009, 11:02
Default Looks to be ok... Before we
  #22
New Member
 
Join Date: Mar 2009
Posts: 25
Rep Power: 8
jlakovic is on a distinguished road
Looks to be ok...

Before we do anything else, try a simple

sudo apt-get update

and then, for 'cmake', 'firebird', 'build-essential' and 'flex', do

aptitude search NAME_OF_PACKAGE

to check if the missing packages are now available. (If aptitude is not installed, do sudo apt-get install aptitude)
jlakovic is offline   Reply With Quote

Old   February 8, 2009, 12:20
Default Good day for all foamers; *
  #23
Member
 
hamdi
Join Date: Mar 2009
Posts: 72
Rep Power: 8
hamcer is on a distinguished road
Good day for all foamers;

*I used ubuntu 8.10 system in my sony laptop, i done the script installation for OF-1.5 created by Jure (great Thanks), but when the script runs, I shown like these warning:
......
......
qchar.h:59: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:60: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:239: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:240: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:241: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:326: warning: type qualif: In member function 'bool
...
....
QPdfBaseEnginePrivate::openPrintDevice()':
painting/qpdf.cpp:1567: warning: deprecated conversion from string constant to 'char*'
painting/qpdf.cpp:1573: warning: deprecated conversion from string constant to 'char*'
painting/qpdf.cpp:1575: warning: deprecated conversion from string constant to 'char*'
painting/qpdf.cpp:1583: warning: deprecated conversion from string constant
...
....


*2nd thing, I didn't show the Qt icons in the star menu

but when i run qtdemo, it works,
also the tutorials of OF examples worked well and, i can display the paraview to show them

I didn't know if my installation is complete !!

Thanks in advance for your help.
hamcer is offline   Reply With Quote

Old   February 8, 2009, 12:35
Default Good day for all foamers; *
  #24
Member
 
hamdi
Join Date: Mar 2009
Posts: 72
Rep Power: 8
hamcer is on a distinguished road
Good day for all foamers;

*I used ubuntu 8.10 system in my sony laptop, i done the script installation for OF-1.5 created by Jure (great Thanks), but when the script runs, I shown like these warning:
......
......
qchar.h:59: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:60: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:239: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:240: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:241: warning: type qualifiers ignored on function return type
../../include/QtCore/../../src/corelib/tools/qchar.h:326: warning: type qualif: In member function 'bool
...
....
QPdfBaseEnginePrivate::openPrintDevice()':
painting/qpdf.cpp:1567: warning: deprecated conversion from string constant to 'char*'
painting/qpdf.cpp:1573: warning: deprecated conversion from string constant to 'char*'
painting/qpdf.cpp:1575: warning: deprecated conversion from string constant to 'char*'
painting/qpdf.cpp:1583: warning: deprecated conversion from string constant
...
....


*2nd thing, I didn't show the Qt icons in the star menu

but when i run qtdemo, it works,
also the tutorials of OF examples worked well and, i can display the paraview to show them

I didn't know if my installation is complete !!

Thanks in advance for your help.
hamcer is offline   Reply With Quote

Old   February 8, 2009, 13:11
Default Your OpenFOAM installation is
  #25
New Member
 
Join Date: Mar 2009
Posts: 25
Rep Power: 8
jlakovic is on a distinguished road
Your OpenFOAM installation is complete if the command

foamInstallationTest

displays no other errors than a possible conflict in gcc versions and / or failing to detect the availability of a remote shell.

Your ParaView / PV3FoamReader installation is complete if ParaView can properly open any OpenFOAM case (which, judging by your message, it does).

So congratulations on successfully getting it to work!
jlakovic is offline   Reply With Quote

Old   February 8, 2009, 13:20
Default hi Jure ! Thanks for your scr
  #26
Member
 
hamdi
Join Date: Mar 2009
Posts: 72
Rep Power: 8
hamcer is on a distinguished road
hi Jure !
Thanks for your script

but when I run foamInstallationTest , it crashed , I didn't know the Pb.

Thanks again
hamcer is offline   Reply With Quote

Old   February 8, 2009, 13:55
Default hi! Now I know: when i type
  #27
Member
 
hamdi
Join Date: Mar 2009
Posts: 72
Rep Power: 8
hamcer is on a distinguished road
hi!

Now I know: when i type ". foamInstallationTest "it crashed (with point); without point "foamInstallationTest" it works normaly; but, I have error
FATAL ERROR : No remote shell available,

Can I ignored it?. else what the solution
hamcer is offline   Reply With Quote

Old   February 8, 2009, 14:01
Default Please read my post again.
  #28
New Member
 
Join Date: Mar 2009
Posts: 25
Rep Power: 8
jlakovic is on a distinguished road
Please read my post again.
jlakovic is offline   Reply With Quote

Old   February 8, 2009, 14:20
Default hi! Jure. Sorry for my quik s
  #29
Member
 
hamdi
Join Date: Mar 2009
Posts: 72
Rep Power: 8
hamcer is on a distinguished road
hi! Jure.
Sorry for my quik sends.
if I understood, I can ignore this error, since I am the only user.

ThanKs.
hamcer is offline   Reply With Quote

Old   February 18, 2009, 09:27
Default Jure, As a new Ubuntu and L
  #30
New Member
 
Joseph
Join Date: Mar 2009
Location: Halifax, NS
Posts: 14
Rep Power: 8
jnattia is on a distinguished road
Jure,

As a new Ubuntu and Linux user thanks a lot for this script. it's great. I ran it on ubuntu 8.04 but encountered a few issues and was hoping to get some advice from yourself or any of the other Linux experts here:

1. I ran script #2 and entered answers and passwords as needed by the script but noticed that during running it said "at line 83: home/.../OpenFOAM-1.5/etc/bashrc permission denied". not sure if that's the cause of installation failure. foamInstallationTest tells me FATAL ERROR: environment not configured.

2. the OpenFOAM folder created by the script is protected as a root permission only folder. so i'm unable to even remove things to re-run the script on a clean system.

3. I re-ran script #2 onto the old installation but got the same errors.

4. when i try to access the bashrc file under etc in the OpenFOAM folder i find it completely empty.

5. the baffling issue also, is that when i start a terminal i get this error before even the prompt: "bash: /home/joe/OpenFOAM/OpenFOAM-1.5/etc/bashrc: Permission denied" ????

the rest of the builds seem to have worked fine.

I know all of the above could be very basic issues but i'd appreciate any help.

regards,
Joseph
jnattia is offline   Reply With Quote

Old   February 18, 2009, 09:49
Default Did you run any of the scripts
  #31
New Member
 
Join Date: Mar 2009
Posts: 25
Rep Power: 8
jlakovic is on a distinguished road
Did you run any of the scripts as root?
jlakovic is offline   Reply With Quote

Old   February 18, 2009, 10:10
Default No. do i need to? my sudo comm
  #32
New Member
 
Joseph
Join Date: Mar 2009
Location: Halifax, NS
Posts: 14
Rep Power: 8
jnattia is on a distinguished road
No. do i need to? my sudo commands are working.
jnattia is offline   Reply With Quote

Old   February 18, 2009, 10:17
Default You should not install OF as r
  #33
New Member
 
Andreas Feymark
Join Date: Mar 2009
Location: Gothenburg, Sweden
Posts: 18
Rep Power: 8
feymark is on a distinguished road
You should not install OF as root. But if you need to add some packages via apt-get these will require root password.
feymark is offline   Reply With Quote

Old   February 18, 2009, 10:29
Default I provided the root password w
  #34
New Member
 
Joseph
Join Date: Mar 2009
Location: Halifax, NS
Posts: 14
Rep Power: 8
jnattia is on a distinguished road
I provided the root password when script asked for it.
jnattia is offline   Reply With Quote

Old   February 18, 2009, 10:33
Default You wrote: --- 2. the Open
  #35
New Member
 
Join Date: Mar 2009
Posts: 25
Rep Power: 8
jlakovic is on a distinguished road
You wrote:

---
2. the OpenFOAM folder created by the script is protected as a root permission only folder. so i'm unable to even remove things to re-run the script on a clean system.
---

This happens only if the script is run as root...

Anyway, to solve this, try

cd
sudo chown -R joe:joe OpenFOAM
jlakovic is offline   Reply With Quote

Old   February 18, 2009, 10:48
Default Jure, this is great. thanks
  #36
New Member
 
Joseph
Join Date: Mar 2009
Location: Halifax, NS
Posts: 14
Rep Power: 8
jnattia is on a distinguished road
Jure,

this is great. thanks.
Problems 2, 4 and 5 are now gone. but still foamInstallationTest gives me a FATAL ERROR.

thanks
Joe
jnattia is offline   Reply With Quote

Old   February 18, 2009, 11:43
Default should i remove this OpenFOAM
  #37
New Member
 
Joseph
Join Date: Mar 2009
Location: Halifax, NS
Posts: 14
Rep Power: 8
jnattia is on a distinguished road
should i remove this OpenFOAM dir created by the script and re-run it?
jnattia is offline   Reply With Quote

Old   February 18, 2009, 11:53
Default Hello Joseph,
  #38
Member
 
Maruthamuthu Venkatraman
Join Date: Mar 2009
Location: Norway
Posts: 80
Rep Power: 8
maruthamuthu_venkatraman is on a distinguished road
Hello Joseph,
I have some problems while installing OpenFoam Script and have to rerun againdue to improper paraview installation. I deleted both OpenFoam folder and also "src" directory.

After running the Script, then all works fine No worries till now...

May be it answers your Query.

Regards
maruthamuthu_venkatraman is offline   Reply With Quote

Old   February 18, 2009, 12:41
Default Thanks everyone for the help.
  #39
New Member
 
Joseph
Join Date: Mar 2009
Location: Halifax, NS
Posts: 14
Rep Power: 8
jnattia is on a distinguished road
Thanks everyone for the help.

Works just fine now.
jnattia is offline   Reply With Quote

Old   March 5, 2009, 10:28
Default Hi, I'm an absolute newbi on
  #40
New Member
 
Andreas Falk
Join Date: Mar 2009
Posts: 1
Rep Power: 0
schneemann is on a distinguished road
Hi,
I'm an absolute newbi on linux and i need to install OpenFoam on my computer.
I already have installed Ubuntu 8.10.
But I don't really know how to use the skript above.
Can you tell me how to make it run, please?

Thanks for your help.
schneemann is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install OpenFoam in Windows XP robert_dekker OpenFOAM Installation 4 October 20, 2010 21:15
install the openfoam aya CFX 4 July 23, 2008 07:58
How to run Openfoam in a cluster after I install it xiuying OpenFOAM Installation 5 May 5, 2008 12:54
OpenFOAM and Paraview install issues spridal86 OpenFOAM Installation 7 February 13, 2008 14:15
Having problems to Install OpenFOAM 13 release of PowerLab2 ed_teller OpenFOAM Installation 0 June 11, 2007 10:50


All times are GMT -4. The time now is 09:44.