CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Installation using the precompiled binaries on Suse 103 (http://www.cfd-online.com/Forums/openfoam-installation/57203-installation-using-precompiled-binaries-suse-103-a.html)

pamdirac March 6, 2009 21:43

Hi Everyone, I have been tr
 
Hi Everyone,

I have been trying to install OpenFoam on my Suse 10.3 server. After spending some time getting the right path for the libraries in the openfoam install directory for the precompiled binaries in ld.so.conf. When I try to run the applications like Q or mhdFoam. I am getting segmentation faults. Can anyone help me? I am currently trying to install the compiled version and am still working out the library paths for that. any info on that would greatly help as well.

Below is the output of ldd for one of mhdFoam (which is typical output) and a copy of the application giving me a segment fault.

William


=================================================
william@kentbrockman:~/OpenFOAM/OpenFOAM-1.5/applications/bin/linux64GccDPOpt> ldd ./mhdFoam
libfiniteVolume.so => /home/william/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/libfiniteVolume.so (0x00002b22ab51c000)
libOpenFOAM.so => /home/william/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpenFOAM.so (0x00002b22ac1fb000)
libdl.so.2 => /lib64/libdl.so.2 (0x00002b22ac7e1000)
libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002b22ac9e6000)
libm.so.6 => /lib64/libm.so.6 (0x00002b22accee000)
libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002b22acf41000)
libc.so.6 => /lib64/libc.so.6 (0x00002b22ad150000)
libPstream.so => /home/william/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/openmpi-1.2.6/libPstream .so (0x00002b22ad496000)
libtriSurface.so => /home/william/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/libtriSurface.so (0x00002b22ad6a1000)
libmeshTools.so => /home/william/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/libmeshTools.so (0x00002b22ad914000)
libz.so => /usr/lib64/libz.so (0x00002b22adcc1000)
/lib64/ld-linux-x86-64.so.2 (0x00002b22ab2ff000)
libmpi.so.0 => /home/william/OpenFOAM/OpenFOAM-1.5/ThirdParty/openmpi-1.2.6/platforms/linux64Gc cDPOpt/lib/libmpi.so.0 (0x00002b22aded7000)
liblagrangian.so => /home/william/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/liblagrangian.so (0x00002b22ae163000)
libopen-rte.so.0 => /home/william/OpenFOAM/OpenFOAM-1.5/ThirdParty/openmpi-1.2.6/platforms/linux64Gc cDPOpt/lib/libopen-rte.so.0 (0x00002b22ae36b000)
libopen-pal.so.0 => /home/william/OpenFOAM/OpenFOAM-1.5/ThirdParty/openmpi-1.2.6/platforms/linux64Gc cDPOpt/lib/libopen-pal.so.0 (0x00002b22ae5c5000)
libnsl.so.1 => /lib64/libnsl.so.1 (0x00002b22ae826000)
libutil.so.1 => /lib64/libutil.so.1 (0x00002b22aea3e000)
libpthread.so.0 => /lib64/libpthread.so.0 (0x00002b22aec41000)
william@kentbrockman:~/OpenFOAM/OpenFOAM-1.5/applications/bin/linux64GccDPOpt>
william@kentbrockman:~/OpenFOAM/OpenFOAM-1.5/applications/bin/linux64GccDPOpt> ./mhdFoam
Segmentation fault
william@kentbrockman:~/OpenFOAM/OpenFOAM-1.5/applications/bin/linux64GccDPOpt>

dmoroian March 9, 2009 04:05

Hello William, I have an Open
 
Hello William,
I have an OpenSuse 10.3 box, and the binary release did not work for me, thus I had to compile the sources.
However, as a basic principle, you don't have to fiddle with any environment variable, everything is set up by the bashrc script.
Bottom line, my suggestion is to compile the sources.

Dragos


All times are GMT -4. The time now is 22:27.