CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

ProblemGCC compiler

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 5, 2009, 05:51
Default Hello all, When I try to ru
  #1
Member
 
Raghavendra
Join Date: Mar 2009
Location: Goteborg, Sweden
Posts: 94
Rep Power: 8
raagh77 is on a distinguished road
Send a message via Yahoo to raagh77 Send a message via Skype™ to raagh77
Hello all,

When I try to run blockMesh for the cavity tutorial case I found some errors (as mentioned at the end) is that because of gcc compiler or with the sourcing OpenFOAM installation!?

error..

blockMesh: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by blockMesh)
blockMesh: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /apps/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/libmeshTools.so)
blockMesh: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /apps/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/libdynamicMesh.so)
blockMesh: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /apps/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/libOpenFOAM.so)
blockMesh: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /apps/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/libtriSurface.so)
blockMesh: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /apps/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/liblagrangian.so)
blockMesh: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /apps/OpenFOAM/OpenFOAM-1.5/lib/linux64GccDPOpt/libfiniteVolume.so)
raagh77 is offline   Reply With Quote

Old   March 5, 2009, 05:54
Default ..contd also when I run foa
  #2
Member
 
Raghavendra
Join Date: Mar 2009
Location: Goteborg, Sweden
Posts: 94
Rep Power: 8
raagh77 is on a distinguished road
Send a message via Yahoo to raagh77 Send a message via Skype™ to raagh77
..contd

also when I run foamInstallationTest obtained the following message

[prabhu@pcher00350 bin]$ foamInstallationTest
Executing /apps/OpenFOAM/OpenFOAM-1.5/bin/foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: csh
Host: pcher00350
OS: Linux version 2.6.9-22.ELsmp
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /apps/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/prabhu/OpenFOAM/prabhu-1.5 yes no
$WM_THIRD_PARTY_DIR /apps/OpenFOAM/ThirdParty yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /apps/OpenFOAM/OpenFOAM-1.5 yes yes yes

$FOAM_APPBIN ...1.5/applications/bin/linux64GccDPOpt yes yes yes
$FOAM_USER_APPBIN ...1.5/applications/bin/linux64GccDPOpt yes yes no
$WM_DIR /apps/OpenFOAM/OpenFOAM-1.5/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...OAM/OpenFOAM-1.5/lib/linux64GccDPOpt yes yes yes
$FOAM_USER_LIBBIN ...nFOAM/prabhu-1.5/lib/linux64GccDPOpt yes yes no
$MPI_ARCH_PATH ...nmpi-1.2.6/platforms/linux64GccDPOpt yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version : 3.4.4
Minimum required: 4.2.0

gcc 3.4.4
WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.3 /usr/bin/gzip
tar 1.14 /bin/tar
icoFoam .../OpenFOAM-1.5/applications/bin/linux64GccDPOpt/icoFoam
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_pcher00350 Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the OpenFOAM enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

The foam installation contains 1 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.

[prabhu@pcher00350 bin]$


awaiting for replies
raagh77 is offline   Reply With Quote

Old   March 5, 2009, 06:25
Default I would try the following: In
  #3
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 382
Rep Power: 9
gwierink is on a distinguished road
I would try the following:
Install "libstdc++.so.6", install gcc and gcc-c++, and check that you have sourced OpenFOAM in your ~/.bashrc with ". $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc".
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Old   March 5, 2009, 08:06
Default Hello Raghavendra, The listin
  #4
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
Hello Raghavendra,
The listing is explicit enough:
Quote:
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version : 3.4.4
Minimum required: 4.2.0

gcc 3.4.4

WARNING: Conflicting installations:
OpenFOAM settings : /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR
This means you have a too old gcc compiler. In fact it is so old that I don't think you will be able to compile even a newer compiler with it (like gcc 4.3.3).
dmoroian is offline   Reply With Quote

Old   March 5, 2009, 10:30
Default @ Dragos and Gijsbert Than
  #5
Member
 
Raghavendra
Join Date: Mar 2009
Location: Goteborg, Sweden
Posts: 94
Rep Power: 8
raagh77 is on a distinguished road
Send a message via Yahoo to raagh77 Send a message via Skype™ to raagh77
@ Dragos and Gijsbert

Thanks for the replies..
I will contact the system admin and make sure new version of gcc compiler will be installed.

Thanks again for the support

Regards
Raghavendra
raagh77 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gcc compiler shuo OpenFOAM Running, Solving & CFD 5 October 15, 2006 05:43
Gcc compiler shuo OpenFOAM Running, Solving & CFD 1 October 7, 2006 04:15
set compiler f77 andromeda Main CFD Forum 0 July 9, 2006 08:35
Compiler for UDF Alamgir FLUENT 5 July 31, 2002 20:44
C++ Compiler for UDF Dmitriy Makarov FLUENT 1 December 12, 2000 03:41


All times are GMT -4. The time now is 02:23.