CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Cc1plus error libmpfrso1not found

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   October 20, 2008, 02:12
Default Hi, Again you are right. Th
  #41
ep4
Member
 
Pattyn Eric
Join Date: Mar 2009
Posts: 61
Rep Power: 8
ep4 is on a distinguished road
Hi,

Again you are right. The version given by ld --version was 2.15.
I have successfully installed Binutils 2.18, then gmp 4.2.2 but I have again a problem with mpfr 2.3.2. The make command gives a problem "warning: Clock skew detected. your build may be incomplete".
I have read on this forum that it should not be important. But when running "make check", I have an error (see below).

Should I install mpfr even if there is this error ? When I suppressed the additional line in my .bashrc file, the gcc compiler used is a 3.4.6-8 version. Could it be the problem ? Should I install mpfr 2.3.1 and not mpfr 2.3.2 ?

Thank you.

ranlib .libs/libfrtests.a
creating libfrtests.la
(cd .libs && rm -f libfrtests.la && ln -s ../libfrtests.la libfrtests.la)
gcc -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_STDARG=1 -DHAVE_SYS_TIME_H=1 -DHAVE_SETLOCALE=1 -DHAVE_GETTIMEOFDAY=1 -DMPFR_HAVE_FESETROUND=1 -DHAVE_DENORMS=1 -DHAVE_FLOOR=1 -DHAVE_CEIL=1 -DHAVE_LDOUBLE_IEEE_EXT_LITTLE=1 -DHAVE_ATTRIBUTE_MODE=1 -DHAVE_ALLOCA_H=1 -I. -I.. -I.. -Wall -Wmissing-prototypes -g -O2 -MT tversion.o -MD -MP -MF .deps/tversion.Tpo -c -o tversion.o tversion.c
mv -f .deps/tversion.Tpo .deps/tversion.Po
/bin/sh ../libtool --tag=CC --mode=link gcc -Wall -Wmissing-prototypes -g -O2 -o tversion tversion.o libfrtests.la -lm ../libmpfr.la -lgmp
gcc -Wall -Wmissing-prototypes -g -O2 -o .libs/tversion tversion.o ./.libs/libfrtests.a -lm ../.libs/libmpfr.so -lgmp -Wl,--rpath -Wl,/usr/local/lib
../.libs/libmpfr.so: undefined reference to `__gmp_get_memory_functions'
collect2: ld returned 1 exit status
make[2]: *** [tversion] Fehler 1
make[2]: Leaving directory `/net/ric_home/ep4/Desktop/mpfr-2.3.2/tests'
make[1]: *** [check-am] Fehler 2
make[1]: Leaving directory `/net/ric_home/ep4/Desktop/mpfr-2.3.2/tests'
make: *** [check-recursive] Fehler 1
ep4 is offline   Reply With Quote

Old   October 20, 2008, 06:35
Default I haven't had problems with cl
  #42
Member
 
Ville Tossavainen
Join Date: Mar 2009
Location: Helsinki, Finland
Posts: 60
Rep Power: 8
villet is on a distinguished road
I haven't had problems with clock skew. Anyway, have you compiled mpfr this way (I think gmp wasn't found):

./configure --prefix=/x/mpfr-2.3.1 --with-gmp=/x/gmp-4.2.2
villet is offline   Reply With Quote

Old   October 20, 2008, 06:51
Default The command ./configure --pref
  #43
ep4
Member
 
Pattyn Eric
Join Date: Mar 2009
Posts: 61
Rep Power: 8
ep4 is on a distinguished road
The command ./configure --prefix=/x/mpfr-2.3.1 --with-gmp=/x/gmp-4.2.2 says that the gmp.h and the libgmp files are not of the same version.
I only have installed one thing found on http://gmplib.org/#DOWNLOAD.

Should I installed something else ?

checking for alloca... yes
checking for __gmpz_init in -lgmp... yes
checking if gmp.h version and libgmp version are the same... (4.2.4/4.1.4) no
configure: WARNING: 'gmp.h' and 'libgmp' seems to have different versions or
configure: WARNING: we cannot run a program linked with GMP (if you cannot
configure: WARNING: see the version numbers above).
configure: WARNING: However since we can't use 'libtool' inside the configure,
configure: WARNING: we can't be sure. See 'config.log' for details.
configure: creating ./config.status
config.status: creating Makefile
config.status: creating tests/Makefile
config.status: creating mparam.h
config.status: executing depfiles commands
ep4 is offline   Reply With Quote

Old   October 21, 2008, 01:46
Default It's getting quite tricky. Che
  #44
Member
 
Ville Tossavainen
Join Date: Mar 2009
Location: Helsinki, Finland
Posts: 60
Rep Power: 8
villet is on a distinguished road
It's getting quite tricky. Check the MPFR documentation (INSTALL file in source code) and try to add more parameters to find GMP. Do you have a system admistrator who can help you?
villet is offline   Reply With Quote

Old   October 21, 2008, 02:25
Default Hi, Like you suggested yest
  #45
ep4
Member
 
Pattyn Eric
Join Date: Mar 2009
Posts: 61
Rep Power: 8
ep4 is on a distinguished road
Hi,

Like you suggested yesterday, the problem was related to the path for gmp. There is different place where libgmp files appear. MPFR has compiled correctly with the command:
./configure --with-gmp-lib=/usr/local/lib

Nevertheless, I still have the my first error when compiling paraview. Maybe, it could be also due to the same problem.
Does somoene know how i could change the path definitively ?
I also accept any other suggestions...

Thank you

Eric
ep4 is offline   Reply With Quote

Old   October 21, 2008, 04:28
Default You should now include the lib
  #46
Member
 
Ville Tossavainen
Join Date: Mar 2009
Location: Helsinki, Finland
Posts: 60
Rep Power: 8
villet is on a distinguished road
You should now include the libraries for the new compiler:

export LD_LIBRARY_PATH=/usr/local/lib:/x/mpfr-2.3.1/lib
villet is offline   Reply With Quote

Old   October 21, 2008, 08:12
Default I'm now installing Qt 4.4.3 bu
  #47
ep4
Member
 
Pattyn Eric
Join Date: Mar 2009
Posts: 61
Rep Power: 8
ep4 is on a distinguished road
I'm now installing Qt 4.4.3 but I have not suppressed the old one. They are not in the same directories:

old one: /usr/lib64/qt-3.3.3
new one: /us/local/lib64/Qt-4.4.3

When i compile Paraview, it uses the old version. qmake --version gives me 3.3.3.. What can i do to change the path and the application used for the compilation of Paraview?

Thanks a lot

Eric
ep4 is offline   Reply With Quote

Old   October 21, 2008, 08:43
Default Stupid question: after 'hash -
  #48
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 777
Rep Power: 18
olesen will become famous soon enough
Stupid question: after 'hash -r' or 'rehash', does "type qmake" (or "which qmake") return /usr/local/bin/qmake first?
olesen is offline   Reply With Quote

Old   October 21, 2008, 08:48
Default The commands you proposed me g
  #49
ep4
Member
 
Pattyn Eric
Join Date: Mar 2009
Posts: 61
Rep Power: 8
ep4 is on a distinguished road
The commands you proposed me give these results:

[root@wobwslx2 ep4]# hash -r
[root@wobwslx2 ep4]# type qmake
qmake is /usr/bin/qmake
[root@wobwslx2 ep4]# which qmake
/usr/bin/qmake
[root@wobwslx2 ep4]# rehash
bash: rehash: command not found

Eric
ep4 is offline   Reply With Quote

Old   October 21, 2008, 09:40
Default Eric, If you get "qmake is
  #50
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 777
Rep Power: 18
olesen will become famous soon enough
Eric,

If you get "qmake is /usr/bin/qmake", then the old qmake is apparently still being found first in your PATH (as you saw with qmake --version). It seems reasonable that cmake also takes this first one (/usr/bin/qmake) and determines that you'd likely wish to link in /usr/lib64/qt*.

Try placing the new one first in your PATH.
olesen is offline   Reply With Quote

Old   October 21, 2008, 09:44
Default My question was: how should i
  #51
ep4
Member
 
Pattyn Eric
Join Date: Mar 2009
Posts: 61
Rep Power: 8
ep4 is on a distinguished road
My question was: how should i try to place the new one first in my path.
I don't know which command i should use.

Eric
ep4 is offline   Reply With Quote

Old   October 21, 2008, 12:55
Default Eric, Assuming that you're
  #52
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 777
Rep Power: 18
olesen will become famous soon enough
Eric,

Assuming that you're not suffering a minor blackout, you need to grab yourself a basic book on Unix/Linux.

You seem to be using bash/ksh/sh, since 'hash -r' worked, but 'rehash' (csh) didn't.

To see your path:
echo $PATH

Add a directory to the front of your path:

PATH=/usr/local/bin:$PATH; export PATH

The export isn't actually needed, since PATH has already been exported, but it doesn't hurt.

If 'type qmake' still points to the old version, try 'hash -r' to clear the rehash the lookup and see if 'type qmake' and 'qmake --version' are doing what you want.
olesen is offline   Reply With Quote

Old   October 22, 2008, 02:11
Default Hello, Thank you for your h
  #53
ep4
Member
 
Pattyn Eric
Join Date: Mar 2009
Posts: 61
Rep Power: 8
ep4 is on a distinguished road
Hello,

Thank you for your help. Now it works except that the version 4.4.3 is not supported. I had read that but actually i hadn't found a version 4.3.x. Does somebody know where i could dowload this version?

Eric
ep4 is offline   Reply With Quote

Old   October 22, 2008, 03:07
Default Search through the forum. Some
  #54
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 777
Rep Power: 18
olesen will become famous soon enough
Search through the forum. Someone was complaining about the Readme being slightly inaccurate, since you can actually use a newer qt if you edit a file (or two). You should be posting further stuff on that thread, since you've strayed quite far from the original topic (libmpfr.so.1 not found).
olesen is offline   Reply With Quote

Old   February 4, 2009, 10:32
Default Hi. I'm trying to use the foam
  #55
New Member
 
John Paul Handrigan
Join Date: Mar 2009
Location: Ottawa, Ontario, Canada
Posts: 16
Rep Power: 8
jphandrigan is on a distinguished road
Hi. I'm trying to use the foamToTecPlot utility, but I get the following error. I don't have root access, and I'm wondering if there's anyway to fix the below problem. I get the same 'libmpfr.so.1' error that has been mentioned above. Thanks in advance!

[actmodel@r4-bcc-loki11 foamToTecplot]$ wmake

make: Warning: File `Make/linux64GccDPOpt/dontIncludeDeps' has modification time 0.00052 s in the future
make: warning: Clock skew detected. Your build may be incomplete.
SOURCE=foamToTecplot.C ; g++ -m64 -Dlinux64 -DDP -Wall -Wno-strict-aliasing -Wextra -Wno-unused-parameter -Wold-styl e-cast -march=opteron -O3 -DNoRepository -ftemplate-depth-40 -I/mnt/hypatia/linux_home/rhel4_home/actmodel/OpenFOAM/ OpenFOAM-1.5/src/finiteVolume/lnInclude -IlnInclude -I. -I/mnt/hypatia/linux_home/rhel4_home/actmodel/OpenFOAM/OpenFO AM-1.5/src/OpenFOAM/lnInclude -I/mnt/hypatia/linux_home/rhel4_home/actmodel/OpenFOAM/OpenFOAM-1.5/src/OSspecif ic/Unix /lnInclude -fPIC -c $SOURCE -o Make/linux64GccDPOpt/foamToTecplot.o
/mnt/hypatia/linux_home/rhel4_home/actmodel/OpenFOAM/ThirdParty/gcc-4.3.1/platfo rms/linux64/bin/../libexec/gcc/x86_64 -unknown-linux-gnu/4.3.1/cc1plus: error while loading shared libraries: libmpfr.so.1: cannot open shared object file: No such file or directory
make: *** [Make/linux64GccDPOpt/foamToTecplot.o] Error 1
jphandrigan is offline   Reply With Quote

Old   February 4, 2009, 10:44
Default John: This is a common proble
  #56
Senior Member
 
musaddeque hossein
Join Date: Mar 2009
Posts: 307
Rep Power: 9
musahossein is on a distinguished road
John:
This is a common problem with OpenFoam that I have faced. The libmpfr.so.1 needs to be installed in the root directory - and should come with your linux distribution. If not, you can download it from several sites on the internet - you will have to do a google search if you dont have a site already. Either way, you will need access to the root file for this error to go away.
musahossein is offline   Reply With Quote

Old   February 4, 2009, 10:46
Default Musaddeque, Thanks. I guess I
  #57
New Member
 
John Paul Handrigan
Join Date: Mar 2009
Location: Ottawa, Ontario, Canada
Posts: 16
Rep Power: 8
jphandrigan is on a distinguished road
Musaddeque,
Thanks. I guess I'll have to get my administrator on the go. :P
jphandrigan is offline   Reply With Quote

Old   February 22, 2009, 06:23
Default Dear Niels Gjoel Jacobsen
  #58
Member
 
Nugroho Adi
Join Date: Mar 2009
Location: norway
Posts: 79
Rep Power: 8
mahaputra is on a distinguished road
Dear Niels Gjoel Jacobsen


i followed your guideline on http://www.student.dtu.dk/~ngja/OF_u...eOnCluster.pdf


but when i have been on the 8th step
(8. Go to mpfr2.
x.x and execute the following:
a) $ ./configure prefix=$
HOME/install withgmp=$
HOME/install)


i got error message :


[user@localhost mpfr-2.4.0]$ ./configure --prefix=$HOME/install --with-gmp=$HOME/install
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to disable maintainer-specific portions of Makefiles... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: in `/home/user/OpenFOAM/mpfr-2.4.0':
configure: error: C compiler cannot create executables
See `config.log' for more details.


i already looked at config.log

but since im a new user in OpenFOAM, i dont understand the error information on config.log


could you please help me? or anybody?



tusen takk
mahaputra is offline   Reply With Quote

Old   February 22, 2009, 12:41
Default it could be that mpfr is not i
  #59
Senior Member
 
musaddeque hossein
Join Date: Mar 2009
Posts: 307
Rep Power: 9
musahossein is on a distinguished road
it could be that mpfr is not included in the build of linux that you are using or that you did not load it from your linux boot disc. Check to make sure that you have loaded the version of mpfr that is requried.
musahossein is offline   Reply With Quote

Old   February 23, 2009, 10:05
Default Hi Musaddeque thanks. yup y
  #60
Member
 
Nugroho Adi
Join Date: Mar 2009
Location: norway
Posts: 79
Rep Power: 8
mahaputra is on a distinguished road
Hi Musaddeque

thanks. yup you correct

and i did mistake , i sourced

$HOME/OpenFOAM/OpenFOAM1.5/etc/bashrc

and $HOME/.bashrc

so i have to delete that source refers to installation file or make it as #comment


i can manage to configure gcc4.3.1 (follow http://www.student.dtu.dk/~ngja/OF_u...eOnCluster.pdf)

but i got another errors on step 13th (13. make j N check # takes quite some time)


as shown below :


[user@localhost gcc-build]$ make -j 1 check
make[1]: Entering directory `/home/user/localSrc/gcc-build'
make[2]: Entering directory `/home/user/localSrc/gcc-build/fixincludes'
autogen -T .././../gcc-4.3.1/fixincludes/check.tpl .././../gcc-4.3.1/fixincludes
/inclhack.def
make[2]: autogen: Command not found
make[2]: *** [check] Error 127
make[2]: Leaving directory `/home/user/localSrc/gcc-build/fixincludes'
make[1]: *** [check-fixincludes] Error 2
make[1]: Leaving directory `/home/user/localSrc/gcc-build'
make: *** [do-check] Error 2



somebody could give me any suggestions? please
mahaputra is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
injection not found in domain error San FLUENT 3 March 17, 2009 23:24
Error found in stress tutorial mike_jaworski OpenFOAM Running, Solving & CFD 0 September 23, 2007 02:34
Error: Finite angle gap could not be found Richard CFX 0 December 8, 2005 09:39
Boundaries not found error Simone CD-adapco 2 June 13, 2005 07:36
No warning or error messages found. Atit Koonsrisuk CFX 5 January 14, 2003 12:06


All times are GMT -4. The time now is 06:04.