CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   FOAM installation compiler issues (http://www.cfd-online.com/Forums/openfoam-installation/57240-foam-installation-compiler-issues.html)

gareth__it_power February 9, 2009 09:27

Hello, I am totally new to
 
Hello,

I am totally new to both OpenFoam and Linux Ubuntu, which is the OS I'm using. I'm probably pretty computer-illiterate compared to most of you lot!

I've had endless problems so far, but the latest one is something to do with gcc compiler (I don't really know what that is).

The excerpt from the InstalltionTest is below. I'd be very grateful for any advice please!

Thank you

Gareth

Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version :
Minimum required: 4.2.0

gcc .../OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc
gzip 1.3.12 /bin/gzip
tar 1.19 /bin/tar
icoFoam
WARNING: Conflicting installations:
OpenFOAM settings : /home/itpower/OpenFOAM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/icoFoam
current path :
CRITICAL ERROR

-------------------------------------------------------------------------------

dmoroian February 9, 2009 09:35

Hello Gareth, Is it possible
 
Hello Gareth,
Is it possible that you unpacked only the sources (OpenFOAM-1.5.General.gtgz)?
If so, you must unpack the binaries, too (OpenFOAM-1.5.linux64GccDPOpt.gtgz).
The order is or used to be important (first sources, second binaries).

I hope this is helpful,
Dragos

mathieu February 9, 2009 10:01

Hi Gareth, It looks like yo
 
Hi Gareth,

It looks like your installation is set to 32 bits. If it is what you really want, then you'll need to download the 32 bits binaries from this web page:

http://www.opencfd.co.uk/openfoam/linux.html

If your computer is 64 bits, then unset the $WM_32 variable in your .bashrc.

Mathieu

gareth__it_power February 9, 2009 10:06

Dragos - yes, it's all unpacke
 
Dragos - yes, it's all unpacked. Thanks

Matthieu - thanks for that, it sounds promising. Is it in the $HOME/.bashrc? How do I 'unset' it?

mathieu February 9, 2009 11:52

Just comment this line: # e
 
Just comment this line:

# export WM_32=1

in the $HOME/.bashrc file.

Mathieu

gareth__it_power February 9, 2009 11:57

I don't have that line in the
 
I don't have that line in the $HOME/.bashrc file!?

dmoroian February 9, 2009 12:38

I think he meant in $HOME/Open
 
I think he meant in $HOME/OpenFOAM/OpenFOAM-1.5/etc/bashrc

mathieu February 9, 2009 15:12

Does this commands: echo $W
 
Does this commands:

echo $WM_ARCH

returns " linux " or " linux64 " ?


Typing " wm64 " in a terminal should set your environment in 64 bits. Thus try the following in a terminal:

wm64
foamInstallationTest

Mathieu


All times are GMT -4. The time now is 13:23.