CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFOAM15 on Ubuntu810 (http://www.cfd-online.com/Forums/openfoam-installation/57253-openfoam15-ubuntu810.html)

forsumit November 10, 2008 15:17

Hi Guys, I am having troubl
 
Hi Guys,

I am having trouble with the last step of installation of Open-FOAM. I am using Ubuntu-8.10.

I am able to install Open-FOAM but compilation of ParaView is giving me trouble. When I follow the steps mentioned in the download page it gives me the error about cmake file not found.

I have also tried the version 1.5.x and get the same results.

I installed Qt-4.3.4 which is working properly, I confirmed by typing in qtdemo.

Any help or suggestion will be greatly appreciated.

Thanks,
Sumit

forsumit November 10, 2008 17:37

Just to give a detail info of
 
Just to give a detail info of the error message that I am getting.

Building ParaView3.3-cvs
MPI support : OFF
Python support : OFF
MESA support : OFF
Source : /home/sumit/OpenFOAM/ThirdParty/ParaView3.3-cvs
Target : /home/sumit/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc
/home/sumit/OpenFOAM/OpenFOAM-1.5.x/bin/buildParaView3.3-cvs: 88: cmake: not found
make: *** No targets specified and no makefile found. Stop.
done

If any one got any hints, it will be greatly appreciated.

Thanks,
Sumit

msrinath80 November 10, 2008 17:51

sudo apt-get install cmake
 
sudo apt-get install cmake

forsumit November 10, 2008 18:03

Hey Srinath, Thanks for the
 
Hey Srinath,

Thanks for the reply but now I am getting some other message.

Building ParaView3.3-cvs
MPI support : OFF
Python support : OFF
MESA support : OFF
Source : /home/sumit/OpenFOAM/ThirdParty/ParaView3.3-cvs
Target : /home/sumit/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc
CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
/home/sumit/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux64/bin
CMake Error: Error executing cmake::LoadCache(). Aborting.

make: *** No targets specified and no makefile found. Stop.
done

Can help me further?

Thanks,
Sumit

gwierink November 11, 2008 14:06

Hi Sumit, I had a similar p
 
Hi Sumit,

I had a similar problem and installing Qt-4.3.5 fixed it.

Cheers, Gijsbert

lhcamilo November 12, 2008 03:15

provided you have the right qt
 
provided you have the right qt, you have to download the packages specified in this link
http://ubuntuforums.org/showpost.php...2&postcount=46

lhcamilo November 12, 2008 03:16

oh you might wanna make sure t
 
oh you might wanna make sure that you have "build-essential" package installed and installing cmake won't hurt either

dado November 18, 2008 05:26

Hi Guys, I have problem with
 
Hi Guys,
I have problem with installing the OpenFoam (1.5.x) on the Ubuntu 8.10!

8.10 is coming with Qt4-4 and I don't know how to get the Qt4-3 version.

Then, I saw that the new version of the Para View is 3.4. Is it possible to install it instead for the v3.3 (without so much complications)?

Any help or suggestion will be greatly appreciated.

Thanks,
Dado

lhcamilo November 18, 2008 05:46

ok, this mahy sound weird, I a
 
ok, this mahy sound weird, I am running I have a partition with hardy (8.04) and a partition with intrepid (8.10)[64 bit]. Obviously hardy runs without a hitch.Since I am preparing to dump my hardy partition soon in order to start testing the new release 9.04 (jaunty) I decided to test OF on intrepid. Since I didn't want to have to download all the files again I just copied all my OF-1.5 folder onto my intrepid /home (I did also edit the bashrc file). Oddly enough it worked, the paraFoam command loads paraview without a hitch.

I've run qmake and it does not show anyversion installed.

is it possible that it is still linked to the hardy files, or it just works? since I have some kde programs here I reckon some qt libraries should be installed.

if that doesn't work, you may just use the seach for packages engine in firefox to search for the appropriate hardy version packages.

gschaider November 18, 2008 09:15

Hi Dado! I don't know about
 
Hi Dado!

I don't know about Ubuntu, but I'm using paraview3.4 on my MacBook right now. The only modifications I had to do were:
- copy the buildParaview-script and modify it to have the right version number
- modify etc/apps/paraview3/bashrc (or cshrc if that is your drug of choice)
- start a new terminal
- compile paraview and the PV-plugin the way it is described in the README

Bernhard

PS: OK. I did some other modifications to the script, but those had to do with enabling Python

sxhdhi November 18, 2008 20:55

Hi Dado, I just installed t
 
Hi Dado,

I just installed them sucessfully on Ubuntu8.10.

Actually I met the same problem as yours.
The solution is you have to download qt-x11-opensource-src-4.3.5.tar firstly, next,configure it to ~/ThirdParty/Qt4.3.5, make, then make install, at last follow the instruction in installation guide step 7.1 and 7.2.


try above steps you can get it.

Su Xiaohui

dado November 19, 2008 02:47

Thanks, I will try it when I a
 
Thanks, I will try it when I am at home.

Regards
/dado

hsieh December 10, 2008 21:27

Dear FOAMers: I tried to in
 
Dear FOAMers:

I tried to install OF-1.5 on 64 bit Ubuntu 8.10.

I have installed the following:
cmake, libmpfr-dev libmpfr1|db|, installed qt-4.3.5 to ThirdParty/Qt-4.3.5.

(qmake --version showed corrected Qt version - 4.3.5).

I still got the following error:
--------------------------------

peiyinghsieh@ubuntu:~/OpenFOAM/ThirdParty$ qmake --version
QMake version 2.01a
Using Qt version 4.3.5 in /home/peiyinghsieh/OpenFOAM/ThirdParty/Qt-4.3.5/lib
peiyinghsieh@ubuntu:~/OpenFOAM/ThirdParty$ buildParaView3.3-cvs
Building ParaView3.3-cvs
MPI support : OFF
Python support : OFF
MESA support : OFF
Source : /home/peiyinghsieh/OpenFOAM/ThirdParty/ParaView3.3-cvs
Target : /home/peiyinghsieh/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc
CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
/home/peiyinghsieh/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux64/bin
CMake Error: Error executing cmake::LoadCache(). Aborting.

make: *** No targets specified and no makefile found. Stop.
done
peiyinghsieh@ubuntu:~/OpenFOAM/ThirdParty$
-----------------------

On my SuSE 11.0 systems, I had no problem.

Any suggestion?

Pei

lhcamilo December 11, 2008 03:39

Doesn't paraview work out of t
 
Doesn't paraview work out of the box without having to compile on ubuntu 8.10, I have installed it on two ubuntu 8.10 boxes (amd64), with the latest qt (4.4.3) and they ran paraview (paraFoam) just fine. This also seems to be the case with fedora 10.

hsieh December 12, 2008 11:00

Hi, Leonardo, On my Ubuntu
 
Hi, Leonardo,

On my Ubuntu 8.10 64, I was not able to run paraFoam. Also, display kinda looked strange when using paraview (after foamToVTK).

I tried Ubnutu 8.10 32 bit, and did not get the cmake error. Acutally, paraview starts to compile after comment out the Qt check (using native Qt (4.4.0?) intalled with Ubuntu). I will check if this completes paraview reader compilation too.

So, I suspect cmake under OpenFOAM/ThirdParty did not find correct library for 64 bit OS, hence causing the "CMake Error: Could not find CMAKE_ROOT !!! "

Pei

hsieh December 13, 2008 10:15

Hi, On Ubuntu 8.1 32 bit,
 
Hi,

On Ubuntu 8.1 32 bit, I was able to install Qt-4.3.5, and recompiled paraview and paraFoam successfully.

Next step is to find out how to resolve the CMAKE_ROOT error on 64 bit OS.

Pei

maruthamuthu_venkatraman December 22, 2008 09:19

Hello OpenFOAM users,
 
Hello OpenFOAM users,
I just now started to instal Openfoam on my 32 bit system on UBUNTU platform. Iam new to LINUX and found difficulty in installing the same. I have 2 errors in the foaminstalltion test which is attached for your reference. If anybody could guide me then it will save my time.

Thanks,
Muthu

ERROR:
-------------------------------------------------------------------------------
Shell: bash
Host: ubuntu
OS: Linux version 2.6.27-9-generic
-------------------------------------------------------------------------------


Checking main OpenFOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/muthu/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/muthu/OpenFOAM/muthu-1.5 yes no
$WM_THIRD_PARTY_DIR /home/muthu/OpenFOAM/ThirdParty yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/muthu/OpenFOAM/OpenFOAM-1.5 yes yes yes

$FOAM_APPBIN ...M-1.5/applications/bin/linuxGccDPOpt yes yes yes
$FOAM_USER_APPBIN ...u-1.5/applications/bin/linuxGccDPOpt yes yes no
$WM_DIR /home/muthu/OpenFOAM/OpenFOAM-1.5/wmake yes yes yes
-------------------------------------------------------------------------------


Checking the OpenFOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...nFOAM/OpenFOAM-1.5/lib/linuxGccDPOpt yes yes yes
$FOAM_USER_LIBBIN ...OpenFOAM/muthu-1.5/lib/linuxGccDPOpt yes yes no
$MPI_ARCH_PATH ...penmpi-1.2.6/platforms/linuxGccDPOpt yes yes yes
-------------------------------------------------------------------------------


Third party software
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
WARNING: gcc version does not match gcc supplied with this release of OpenFOAM
Supplied version: 4.3.1
User version : ../src/configure
4.3.2
Minimum required: 4.2.0

gcc ...figure
WARNING: Conflicting installations:
OpenFOAM settings : /home/muthu/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

gzip 1.3.12 /bin/gzip
tar 1.20 /bin/tar
icoFoam ...AM/OpenFOAM-1.5/applications/bin/linuxGccDPOpt/icoFoam
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_ubuntu Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Unsuccessful_connection_refused* yes
FATAL ERROR: No remote shell available.
OpenFOAM 1.5 enviroment requires either ssh and/or rsh.
Contact your system administrator.


-------------------------------------------------------------------------------

The system test has evoked 1 fatal error(s).

The foam installation contains 1 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

done.

kumar December 22, 2008 09:45

Hello Mr.Maruthamuthu,
 
Hello Mr.Maruthamuthu,

From the error message that you have posted I can see that the gcc version installed on your computer is not matching with the one required for OF-1.5. And the other error is due to ssh. You have to install ssh or rsh on your computer for remote connection.Just

# sudo apt-get install openssh-server openssh-client
this will install ssh on your computer.

If you look in the forum or search for a script to install OpenFOAM on UBUNTU. you can find a script to install OF-1.5. I used this script to install OF-1.5 on UBUNTU 8..

I suggest you to use this script. If you cannot find this script, let me know I will send you the location .
bye.
K.Suresh kumar

lhcamilo December 22, 2008 09:46

You problems are not exaclty s
 
You problems are not exaclty serious, just go to a terminal windows and paste this

sudo apt-get install gcc

this should sort things out (there's another solution but I would rather not go there)

as for the other error, it has to do with ssh, unless you are going to use multiple computers in a network to calculate a case, then I wouldn't worry about it.

maruthamuthu_venkatraman December 22, 2008 10:48

Hello, Thanks for your commen
 
Hello,
Thanks for your comments. If you could send me the installation script location for OPENFOAM 1.5 suitable for UBUNTU 8.1 platform that would be useful to me.

I also found that ParaFOAM is not installed properly. To avoid all such bugs, let me install everything correctly by running the working script.

Note: i found one post in the following link . I am not sure will it be applicable for 8.10 Ubuntu.

http://www.cfd-online.com/OpenFOAM_D...tml?1222736035

Thanks


All times are GMT -4. The time now is 09:51.