CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Installation of OpenFoam 15 Compilation paraview (http://www.cfd-online.com/Forums/openfoam-installation/57262-installation-openfoam-15-compilation-paraview.html)

soeren_brot July 16, 2008 15:22

Dear all, i tried to instal
 
Dear all,

i tried to install OpenFoam 1.5 today, everything looks fine until the compilation of paraview.

Additional information:
-Ubuntu 8.04
-"qmake --version
QMake version 2.01a
Using Qt version 4.3.4 in /usr/lib"
-OpenFoam 1.4.1 worked properly

As I am a more or less beginner in Linux, I used the the "installation guide" on the website and especially the README file.

Typing the commands:
* cd $FOAM_INST_DIR/ThirdParty
* rm -rf ParaView3.3-cvs/platforms
* buildParaView3.3-cvs

the last one produces following error message:

"soeren@soeren-laptop:~/OpenFOAM/ThirdParty$ buildParaView3.3-cvs
Building ParaView3.3-cvs
MPI support : OFF
Python support : OFF
MESA support : OFF
Source : /home/soeren/OpenFOAM/ThirdParty/ParaView3.3-cvs
Target : /home/soeren/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc
-- Check for working C compiler: /home/soeren/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc
-- Check for working C compiler: /home/soeren/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc -- broken
CMake Error: The C compiler "/home/soeren/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc" is not able to compile a simple test program.
It fails with the following output:
/usr/bin/make -f CMakeFiles/cmTryCompileExec.dir/build.make CMakeFiles/cmTryCompileExec.dir/build
make[1]: Betrete Verzeichnis '/home/soeren/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/CMakeFiles/ CMakeTmp'
/home/soeren/OpenFOAM/ThirdParty/cmake-2.4.6/platforms/linux/bin/cmake -E cmake_progress_report /home/soeren/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/CMakeFiles/C MakeTmp/CMakeFiles 1
Building C object CMakeFiles/cmTryCompileExec.dir/testCCompiler.o
/home/soeren/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/gcc -o CMakeFiles/cmTryCompileExec.dir/testCCompiler.o -c /home/soeren/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/CMakeFiles/C MakeTmp/testCCompiler.c
/home/soeren/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux/bin/../libexec/gcc/i6 86-pc-linux-gnu/4.3.1/cc1: error while loading shared libraries: libmpfr.so.1: cannot open shared object file: No such file or directory
make[1]: *** [CMakeFiles/cmTryCompileExec.dir/testCCompiler.o] Fehler 1
make[1]: Verlasse Verzeichnis '/home/soeren/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linuxGcc/CMakeFiles/ CMakeTmp'
make: *** [cmTryCompileExec/fast] Fehler 2


CMake will not be able to correctly generate this project.
-- Configuring done
make: *** Keine Targets angegeben und keine ğmakeĞ-Steuerdatei gefunden. Schluss.
"

Seems that the compiler does not work...
I would greatly appreciate any help on how to resolve this problem!

Thanks a lot in advance

Sören

nzy102 July 16, 2008 16:25

I am having exactly the same p
 
I am having exactly the same problem.

olesen July 17, 2008 02:31

The new gcc requires gmp and m
 
The new gcc requires gmp and mpfr to be installed. The details and rationale can be found here: changes.html

They might not be installed by default on slightly older systems.

mgz1985 July 17, 2008 03:06

i am having a problem with ins
 
i am having a problem with installing openfoam.....my connection to ssh and rsh is failing...i work in a network.,....then when i run blockMesh . cavity

i get the error no such file or directory.but i have sourced the file correctly........can ne1 help me..it has been 2 weeks with this problem....

jros July 17, 2008 03:42

From synaptic in Ubuntu 8.04 i
 
From synaptic in Ubuntu 8.04 it seems that the packages you need are

libmpfr-dev

libmpfr1|dbl

May be that the second one is enough. Do a search in synaptic with the string mpfr and they will arise.

Javier

gitsnedbutzi July 20, 2008 10:38

hi, I have another problem
 
hi,

I have another problem with ParaView.
In my thirdparty folder there's no platforms directory and also no buildParaview3.3-cvs.

Why is that?

Thanks

soeren_brot July 22, 2008 04:56

Thanks a lot! Including "libm
 
Thanks a lot!
Including "libmpfr-dev + libmpfr1|dbl" resolved my problem, everything fine now!
Sören

ttdtud July 23, 2008 08:17

Hi, I have the exactly same
 
Hi,
I have the exactly same problem as Seoren.
However the configuration of my laptop a little different:
Debian
qmake --version
QMake version 2.01a
Using Qt version 4.3.1 in /usr/local/Trolltech/Qt-4.3.1/lib

And I got the entirely same error message as Seoren.
what should I do?

Thanks a lot!
Yu

torvic July 23, 2008 18:26

Hello ! I compiled Paraview
 
Hello !

I compiled Paraview and it works. I have SLED SP1 and installed from scratch the following:

gmp (with ABI=64)
mpfr
gcc-4.3.1 (in the same path as stated in the README)
qt-X11-opensource-src-4.3.5

and then buildParaView3.3-cvs, which worked.

However, with Qt-4.3.1 it compiled as well, but, I had the problem regarding ".OpenFOAM" extension, and hence got to do the FoamToVTK procedure as Alberto suggest in a similar thread.

Hope it helps

best

V

noredine July 24, 2008 02:23

Hello, I have same problem
 
Hello,

I have same problem as Soeren had.

my question is that i dont find libmpfr1|dbl. I have ubuntu 8.04.

Thnks,

Noureddine

mgz1985 July 24, 2008 02:36

hi while installing openFoam-1
 
hi while installing openFoam-1.5, when i m trying to source the file, i am getting errors

bash:~/............./apps/bin/foamcleanpath:no such file or directory...
bash:~/.................../apps.paraview:no such file or directory

such a thing is coming for many apps.

can sum1 help?

nishant_hull August 14, 2008 10:38

I am trying to install openfoa
 
I am trying to install openfoam-1.5 and I can successfully run the case with bloclkmesh and solver commands (like icoFoam etc)
But paraFoam command is not working well.
I have qt-4.3.5 installed by default in my FEDORA-9. I checked the GMP and MPFR installation as well. The error it is reposting is:-


[343880@w191-210 channel395]$ paraFoam
paraview: error while loading shared libraries: libQtAssistantClient.so.4: cannot open shared object file: No such file or directory

can anybody help?

regards,
Nishant

jaswi August 14, 2008 17:07

Hi Nishant I guess compilat
 
Hi Nishant

I guess compilation is the only way out as
the README document has explicity mentioned that
the binaries of installation version will work only with Qt-4.3.1 .

Please be kind to study the README and installation document provided . here is the link:

http://www.opencfd.co.uk/openfoam/doc/README.html

Please scroll down on this page and it details all the possible solutions.

Hope that might solve your problem.

With Best Regards
Jaswi

lin August 14, 2008 17:43

Hello,Nishant Singh I us
 
Hello,Nishant Singh

I use fedora9,it works for me.For the missing file,libQtAssistantClient.so.4,you need to install the package qt-x11-4.3.5-2.fc9.i386.

Hope it helps

gbrother August 14, 2008 21:25

Nishant, I had to copy my Qt l
 
Nishant, I had to copy my Qt libs and .so files over to /usr/libs; than re-ran through the paraview3.3 steps in the install documentation. That seemed to work for me.

If you got as far as you say, then you're probably just missing this last part.

nishant_hull August 14, 2008 23:07

hi jaswi I go thru the REA
 
hi jaswi
I go thru the README file but I considered that the Qt version should be in between 4.3 and 4.4. Anyways, the problem at hand is that I have two installations of Qt - 1) qt 3.3 and 2) qt 4.3.5.
Linz, I installed the same package but 4.3.5 but in my case there is dual installation of qt 3.3 and 4.3.5.
Gene, I tried making a symbolic link through ln -s command for the lib folder b/w /usr/local/trolltech/qt-4.3.5/lib and /usr/lib/. but that didnt work. Will it be work, if i simply copy and recompile it? I will try this way.
Thanks all...

Nishant

lin August 14, 2008 23:25

Hello, Nishant Since I also
 
Hello, Nishant

Since I also use fedora 9,I could confirm that your problem is not related double qt version.For me,I also have two qt versions installed.

[root@phy-208 ~]# rpm -q qt
qt-4.3.5-2.fc9.i386
[root@phy-208 ~]# rpm -q qt3
qt3-3.3.8b-14.fc9.i386

The only answer I know is that you missing file libQtAssistantClient.so.4 is contained in the package qt-x11-4.3.5-2.fc9.i386.

mabinty August 21, 2008 10:40

Dear all! I have the same p
 
Dear all!

I have the same problem as Martin. when i have a look at the linuxGccDPOpt/ directory it is empty, when i want to generate a mesh for the cavity case, the bashrc doesn t know the blockMesh command:

[aa@lws16 icoFoam]$ blockMesh . cavity
bash: blockMesh: command not found

thx a lot in advance for any comments!

aram

xiaohezhu August 21, 2008 11:31

I tried to install OpenFoam 1.
 
I tried to install OpenFoam 1.5 today,I faced the problem just like Soeren described.
My OS is Mandriva2007,I have Qt version 4.3.2,
and today I have installed gmp4.2.1 and mpfr 2.3.1,I think these meet the install requirment .but I can't bulidparaview.

produces error message: like Soeren described


This is the first time for me to install OF.I feel so confused ,
could any one help me?Thanks a lot!

then August 28, 2008 22:01

Hi all, I am a new Linux us
 
Hi all,

I am a new Linux user and have Ubuntu 8.04 (64 bit) and OpenFOAM 1.5 (64 bit) on my laptop. The following is the error msg:

Building ParaView3.3-cvs
MPI support : OFF
Python support : OFF
MESA support : OFF
Source : /home/then/OpenFOAM/ThirdParty/ParaView3.3-cvs
Target : /home/then/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc
/home/then/OpenFOAM/OpenFOAM-1.5/bin/buildParaView3.3-cvs: 64: cmake: not found
make: *** No targets specified and no makefile found. Stop.
done

I followed the instructions in this thread and installed 2 libmpfr files, but still have the same error.

Still trying to figure out why... Any comments? Thanks.


All times are GMT -4. The time now is 11:16.