CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Paraview problem on OpenSuse (http://www.cfd-online.com/Forums/openfoam-installation/57271-paraview-problem-opensuse.html)

gizmo October 2, 2008 08:03

Hello, I'm new to this commu
 
Hello,
I'm new to this community and I'm a new OpenSuse user. I tried to install OpenFOAM on OpenSuse 11 and it just worked. The foamInstallationTest returned me 0 error.

But, when I'm trying to build paraview, I got this message:

"-- Application: default ParaView Client enabled
Qt ASSISTANT library not found.
Qt GUI library not found.
CMake Error: Error in cmake code at
/home/Gizmo/OpenFOAM/ThirdParty/ParaView3.3-cvs/Applications/Client/CMakeLists.t xt:533:
FILE GLOB requires a glob expression after the directory
Current CMake stack: /home/Gizmo/OpenFOAM/ThirdParty/ParaView3.3-cvs/Applications/Client/CMakeLists.t xt
CMake Error: Error in cmake code at
/home/Gizmo/OpenFOAM/ThirdParty/ParaView3.3-cvs/Applications/Client/CMakeLists.t xt:533:
FILE GLOB requires a glob expression after the directory
Current CMake stack: /home/Gizmo/OpenFOAM/ThirdParty/ParaView3.3-cvs/Applications/Client/CMakeLists.t xt
-- Application: Custom Server enabled
-- Application: DobranoViz enabled
-- Plugin: Prism enabled
-- Found Qt-Version 4.4.0
Qt GUI library not found.
-- Configuring done
make: *** Pas de cibles spécifiées et aucun makefile n'a été trouvé. Arrêt.
done"

I don't really understand what the problem is so it would be really great if someone could help me! ;-)


I had the same kind problem with Ubuntu Hardly Heron...

Thank you for your help.

olesen October 2, 2008 08:46

Check that you have the qt dev
 
Check that you have the qt devel packages installed. I have the following rpms installed:

libqt4-devel-doc
libqt4-x11
libqt4-sql
libqt4-devel
libqt4-devel-doc-data
libqt4
libqt4-qt3support
libqt4-dbus

gizmo October 2, 2008 16:54

I checked then I typed the com
 
I checked then I typed the command: rpm -qa libqt* in the terminal to be sure that I have the good ones (I found this command in another subject in this forum) and I still have exactly the same message :-(

Thank you for your help ;-)

Any other suggestion?

danielle October 4, 2008 23:19

I have the same problem http:/
 
I have the same problem http://www.cfd-online.com/OpenFOAM_D...lipart/sad.gif
what is the solution ?????
thanks for help

gizmo October 5, 2008 04:18

I solved the problem by downlo
 
I solved the problem by downloading and re-installing libqt4 packages with yast and it worked!

Tell me if your problem is solved ;-)

danielle October 5, 2008 22:53

Thanks Benjamin, The problem
 
Thanks Benjamin,
The problem still the same :-(
and I need see my results.

gizmo October 6, 2008 05:42

I have the following packages
 
I have the following packages installed on my OpenSuse (maybe there are not all needed but this can help you):

gcc
gcc-4.2
gcc-4.2-base
libqt-4-core
libqt-4-debug
libqt-4-dev
libqt-4-gui
libqt-4-qt3support
libqt-4-sql
libqthreads-12
libmpfr-dev

If Yast suggests you other packages while installing these, accept them.

Good luck ;-)

asddsa001 November 30, 2008 22:19

Did you installed the cmake pa
 
Did you installed the cmake package?

hellorishi December 8, 2008 11:32

I've installed gcc-4.3.1 in ad
 
I've installed gcc-4.3.1 in addition to the gcc on my current system (avoid conflicts).
Now I am trying to build ParaView as mentioned in guide, however I am stuck at this issue and have no clue... please help.
***********************************************
>buildParaView3.3-cvs
***********************************************
Building ParaView3.3-cvs
MPI support : OFF
Python support : OFF
MESA support : OFF
Source : /home/cfd2/OpenFOAM/ThirdParty/ParaView3.3-cvs
Target : /home/cfd2/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc
-- Check for working C compiler: /home/cfd2/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux64/bin/gcc
-- Check for working C compiler: /home/cfd2/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux64/bin/gcc -- works
-- Check size of void*
-- Check size of void* - done
-- Check for working CXX compiler: /home/cfd2/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux64/bin/c++
-- Check for working CXX compiler: /home/cfd2/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linux64/bin/c++ -- works
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
...
...
...
Found Qt-Version 4.3.2
CMake Error: This project requires some variables to be set,
and cmake can not find them.
Please set the following variables:
QT_X11_/home/cfd2/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc/Appli cations/CMakeFiles/CMakeTmpQmake/tmp.pro
_LIBRARY
QT_X11_/home/cfd2/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc/Qt/CM akeFiles/CMakeTmpQmake/tmp.pro
_LIBRARY
QT_X11_/home/cfd2/OpenFOAM/ThirdParty/ParaView3.3-cvs/platforms/linux64Gcc/VTK/G UISupport/Qt/CMakeFiles/CMakeTmpQmake/tmp.pro
_LIBRARY
QT_X11_/usr/local/Trolltech/Qt-4.3.2/mkspecs/default/qmake.conf.
Error_LIBRARY
QT_X11_Failure_LIBRARY
QT_X11_QMAKESPEC_LIBRARY
QT_X11_conf_LIBRARY
QT_X11_file:_LIBRARY
QT_X11_file_LIBRARY
QT_X11_processing_LIBRARY
QT_X11_project_LIBRARY
QT_X11_read_LIBRARY
QT_X11_to_LIBRARY

-- Configuring done
make: *** No targets specified and no makefile found. Stop.
done

gschaider December 9, 2008 09:51

Hi Rishi! Have a look at Ma
 
Hi Rishi!

Have a look at Mark's post above. Fastest way to check whether you have the packages described there would be

rpm -qa | grep qt4

My guess would be that the qt4-x11-packages are not installed on your machine.

Bernhard

hellorishi December 9, 2008 18:01

HI Bernhard, Well my situa
 
HI Bernhard,

Well my situation is pretty strange. I dont have direct internet access on this OF machine, so I cant install using rpm/YaST. To add to that, I cant generally install using rpm, since it tends to disturb settings/dependencies for other installed programs.

Hence I can only install the autoconf way:
./configure
make
su
make install

I have already installed qt4.3.2-x11 packages. I have a different error message today, after playing around with qt-x11.




> buildParaView3.3-cvs
************************************************** *******
....
....
-- Found Qt-Version 4.3.2
CMake Error: This project requires some variables to be set,
and cmake can not find them.
Please set the following variables:
QT_X11_Feature_LIBRARY
QT_X11_LOAD():_LIBRARY
QT_X11_Project_LIBRARY
QT_X11_be_LIBRARY
QT_X11_cannot_LIBRARY
QT_X11_found.
_LIBRARY
QT_X11_qt_config_LIBRARY

-- Configuring done
make: *** No targets specified and no makefile found. Stop.
done

************************************************** *******
possible problem:
/home/cfd2/OpenFOAM/ThirdParty/ParaView3.3-cvs/Applications/CMakeCache.txt
************************************************** *******
.....
.....
//The location of the Qt mkspecs
QT_MKSPECS_DIR:PATH=/usr/local/Trolltech/Qt-4.3.2/mkspecs

//The moc executable
QT_MOC_EXECUTABLE:FILEPATH=Project LOAD(); Feature qt_config cannot be found.
.....
.....
************************************************** *******


any further hints will be appreciated.
Thanks

gwierink December 10, 2008 15:11

Hi Rishi, Did you have a lo
 
Hi Rishi,

Did you have a look at Alberto Passalacqua's site yet? http://albertopassalacqua.com/?p=112
There he describes to get OpenFOAM-1.5 working in OpenSUSE-11.0.

Regards, Gijsbert

hellorishi December 11, 2008 12:49

Hello Gijsbert, Thanks for
 
Hello Gijsbert,

Thanks for the reply.

I looked at the post, but I cannot download from git, due to lack of internet access for Linux machines at my place and I cant install GIT software on XP, since its a univ library machine (from where I am writing this post). Only an http or ftp download is an option for me.

Now OF-1.5 is working. I installed ParaView-3.4. Still missing paraFoam: same old QT errors...

gwierink December 14, 2008 04:09

Ok, that complicates the issue
 
Ok, that complicates the issue a bit http://www.cfd-online.com/OpenFOAM_D...part/happy.gif. I have had a similar problem in Fedora and there it work to copy the Qt executable that lives somewhere in /usr/bin/.. or something to /home/<username>/bin/ . Then it worked. I don't know whether this solves your problem or whether it is very elegant, but it worked for me ...


All times are GMT -4. The time now is 18:03.