CFD Online Logo CFD Online URL
Home > Forums > OpenFOAM Installation

Installation of OpenFOAM15 on the SGI Altix 4700 LinuxIA64I64DP0pt

Register Blogs Members List Search Today's Posts Mark Forums Read

LinkBack Thread Tools Display Modes
Old   November 20, 2008, 17:10
Default Has anyone successfully compil
New Member
bong rhee
Join Date: Mar 2009
Location: bethesda, md, usa
Posts: 2
Rep Power: 0
rhee is on a distinguished road
Has anyone successfully compiled OpenFOAM-1.5 on the SGI Altix Itanium 64 machine? Or Has anyone have a piece of advice as to crack at my installation problems I have encountered?

I am struggling to compile OpenFOAM-1.5 on the SGI Altix 4700 Itanium 64 machine (linuxIA64I64).
When I run build script './Allwmake' at the top-level source dir, I get an error message saying "no such file or directory" found in linuxIA64I64 dir. For some reason the build script did not create that dir under rules dir. IOW there is no rule for wmake. Question 1: How come the build script did not create a rule for wmake? Is this something to do with a relativ new platform?

Makefile:61: /hafs5/rhee/OpenFOAM/OpenFOAM-1.5/wmake/rules/linuxIA64I64/general: No such file or directory

For the sake of my curiosity, I did a little experiment with wmake by blindly copying LinuxIA64I64 dir from OpenFOAM-1.4.1 onto OpenFOAM-1.5. I know this may not work because of compatibility issue. This time I get the following error messages including ones related to MPI library. I am aware that in order to properly compile MPI programs on the SGI Altix, I need to specify MPI option different from the one found in OpenFOAM.
hawk-0:/hafs5/rhee/OpenFOAM/OpenFOAM-1.5/ ./Allwmake
+ cd .
+ cd wmake/src
+ make
make: Nothing to be done for `all'.
+ cd /hafs5/rhee/OpenFOAM/ThirdParty
+ ./Allwmake
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ '[' -n '' ']'
+ wmake libso zlib-1.2.3
icpc: Command line error: no files specified; for help type "icpc -help"
make: *** [] Error 1
+ cd malloc
+ ./Allwmake
+ wmake libso hoard
icpc: Command line error: no files specified; for help type "icpc -help"
make: *** [] Error 1
+ wmake libo fbsdmalloc
ld -r -o libNULL.o
ld: no input files
make: *** [libNULL.o] Error 1
+ case "$WM_MPLIB" in
+ '[' -r /hafs5/rhee/OpenFOAM/ThirdParty/openmpi-1.2.6/platforms/linuxIA64I64DPOpt/lib/li ']'
+ echo 'have OPENMPI shared library'
have OPENMPI shared library
+ cd metis-5.0pre2
+ wmake libso GKlib
'/hafs5/rhee/OpenFOAM/OpenFOAM-1.5/lib/linuxIA64I64DPOpt/' is up to date.
+ wmake libs+ wmake libso dummy
SOURCE=Pstream.C ; icpc -DlinuxIA64 -DDP -wd654,819,1125,1476,1505,1572 -DICC_IA64_PREFETCH -ansi-alias -O3 -ftz -mP3OPT_ecg_swp_control=0x400000 -fno-alias -mtune=itanium2 -fargument-noalias-global -unroll0 -DNoRepository -IlnInclude -I. -I/hafs5/rhee/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/hafs5/rhee/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -KPIC -c $SOURCE -o Make/linuxIA64I64DPOpt/Pstream.o
/hafs5/rhee/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude/Pstream.H(45): catastrophic error: could not open source file "labelList.H"
#include "labelList.H"

compilation aborted for Pstream.C (code 4)
make: *** [Make/linuxIA64I64DPOpt/Pstream.o] Error 4
+ case "$WM_MPLIB" in
+ export WM_OPTIONS=linuxIA64I64DPOptOPENMPI
+ set +x

Note: ignore spurious warnings about missing mpicxx.h headers
+ wmake libso mpi
SOURCE=OPwrite.C ; icpc -DlinuxIA64 -DDP -wd654,819,1125,1476,1505,1572 -DICC_IA64_PREFETCH -ansi-alias -O3 -ftz -mP3OPT_ecg_swp_control=0x400000 -fno-alias -mtune=itanium2 -fargument-noalias-global -unroll0 -DNoRepository -DOMPI_SKIP_MPICXX -I/include -IlnInclude -I. -I/hafs5/rhee/OpenFOAM/OpenFOAM-1.5/src/OpenFOAM/lnInclude -I/hafs5/rhee/OpenFOAM/OpenFOAM-1.5/src/OSspecific/Unix/lnInclude -KPIC -c $SOURCE -o Make/linuxIA64I64DPOptOPENMPI/OPwrite.o
/default/rhee/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linuxIA64I64/bin/../includ e/c++/4.3.1/ia64-unknown-linux-gnu/bits/c++config.h(233): error: expected a "{"

/default/rhee/OpenFOAM/ThirdParty/gcc-4.3.1/platforms/linuxIA64I64/bin/../includ e/c++/4.3.1/bits/stringfwd.h(46): error: expected a "{"
rhee is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error using LaunderGibsonRSTM on SGI ALTIX 4700 jaswi OpenFOAM 2 April 29, 2008 10:54
Running Fluent on an SGI Altix machine Jonathan Vogt FLUENT 1 March 19, 2008 02:35
OF on Altix Itanium2 machine skabilan OpenFOAM Installation 0 December 14, 2007 05:04
Installation on an SGI Altix eviled OpenFOAM Installation 0 March 31, 2007 04:34
Building OpenFoAm on SGI Altix 64bits anne OpenFOAM Installation 8 June 15, 2006 09:27

All times are GMT -4. The time now is 17:58.