CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Pls help last problem to be solved for installing OPENfoam

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   November 7, 2008, 11:21
Default HI Follow all the instruction
  #1
New Member
 
lding
Join Date: Mar 2009
Posts: 4
Rep Power: 8
daydayuper is on a distinguished road
HI
Follow all the instructions of openfoam and related experience of others, and I have reached here, don;t know how to handle.
I find very strange while compiling openfoam with the following errors:
################################################## ##################
/home/dingliang/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:68: 68: error: iostream.h: no such file or directory
/home/dingliang/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:69: 23: error: iomanip.h: no such file or directory
/home/dingliang/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:70: 70: error: fstream.h: no such file or directory
/home/dingliang/OpenFOAM/ThirdParty/ParaView3.3-cvs/VTK/Common/vtkIOStream.h:129 :58: error: strstream.h: no such file or directory
..
################################################## ######################
i am quite new in Linux. But i just find in gcc directory and there exists iostream.h and other files. except the above errors, no other related errors. so pls someone could help?

Many thanks in advance!

Lding
daydayuper is offline   Reply With Quote

Old   November 8, 2008, 03:16
Default I USE UBUNTU 8.10 and have ins
  #2
New Member
 
lding
Join Date: Mar 2009
Posts: 4
Rep Power: 8
daydayuper is on a distinguished road
I USE UBUNTU 8.10 and have installed related libraries. can someone give some advice? Thanks.
daydayuper is offline   Reply With Quote

Old   November 8, 2008, 03:48
Default As an attempt, you can go in P
  #3
Senior Member
 
Francesco Del Citto
Join Date: Mar 2009
Location: Zürich Area, Switzerland
Posts: 215
Rep Power: 9
fra76 is on a distinguished road
As an attempt, you can go in Paraview3.3-cvs/platforms/[your_platform] and run "ccmake .". In the configuration window, toggle advanced mode on pressing "t" and look for CMAKE_CXX_FLAGS and CMAKE_C_FLAGS and modify them by adding: "-I/path/to/ThirdParty/gcc-4.3.1/platforms/yourplatform/include" or wherever your include directory containing missing headers is.
Then, press "c" to configure and "g" to generate and exit. Go back to ThirdParty directory and run buildParaView3.3-cvs with any argument, to avoid reconfiguring (for example, "buildParaView3.3-cvs 1").
If you are lucky enough, this could resolve your problem...

Francesco
fra76 is offline   Reply With Quote

Old   November 8, 2008, 13:11
Default Francesco I really apprecia
  #4
New Member
 
lding
Join Date: Mar 2009
Posts: 4
Rep Power: 8
daydayuper is on a distinguished road
Francesco
I really appreciate yr help and it worked. Thank you. BUT here when compling paraview, I met a new problem:
###
...
-- Looking for strtoll
-- Looking for strtoll - found
-- Check if system supports 64 bit streams
-- Check if system supports 64 bit streams - yes
-- Looking for malloc.h
-- Looking for malloc.h - found
-- Check if system supports 64 bit streams
-- Check if system supports 64 bit streams - yes
-- Found Qt-Version 4.3.2
-- Found Qt-Version 4.3.2
-- Application: default ParaView Client enabled
-- Application: Custom Server enabled
-- Application: DobranoViz enabled
-- Plugin: Prism enabled
-- Found Qt-Version 4.3.2
CMake Error: This project requires some variables to be set,
and cmake can not find them.
Please set the following variables:
OPENGL_INCLUDE_DIR (ADVANCED)

...
##########
seemed it can't find opengl? But i dn't know how to do.I googled it and serached my OS but can't find gl.h? some library not installed?
THANKS AGAIN
daydayuper is offline   Reply With Quote

Old   November 9, 2008, 05:07
Default Hi Iding, now depends on your
  #5
Senior Member
 
Francesco Del Citto
Join Date: Mar 2009
Location: Zürich Area, Switzerland
Posts: 215
Rep Power: 9
fra76 is on a distinguished road
Hi Iding,
now depends on your operating system. You have to install a package for developing graphical application. Something like x11-....-devel.
I'm on a Mac, now, and I cannot check a Linux installation.

Hope this helps, even if it's not so much...

Francesco
fra76 is offline   Reply With Quote

Old   November 9, 2008, 05:59
Default Hi lding, This should conta
  #6
Senior Member
 
Gijsbert Wierink
Join Date: Mar 2009
Posts: 383
Rep Power: 9
gwierink is on a distinguished road
Hi lding,

This should contain the right packages (at least on Fedora, in Ubuntu just grab anything with X11-..-devel via Synaptic):

yum groupinstall "X Software Development"

Rgds, Gijsbert
__________________
Regards, Gijs
gwierink is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem in Paraview While installing OpenFOAM 15 in Suse 103 altranindia OpenFOAM Installation 1 February 20, 2009 10:20
Installing OpenFOAM without Paraview quartzian OpenFOAM Installation 0 September 8, 2008 09:29
Installing OpenFOAM honcho OpenFOAM Installation 1 April 9, 2008 06:29
Problem installing OpenFOAM 141 sachin OpenFOAM Installation 2 February 22, 2008 11:20
Installing OpenFOAM on SuSE Linux 91 Lars Edvardsen (Edvardsen) OpenFOAM Installation 2 January 10, 2005 03:26


All times are GMT -4. The time now is 04:26.