CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Problem of paraFoam in OF15

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   September 29, 2008, 12:03
Default Hi all, I installed OF1
  #1
kai
New Member
 
Kai Liu
Join Date: Mar 2009
Location: Beijing, China
Posts: 6
Rep Power: 8
kai is on a distinguished road
Hi all,

I installed OF1.5 on my Fedora 9 system simply by extractiong all the binary packages as described in README. When I tested it with icoFoam's cavity case, the blockMesh and the solver icoFoam worked well, but the paraFoam programme told me it could not find a reader of the case. Now I can only use foamToVTK to see the result. So what is the problem and how to solve it?

Regards,
Kai
kai is offline   Reply With Quote

Old   September 29, 2008, 13:41
Default Hi You need QT4.3.x and yo
  #2
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Deltares, Delft, The Netherlands
Posts: 1,619
Rep Power: 25
ngj will become famous soon enoughngj will become famous soon enough
Hi

You need QT4.3.x and you need to compile paraFoam from scratch. Look in the README file for further informations.

It should be noted that on Fedora 9, QT4.4.x is the default, thus you need to download the source for QT4.3.x and compile that be yourself as well.

Further you will probably be needing libmpfr<something> for the gcc-compiler to be working.

Good luck,

Niels
__________________
Please note that I do not use the Friend-feature, so do not be offended, if I do not accept a request.
ngj is offline   Reply With Quote

Old   October 1, 2008, 02:50
Default Hi Niels, Thanks you for yo
  #3
kai
New Member
 
Kai Liu
Join Date: Mar 2009
Location: Beijing, China
Posts: 6
Rep Power: 8
kai is on a distinguished road
Hi Niels,

Thanks you for your advice.

Yes, I tried the buildParaView3.3-cvs method mentioned in README and failed. The reason may be QT version incompliant as you said. Now, should I delete the qt-4.4.1 on my system before installing qt4.3, or just simply compile qt4.3 in the case of qt4.4.1 existing ?

Regards,

Kai
kai is offline   Reply With Quote

Old   October 1, 2008, 03:14
Default You don't need to install qt4.
  #4
Member
 
Matthias Kern
Join Date: Mar 2009
Location: Karlsruhe, Germany
Posts: 36
Rep Power: 8
make is on a distinguished road
You don't need to install qt4.3!
I just compiled paraview using qt4.4.2.
Simply uncomment the qt check in the CMakeLists.txt.
There is a line starting with MESSAGE(SEND_ERROR "QT ${QTVERSION }.... Add a # in front.
It compiled without error and runs perfectly. Didn't even crach once since a use it.

regards,
Matthias
make is offline   Reply With Quote

Old   October 1, 2008, 03:31
Default Note that even a slight mis-ma
  #5
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 777
Rep Power: 18
olesen will become famous soon enough
Note that even a slight mis-match in qt versions can cause problems. I had paraview and the OpenFOAM reader module compiled with qt 4.3.3.
One of the machines had qt 4.3.1 installed, which meant that paraview started okay, but the reader module didn't load. Updating all the workstations to the same qt4.3.3 version eliminated the problem.
olesen is offline   Reply With Quote

Old   October 1, 2008, 12:36
Default Hi Matthias, Thanks a lot
  #6
kai
New Member
 
Kai Liu
Join Date: Mar 2009
Location: Beijing, China
Posts: 6
Rep Power: 8
kai is on a distinguished road
Hi Matthias,

Thanks a lot! I just followed your advice and successfully recompiled the paraFoam with qt-4.4.1. It runs well now. I cannot understand why the install guide says that versions older or newer than qt-4.3.x are not allowed.

Best regards,

Kai
kai is offline   Reply With Quote

Old   October 2, 2008, 02:31
Default Hi Kai, If you scan the par
  #7
Senior Member
 
Mark Olesen
Join Date: Mar 2009
Location: http://olesenm.github.io/
Posts: 777
Rep Power: 18
olesen will become famous soon enough
Hi Kai,

If you scan the paraview mailing lists, you'll see that building with various qt versions, or even debug vs. release, is a constantly recurring topic. The qt API might change a little between versions, the cmake files might be too stringent in allowing/disallowing particular qt versions, there may be qt bugs that paraview triggers in particular qt versions, or simply that the paraview developers have compiled with a particular version and don't know if it works well with a newer/older version.

I hope this explains why the install guide really isn't misleading. What if the install guide stated "you should use qt-4.3.x, unless you change the CMakeLists.txt, clean out all the old build remnants (and cmake cache files, and it might be necessary to remove the entire paraview directory and do a fresh cvs checkout too) and pray that all goes well when you compile against a different qt version"?

Scan the paraview mailing lists and you'll see what I mean. I am personally grateful for the buildParaview script provided with OpenFOAM - it has greatly improved my success rate with building paraview!
olesen is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with paraFoam wandeklein OpenFOAM Paraview & paraFoam 1 October 9, 2008 16:12
Parafoam problem mochzeen OpenFOAM Paraview & paraFoam 12 September 22, 2008 17:46
OF15 paraFoam Update GUI not functional aunola OpenFOAM Installation 1 July 28, 2008 00:32
ParaFOam problem luca OpenFOAM Running, Solving & CFD 1 May 3, 2006 12:06
Could anybody help me about the paraFoam problem liugx212 OpenFOAM Paraview & paraFoam 1 February 3, 2006 12:06


All times are GMT -4. The time now is 11:51.