CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   ParaViewParafoam on SUSE 11 (http://www.cfd-online.com/Forums/openfoam-installation/57344-paraviewparafoam-suse-11-a.html)

tkoz July 23, 2008 14:25

I have SUSE 11 installed. I h
 
I have SUSE 11 installed. I have OpenFOAM 1.5 installed. All checks out well but paraFoam. After running tutorial case Cavity, I get the same message that others have pointed to, "reader cannot be found......".

SUSE comes with qt 4.4. OpenFOAM paraView needs qt 4.3.

Where do I get a qt 4.3? Where do I install it? Can two qts exist on the same machine? The qt4.4 seems tied into much of SUSE and looks like it can't be deleted.

Should I go back and install an earlier version of SUSE that utilized qt 4.3?

Thanks for any help,

Tom Kosvic

podallaire July 23, 2008 14:50

Hi, just comment line 94 in
 
Hi,

just comment line 94 in Paraview3.3-cvs/CMakeLists.txt - should work. This way, you can compile Paraview with Qt4.4.

Good luck

PO

alberto July 23, 2008 14:55

Hello Thomas, if you succee
 
Hello Thomas,

if you succeed in compiling paraview with Qt 4.4, with a working reader on openSUSE 11.0, please could you just report that here?

I'm still unable to get a working paraFoam, even if paraview works OK.

Regards,
Alberto

alberto July 23, 2008 14:59

FYI, I reported this some time
 
FYI, I reported this some time ago: http://www.cfd-online.com/OpenFOAM_D...tml?1216182080

A.

santos July 23, 2008 15:57

Alberto, In the same thread
 
Alberto,

In the same thread you linked to, I reported a successful compilation of both Paraview and reader on openSUSE 11.0 with Qt 4.4:
http://www.cfd-online.com/cgi-bin/OpenFOAM_Discus/show.cgi?tpc=126&post=24573#POST245 73

What is exactly your problem during the compilation of the reader?

Regards,
Jose Santos

tkoz July 23, 2008 15:58

Pierre-Olivier Dallaire, Th
 
Pierre-Olivier Dallaire,

Thanks for your response but it seems that just commenting out the test as you suggested for the qt version number is too simple a solution. Would not someone just change the test to include qt 4.4 in the version tests if paraView would work with qt4.4?

I am reluctant to try this as I would probably overwrite the paraView that came with my installed openFOAM.

alberto July 23, 2008 23:54

Hi Jose, the problem I meet
 
Hi Jose,

the problem I meet is exactly what I reported there. If I recompile paraview and the reader with Qt 4.4, paraview works properly, but the reader passes to it a completely broken case (see the picture in the links to flickr).

Regards,
Alberto


All times are GMT -4. The time now is 08:53.