CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

How can i run OF14 rshssh passwordless

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   July 10, 2008, 06:01
Default Hi everyone. i have install t
  #1
Senior Member
 
wayne.zhang
Join Date: Mar 2009
Location: Shanghai, Shanghai, P.R.China
Posts: 307
Rep Power: 9
waynezw0618 is on a distinguished road
Send a message via MSN to waynezw0618 Send a message via Skype™ to waynezw0618
Hi everyone.
i have install the OF 1.4 in a cluster.but when i run foamInstalltest rsh is not accessed

Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes

but i can run rsh of /usr/bin in the shell to connect to the machine which i want to use.but this need i add the /usr/bin to the .bashrc of $HOME.if not the rsh is run in the /usr/kerberos/bin.and there will error message:

connect to address 10.128.0.98: Connection refused
Trying krb4 rlogin...
connect to address 10.128.0.98: Connection refused
trying normal rlogin (/usr/bin/rlogin)

Last login: Thu Jul 10 15:40:11 from cn176
Executing: /home/yjs10023k/OpenFOAM/OpenFOAM-1.4.1/.bashrc
Executing: /home/yjs10023k/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/apps/ensightFoam/bashrc
Executing: /home/yjs10023k/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/apps/paraview/bashrc
[yjs10023k@cn98 yjs10023k]$

and then connect to the machine.

but if i run the OF in the parallel way it looks like OF use the ssh insteady of rsh.and ask for password.but when i enter the password there still error messages:

ssh_exchange_identification: Connection closed by remote host
[cn176:11671] [0,0,0] ORTE_ERROR_LOG: Timeout in file base/pls_base_orted_cmds.c at line 275
[cn176:11671] [0,0,0] ORTE_ERROR_LOG: Timeout in file pls_rsh_module.c at line 1164
[cn176:11671] [0,0,0] ORTE_ERROR_LOG: Timeout in file errmgr_hnp.c at line 90
[cn176:11671] ERROR: A daemon on node cn98 failed to start as expected.
[cn176:11671] ERROR: There may be more information available from
[cn176:11671] ERROR: the remote shell (see above).
[cn176:11671] ERROR: The daemon exited unexpectedly with status 255.
[cn176:11671] [0,0,0] ORTE_ERROR_LOG: Timeout in file base/pls_base_orted_cmds.c at line 188
[cn176:11671] [0,0,0] ORTE_ERROR_LOG: Timeout in file pls_rsh_module.c at line 1196
--------------------------------------------------------------------------
mpirun was unable to cleanly terminate the daemons for this job. Returned value Timeout instead of ORTE_SUCCESS.

--------------------------------------------------------------------------



how can i resolve it?

thanks!!

wayne
waynezw0618 is offline   Reply With Quote

Old   July 11, 2008, 04:52
Default btw how can i run in paralle
  #2
Senior Member
 
wayne.zhang
Join Date: Mar 2009
Location: Shanghai, Shanghai, P.R.China
Posts: 307
Rep Power: 9
waynezw0618 is on a distinguished road
Send a message via MSN to waynezw0618 Send a message via Skype™ to waynezw0618
btw
how can i run in parallel way use mpi of my system instead of openmpi?
when do there is error message :
[yjs10023k@cn176 tutorials]$ mpirun -machinefile interFoam/damBreak/system/machi
nes `which interFoam` interFoam/ damBreak
/home/yjs10023k/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/interFoam : error while loading shared libraries: libPstream.so: cannot open shared object file: No such file or directory


and what will i do?

thanks

yours wayne
waynezw0618 is offline   Reply With Quote

Old   July 11, 2008, 06:41
Default and if i cp a libPstream.so to
  #3
Senior Member
 
wayne.zhang
Join Date: Mar 2009
Location: Shanghai, Shanghai, P.R.China
Posts: 307
Rep Power: 9
waynezw0618 is on a distinguished road
Send a message via MSN to waynezw0618 Send a message via Skype™ to waynezw0618
and if i cp a libPstream.so to $FOAM_LIBBIN/mpi-1.2.5 there still have error:

[yjs10023k@cn176 tutorials]$ mpirun -machinefile interFoam/damBreak/system/machines
`which interFoam` interFoam/ damBreak
/home/yjs10023k/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/interFoam : error while loading shared libraries: libmpi.so.0: cannot open shared object file: No such file or directory


i can not find limpi.so.0

how can i do??

thannks

wayne
waynezw0618 is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
MergeMeshes with version OF14 jens_klostermann OpenFOAM Bugs 2 November 7, 2014 17:27
How to upgrade OF14 to OF15 ivanyao OpenFOAM Installation 7 February 15, 2009 11:19
PROBLEMS WITH cfdTools in OF14 leosding OpenFOAM Running, Solving & CFD 1 August 20, 2007 13:05
MotionUy and DynamicMesh with OF14 bfa OpenFOAM Running, Solving & CFD 2 July 10, 2007 06:52
OF14 compilation error with icc91 ueno OpenFOAM Installation 0 June 1, 2007 08:54


All times are GMT -4. The time now is 02:05.