CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   IcoFoam Not Installed and blockMesh command not found (http://www.cfd-online.com/Forums/openfoam-installation/57358-icofoam-not-installed-blockmesh-command-not-found.html)

cesarbz June 25, 2008 16:27

Dear Gurus, I have some pro
 
Dear Gurus,

I have some problems when I install OpenFoam-1.3 , I can solved all least one. When I run foamInstallationTest appears the following:

Executing /home/cebz/OpenFOAM/OpenFOAM-1.3/bin/foamInstallationTest:





Checking basic setup...

-------------------------------------------------------------------------------

Shell: bash

Host: cebz

OS: Linux version 2.6.22.5-31-default

User: cebz

User_config: /home/cebz/.bashrc

Foam_config: /home/cebz/.OpenFOAM-1.3/bashrc sourced correctly.

-------------------------------------------------------------------------------



Checking main FOAM env variables...

-------------------------------------------------------------------------------

Environment_variable Set_to_file_or_directory Valid Crit

-------------------------------------------------------------------------------

$WM_PROJECT_INST_DIR /home/cebz/OpenFOAM yes yes

$WM_PROJECT_USER_DIR /home/cebz/OpenFOAM/cebz-1.3 yes no

$FOAM_JOB_DIR /home/cebz/OpenFOAM/jobControl yes yes

-------------------------------------------------------------------------------



Checking the FOAM env variables set on the PATH...

-------------------------------------------------------------------------------

Environment_variable Set_to_file_or_directory Valid Path Crit

-------------------------------------------------------------------------------

$WM_PROJECT_DIR /home/cebz/OpenFOAM/OpenFOAM-1.3 yes yes yes



$FOAM_USER_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes no

$FOAM_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes yes

$WM_DIR /home/cebz/OpenFOAM/OpenFOAM-1.3/wmake yes yes yes

$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes no yes

$CEI_HOME /usr/local/ensight/CEI no no



$JAVA_PATH /home/cebz/OpenFOAM/linux/j2sdk1.4.2_05 yes yes no

$MICO_ARCH_PATH ...mico-2.3.11/platforms/linuxGcc4DPOpt yes yes yes

$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes

$MPICH_ARCH_PATH --------- env variable not set --------- no

-------------------------------------------------------------------------------



Checking the FOAM env variables set on the LD_LIBRARY_PATH...

-------------------------------------------------------------------------------

Environment_variable Set_to_file_or_directory Valid Path Crit

-------------------------------------------------------------------------------

$FOAM_LIBBIN ...FOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt yes yes yes

$FOAM_USER_LIBBIN ...OpenFOAM/cebz-1.3/lib/linuxGcc4DPOpt yes yes no

$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes

-------------------------------------------------------------------------------



Software versions

-------------------------------------------------------------------------------

Software Version Location

-------------------------------------------------------------------------------

gcc 4.1.0 /home/cebz/OpenFOAM/linux/gcc-4.1.0-64/bin/gcc

java 1.4.2_05 /home/cebz/OpenFOAM/linux/j2sdk1.4.2_05/bin/java

gzip 1.3.12 /usr/bin/gzip

tar 1.3.12 /bin/tar

icoFoam *** not installed ***

CRITICAL ERROR

-------------------------------------------------------------------------------



Checking file/directory permissions...

-------------------------------------------------------------------------------

File/directory Set Reqd Crit

-------------------------------------------------------------------------------



Checking networking...

-------------------------------------------------------------------------------

Action Result Crit

-------------------------------------------------------------------------------

Pinging_cebz Successful yes

Pinging_localHost Successful yes

Test_rsh: Unsuccessful_connection_refused* yes

Test_ssh: Successful yes

(*) Only one of rsh or ssh is required by the Foam enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

The foam installation contains 1 critical error(s).

Review the output for warning messages and consult

the installation guide for trouble shooting.

-------------------------------------------------------------------------------- ------

The only Critical Error was whit icoFoam. I am sure that I copy the tutorial directory in the right place, using the command:

cebz@cebz:~/OpenFOAM/cebz-1.3/run/tutorials/icoFoam> cp -r OpenFOAM-1.3/tutorials cebz-1.3/run

Well, this is whit foamInstallationTest, in the practice (in the terminal) I sow the following. When I type "run", its work, I mean this comand get me in directory run

cebz@cebz:~> run

cebz@cebz:~/OpenFOAM/cebz-1.3/run>

But, wen I go to icoFoam directory and I type "blockMesh . cavity" this append:

cebz@cebz:~/OpenFOAM/cebz-1.3/run> cd tutorials/

cebz@cebz:~/OpenFOAM/cebz-1.3/run/tutorials> cd icoFoam/

cebz@cebz:~/OpenFOAM/cebz-1.3/run/tutorials/icoFoam> ls

Allclean Allrun cavity cavityClipped cavityGrade elbow resetFixedWallsScr

cebz@cebz:~/OpenFOAM/cebz-1.3/run/tutorials/icoFoam> blockMesh . cavity

bash: blockMesh: command not found

cebz@cebz:~/OpenFOAM/cebz-1.3/run/tutorials/icoFoam>


this message "bash: blockMesh: command not found" Say me that may be the bash is not well configured, but when I star the terminal there is messege of bast, it is:

Executing: /home/cebz/OpenFOAM/OpenFOAM-1.3/.bashrc

Executing: /home/cebz/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/apps/ensightFoam/bashrc

Executing: /home/cebz/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/apps/paraview/bashrc

cebz@cebz:~>


In other and, when I run Paraview, appears a list of errors but the ParaView in self run and I can see the grafic interface.

paraFoam . cavity

ErrorMessage

# Error or warning: ERROR: In ../../../../../paraview-2.4.2/Utilities/VTKClientServer/vtkClientServerInterpret er.cxx, line 866

vtkClientServerInterpreter (0x530180): Cannot find module "libPVFoamReader.so". The following paths were searched:

/home/cebz/OpenFOAM/linux/paraview-2.4.2/lib/paraview-2.4

/home/cebz/OpenFOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt/lam-7.1.1

.
.
.


Well, this is my situation, please somebody tell me what can I do to run blockMesh and star using OpenFOAM.

gschaider June 25, 2008 18:08

Hi Cesar! Out of personal c
 
Hi Cesar!

Out of personal curiosity: why are you installing 1.3? (If I do that, it's because of the retro-feeling. The good old days, when men were men and linear solver specifications were lines and not fancy dictionaries. SCNR) For a newcomer I would definitely recommend 1.4.1. It's one year old (==stable) and it's what most people who could help you use

Joke aside: you DID try it from a fresh shell? Not the same you preformed the necessary steps in (editing of .bashrc etc)

Bernhard

cesarbz June 26, 2008 00:30

Well, I used OpenFOAM 1.3 for
 
Well, I used OpenFOAM 1.3 for the las 3 year and I never had any problem, so I had a good experience whit this version.

But, in consideration of this installation's problemas I am thinking seriosly in install 1.4.1 version.

marruda July 3, 2008 12:02

Hi Cesar, I am afraid I am ha
 
Hi Cesar,
I am afraid I am having a similar problem trying to run the blockMesh and other applications.
The error message is:
bash: /home/marruda/OpenFOAM/OpenFOAM-1.4.1/applications/bin/linuxGccDPOpt/blockMesh: No such file or directory

Have you managed to get it to work in the meanwhile?

Thanks.

madad2005 July 3, 2008 12:36

I had a similar problem when I
 
I had a similar problem when I first tried it, but I got it all installed fine after 2 or three attempts. It was normally not following instructions properly, or missing out a step. Someone else has already mentioned it, but the ubuntu openfoam installation guide is quite good. See here:

https://help.ubuntu.com/community/OpenFOAM

marruda July 3, 2008 14:07

Thanks Adriano. I have just d
 
Thanks Adriano.
I have just decided to do the installation again from scratch and it now works.
Here's my thread of mistakes:
1. my os is Linux64 (ubuntu 6.10)
2. I first downloaded the linux64 binaries but forgot to set WN_64="on"
3. it didn't work giving me an error message:
bash: No such file or directory
4. Then I downloaded the linux32 binaries but the problem persisted ;(
5. started again with the binaries for linux64 but now setting WN_64="on"
6. Now it all seems to work... well at least I can run the tutorials.

Thanx for the help ;p

madad2005 July 4, 2008 04:44

No problem, Mauro. The WN_64="
 
No problem, Mauro. The WN_64="on" caught me out as well until I found the ubuntu guide. Good luck with the code! :-)


All times are GMT -4. The time now is 15:44.