CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Confused by Problems when reinstalling OPenFoam 13

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   June 1, 2008, 17:54
Default Hi, everybody, To use the i
  #1
New Member
 
jin xu
Join Date: Mar 2009
Location: london, UK
Posts: 13
Rep Power: 8
jin_xu is on a distinguished road
Hi, everybody,

To use the icoFsiFoam, I re-install my OF(1.3).Before the re-installation, everythin is working well. I can launch FoamX, compile solvers and the settings of enviroment variable are correct.

however, after the installtion, I can not set the enviroment variable correct any more, the problems are, when I type "which g++", it shows:

snail@snail-laptop:~$ which g++
/usr/bin/g++

but it should show a path to use the gcc/g++ of OF

and when I try to compile a solver, I also run into errors:

/usr/bin/ld: cannot find -liberty
collect2: ld returned 1 exit status
make: *** [/home/snail/OpenFOAM/snail-1.3/applications/bin/linuxGcc4DPOpt/icoFsiFoam] Error 1

I am pretty sure that the enviroment variable is not set correctly, but I think I have tried many times following the installation step in the wiki, but run into same problems.

Could anybody give me some hints to solve the problems.

Thanks in advance

jin
jin_xu is offline   Reply With Quote

Old   June 2, 2008, 04:00
Default Hi Jin Solution is offered
  #2
ngj
Senior Member
 
Niels Gjoel Jacobsen
Join Date: Mar 2009
Location: Rotterdam, The Netherlands
Posts: 1,592
Rep Power: 24
ngj will become famous soon enoughngj will become famous soon enough
Hi Jin

Solution is offered in this thread:

http://www.cfd-online.com/OpenFOAM_D...es/1/3063.html

/ Niels
__________________
Please note that I do not use the Friend-feature, so do not be offended, if I do not accept a request.
ngj is offline   Reply With Quote

Old   June 2, 2008, 20:53
Default Hi Niels, Thanks for your r
  #3
New Member
 
jin xu
Join Date: Mar 2009
Location: london, UK
Posts: 13
Rep Power: 8
jin_xu is on a distinguished road
Hi Niels,

Thanks for your reply!

I think I have solved this problem by re-installing OF-1,3 by the files downloaded from the OF offcial website. the problem is caused by my using of different version of OF-1,3(I was using the one pre-compiled by Pro.Jasak,)

Kind regards

jin
jin_xu is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with installation of OpenFoam sheyer OpenFOAM Installation 8 July 28, 2008 03:45
OpenFoam - problems MateuszZb ParaView 8 July 21, 2008 16:16
Ld problems with openfoam srinath OpenFOAM Installation 1 May 2, 2008 07:49
OpenFOAM 141 gccicoFoamnsd problems sippycup OpenFOAM Installation 1 August 29, 2007 08:59
OpenFOAM installation on SUSE92 problems derath OpenFOAM Installation 1 April 3, 2006 06:44


All times are GMT -4. The time now is 20:20.