CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Installation problems (http://www.cfd-online.com/Forums/openfoam-installation/57409-installation-problems.html)

indy April 5, 2008 15:02

Dear all, I am quite new to
 
Dear all,

I am quite new to OF and am experiencing some problems with the installation:

I have unpacked the source & binaries and installed in
/home/indy/OpenFOAM

I changed the .bashrc in the home/indy folder and it looks as it is sourced correctly.

However, when I run the foamInstallation test I get the following:


Executing ./foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: dhcppc1
OS: Linux version 2.6.22.5-31-default
User: indy
User_config: /home/indy/.bashrc
Foam_config: /home/indy/.OpenFOAM-1.4.1/bashrc sourced correctly.

FATAL ERROR Foam install directory not set.

Set correct path to installation 'WM_PROJECT_INST_DIR' in /home/indy/.foam2.3/bashrc
-------------------------------------------------------------------------------


Checking main FOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR --------- env variable not set --------- yes
$WM_PROJECT_USER_DIR --------- env variable not set --------- no
$FOAM_JOB_DIR --------- env variable not set --------- yes
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR --------- env variable not set --------- yes

$FOAM_USER_APPBIN --------- env variable not set --------- no
$FOAM_APPBIN --------- env variable not set --------- yes
$WM_DIR --------- env variable not set --------- yes
$FOAMX_PATH --------- env variable not set --------- yes
$CEI_HOME --------- env variable not set --------- no

$JAVA_PATH --------- env variable not set --------- no
$MICO_ARCH_PATH --------- env variable not set --------- yes
$LAM_ARCH_PATH --------- env variable not set --------- yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN --------- env variable not set --------- yes
$FOAM_USER_LIBBIN --------- env variable not set --------- no
$LAM_ARCH_PATH --------- env variable not set --------- yes
-------------------------------------------------------------------------------


Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc ...figure
WARNING: Conflicting installations:
foam settings: /bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

java 1.5.0_12
WARNING: Conflicting installations:
foam settings: /usr/lib64/jvm/jre/bin/java
current path : /usr/bin/java

gzip 1.3.12 /usr/bin/gzip
tar 1.3.12 /bin/tar
icoFoam *** not installed ***
CRITICAL ERROR

-------------------------------------------------------------------------------


Checking file/directory permissions...
-------------------------------------------------------------------------------
File/directory Set Reqd Crit
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_dhcppc1 No_entry_for_"dhcppc1"_in_/etc/hosts yes
WARNING: CRITICAL ERROR

Pinging_localHost Successful yes
Test_rsh: Not_active* yes
Test_ssh: Not_active* yes
FATAL ERROR: No remote shell available.
Foam1.4.1 enviroment requires either ssh and/or rsh.
Contact your system administrator.


-------------------------------------------------------------------------------

The system test has evoked 1 fatal error(s).

The foam installation contains 3 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.


So my question is: How do I setup the right installation? (the error given by: Set correct path to installation 'WM_PROJECT_INST_DIR' in /home/olli/.foam2.3/bashrc)

And secondly, are the other errors dependend on the first or what would I have to do to solve this?

Thank you very much for any help !!!!!!!!

Indy

indy April 6, 2008 08:11

Hi, I somehow (dont ask me
 
Hi,

I somehow (dont ask me why!:-)) have now made it to here, but there are still 1 fatal and 1 critical error I am struggling with...

Can anybody help me with these, or do you not need those variables when you are running on a single Linux PC???

Thanks & and sorry for the long post:!!

Executing ./foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: dhcppc1
OS: Linux version 2.6.22.5-31-default
User: indy
User_config: /home/indy/.bashrc
Foam_config: /home/indy/.OpenFOAM-1.4.1/bashrc sourced correctly.
-------------------------------------------------------------------------------


Checking main FOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/indy/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/indy/OpenFOAM yes no
$FOAM_JOB_DIR /home/indy/OpenFOAM yes yes
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/olli/OpenFOAM yes yes yes

$FOAM_USER_APPBIN ...FOAM/OpenFOAM-1.4.1/applications/bin yes yes no
$FOAM_APPBIN ...4.1/applications/bin/linux64GccDPOpt yes yes yes
$WM_DIR /home/indy/OpenFOAM/OpenFOAM-1.4.1/wmake yes yes yes
$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes yes yes
$CEI_HOME --------- env variable not set --------- no

$JAVA_PATH ...i/OpenFOAM/linux64/j2sdk1.4.2_05/bin yes yes no
$MICO_ARCH_PATH ...ico-2.3.12/platforms/linux64GccDPOpt yes yes yes
$LAM_ARCH_PATH --------- env variable not set --------- yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...M/OpenFOAM-1.4.1/lib/linux64GccDPOpt yes yes yes
$FOAM_USER_LIBBIN .../OpenFOAM-1.4.1/lib//linux64GccDPOpt yes yes no
$LAM_ARCH_PATH --------- env variable not set --------- yes
-------------------------------------------------------------------------------


Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc ...figure /usr/bin/gcc
java 1.5.0_12
WARNING: Conflicting installations:
foam settings: /home/olli/OpenFOAM/linux64/j2sdk1.4.2_05/bin/java
current path : /usr/bin/java

gzip 1.3.12 /usr/bin/gzip
tar 1.3.12 /bin/tar
icoFoam ...penFOAM-1.4.1/applications/bin/linux64GccDPOpt/icoFoam
-------------------------------------------------------------------------------


Checking file/directory permissions...
-------------------------------------------------------------------------------
File/directory Set Reqd Crit
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_dhcppc1 No_entry_for_"dhcppc1"_in_/etc/hosts yes
WARNING: CRITICAL ERROR

Pinging_localHost Successful yes
Test_rsh: Not_active* yes
Test_ssh: Not_active* yes
FATAL ERROR: No remote shell available.
Foam1.4.1 enviroment requires either ssh and/or rsh.
Contact your system administrator.


-------------------------------------------------------------------------------

The system test has evoked 1 fatal error(s).

The foam installation contains 1 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.

Thanks for any help!!

platopus April 6, 2008 09:36

Hi Indiana, note the sectio
 
Hi Indiana,

note the section:

Pinging_localHost Successful yes
Test_rsh: Not_active* yes
Test_ssh: Not_active* yes
FATAL ERROR: No remote shell available.
Foam1.4.1 enviroment requires either ssh and/or rsh.
Contact your system administrator.

I suggest you install openssh and try again. On my system it is in packages openssh-client and openssh-server. On some distributions simply installing ssh pulls both of these in.

Note that you also have a potential problem with java. I don't know if that is going to bite you.


Regards, Graeme.

indy April 6, 2008 12:01

Hi Graeme, thanks for you h
 
Hi Graeme,

thanks for you help,.......!

what i dont understand is, that I have openssh installed (version 4.6, came with SUSE 10.3) so it should actually be fine

I have luckily solved the java problem by pointing to the SUSE 10.3 java path which looks ok now.

I am not sure if the $LAM_ARCH_PATH has to be specified (isnt this just for parallel computing?)

Further on, I have followed the installation guide and am stuck now at the first test:

indy@dhcppc1:~/OpenFOAM/indy-1.4.1/run/tutorials> icoFoam
dotFoam(const fileName&) : Couldn't find file /home/indy//home/indy/OpenFOAM/OpenFOAM-1.4.1/controlDict or /home/indy/OpenFOAM/OpenFOAM-1.4.1//home/indy/OpenFOAM/OpenFOAM-1.4.1/controlDic t

Has this something to do with the environmental variables in the .bashrc file
Sorry again for the long post...!!
Indiana

platopus April 7, 2008 08:39

> thanks for you help,.......!
 
> thanks for you help,.......!

Not a problem.

> what i dont understand is, that I have openssh installed (version 4.6, came with SUSE 10.3) so it should actually be fine

That seems odd. Have you tried 'ssh dhcppc1' from a shell prompt?

> I have luckily solved the java problem by pointing to the SUSE 10.3 java path which looks ok now.

> I am not sure if the $LAM_ARCH_PATH has to be specified (isnt this just for parallel computing?)

Yes, I think so.

> Further on, I have followed the installation guide and am stuck now at the first test:

> indy@dhcppc1:~/OpenFOAM/indy-1.4.1/run/tutorials> icoFoam
> dotFoam(const fileName&) : Couldn't find file /home/indy//home/indy/OpenFOAM/OpenFOAM-1.4.1/controlDict or
> /home/indy/OpenFOAM/OpenFOAM-1.4.1//home/indy/OpenFOAM/OpenFOAM-1.4.1/controlDic t

This doesn't look like any error message I've seen. It looks like you tried to run the icoFoam solver with no arguments, but when I do that I get an error message that looks quite different.

Try changing directories to the .../run/tutorials/icoFoam directory like it says in the README, and run

./Allclean
blockMesh . cavity
icoFoam . cavity

Maybe it'll behave differently.

> Has this something to do with the environmental variables in the .bashrc file

There are some obviously wrong paths mentioned in that error message, but I don't know where they're coming from. Did you just add the line

. $HOME/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/bashrc

to the ~/.bashrc file like the README says?

> Sorry again for the long post...!!

It's okay.


Regards, Graeme.

indy April 7, 2008 13:59

Hi, I heard that the ssh FA
 
Hi,

I heard that the ssh FATAL ERRROR isn't such a problem for stand alone cases, so that should be fine I hope..

I did the

./Allclean commands and it did not change anything.

I copied the tutorials to the directory as it was in the README file...
same as with the sourcing
. $HOME/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/bashrc
to the ~/.bashrc file

if anybody has an idea, that would be most appreciated..

thanks

platopus April 8, 2008 10:31

> I heard that the ssh FATAL E
 
> I heard that the ssh FATAL ERRROR isn't such a problem for stand alone cases, so that should be fine I hope..

I just tried icoFoam without a working sshd, and it works fine, so you're right - it isn't that.

I can't help thinking that the fact that it's looking for the controlDict in

/home/indy//home/indy/OpenFOAM/OpenFOAM-1.4.1/controlDict

or

/home/indy/OpenFOAM/OpenFOAM-1.4.1//home/indy/OpenFOAM/OpenFOAM-1.4.1/controlDic t

has something to do with the problem - like your environment isn't set up properly. Notice the repeats and the occurrences of // - not good.

Failing that, I'm almost out of ideas.

Finally, what type of CPU do you have?


Regards, Graeme.

pistacoppu April 3, 2009 09:40

ssh
 
Hi ,
i had the same "fatal error",
...
FATAL ERROR: No remote shell available.
Foam1.4.1 enviroment requires either ssh and/or rsh.
Contact your system administrator.
...
even if i was able to run the icoFoam tutorial.
After that thread i opened synaptic packet manager, ad installed: ssh , that also automatically installed openssh-server .
I already had openssh-client installed but , the fatal error was fixed after i installed ssh .
...
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the Foam enviroment.
...
I run ubntu 8.10.
Bye


All times are GMT -4. The time now is 18:33.