CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

OpenFOAM and Paraview install issues

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   December 20, 2007, 12:34
Default I'm trying to set up OpenFOAM
  #1
New Member
 
Bob
Join Date: Mar 2009
Posts: 1
Rep Power: 0
spridal86 is on a distinguished road
I'm trying to set up OpenFOAM on a first time Linux machine. SuSE 10.1 was just installed on it. OpenFOAM installs fine, but when i do a installation test, I get a fatal error stating:
Test_rsh: Unsuccessful_connection_refused* yes
(*) Only one of rsh or ssh is required by the Foam enviroment.

When trying to install Paraview, I know i first have to install cmake and Qt, but when tryingto configure cmake 2.4.7, I get the following error message:
Error when bootstrapping CMake:
Cannot find appropriate C compiler on this system.
Please specify one using environment variable CC.
See cmake_bootstrap.log for compilers attempted.

Any help that can be provided would be much appreciated. Try to keep in mind however that I am a first time linux user and have very little experience. Thanks
spridal86 is offline   Reply With Quote

Old   December 21, 2007, 02:47
Default Hi Bob, The error that you ge
  #2
Senior Member
 
dmoroian's Avatar
 
Dragos
Join Date: Mar 2009
Posts: 647
Rep Power: 11
dmoroian is on a distinguished road
Hi Bob,
The error that you get is not one that you should worry about. As it says it self, if you have ssh working then you are on the right track. Anyway, having rsh or ssh up and running matters only if you do parallel computations on different nodes.
About paraview: why don't you run the binary version that comes bundled with OpenFOAM-1.4.1? You don't need to compile anything, just download and unpack everything from the web.

Dragos
dmoroian is offline   Reply With Quote

Old   December 21, 2007, 06:00
Default Seems that you don't have gcc
  #3
Member
 
lillberg's Avatar
 
Eric Lillberg
Join Date: Mar 2009
Location: Stockholm
Posts: 80
Rep Power: 8
lillberg is on a distinguished road
Send a message via Skype™ to lillberg
Seems that you don't have gcc in your path. What does 'which gcc' tell you?

/Eric
lillberg is offline   Reply With Quote

Old   January 23, 2008, 12:54
Default Hello world, I'm trying to
  #4
Member
 
Robertas N.
Join Date: Mar 2009
Location: Kaunas, Lithuania
Posts: 52
Rep Power: 8
r08n is on a distinguished road
Hello world,

I'm trying to compile OpenFOAM-1.4.1 on Debian 4.0 (if it matters). Somewhere in the process, I get this kind of errors:

make[3]: Leaving directory `/home/rob/Install/CFD/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/postProces sing/graphics/PVFoamReader/vtkFoam'
+ cd PVFoamReader
+ mkdir -p Make/linuxg++DPOpt
+ cd Make/linuxg++DPOpt
+ cmake ../..
CMake Error: Error in cmake code at
/home/rob/OpenFOAM/linux/paraview-2.4.4/lib/paraview-2.4/ParaViewConfig.cmake:29 :
INCLUDE Could not find include file: /home/dm2/henry/OpenFOAM/linuxSrc/paraview-2.4.4/platforms/linuxGcc4DPOpt/ParaVi ewLibraryDepends.cmake
Current CMake stack: /home/rob/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/postProcessing/graphics /PVFoamReader/PVFoamReader/CMakeLists.txt;/usr/share/cmake-2.4/Modules/CMakeCInf ormation.cmake;/usr/share/cmake-2.4/Modules/CMakeCXXInformation.cmake;/home/rob/ OpenFOAM/linux/paraview-2.4.4/lib/paraview-2.4/ParaViewConfig.cmake;/home/dm2/he nry/OpenFOAM/linuxSrc/paraview-2.4.4/platforms/linuxGcc4DPOpt/ParaViewLibraryDep ends.cmake

I have the Paraview files that come with the OpenFOAM installation in the folder ~/OpenFOAM/linux/paraview-2.4.4. The file causing the above errors is ~/OpenFOAM/linux/paraview-2.4.4/lib/paraview-2.4/ParaViewConfig.cmake
and it contains the following:

---8<---
SET(PARAVIEW_VERSION_MAJOR "2")
SET(PARAVIEW_VERSION_MINOR "4")
SET(PARAVIEW_VERSION_PATCH "4")

SET(PARAVIEW_BUILD_SHARED_LIBS "ON")
SET(PARAVIEW_USE_FILE "/home/dm2/henry/OpenFOAM/linuxSrc/paraview-2.4.4/ParaViewUse.cmake")
SET(PARAVIEW_VTK_DIR "/home/dm2/henry/OpenFOAM/linuxSrc/paraview-2.4.4/platforms/linuxGcc4DPOpt/VTK")
... (skipped the rest)
---8<---

The hardcoded folder "/home/dm2/henry/" implies some half-brewed development snapshot. I could edit this file and insert the correct folders, but the problem is, most of these files and folders to which ParaViewConfig.cmake refers are nowhere to be found. There are no paraview-2.4.4/Utilities/ or paraview-2.4.4/VTK folders; it seems that the entire Paraview installation is incomplete. Is it really so, or did I overlook smth? Where else could I look for errors?
r08n is offline   Reply With Quote

Old   February 10, 2008, 17:12
Default Hi, i got exactly the same err
  #5
New Member
 
Andre
Join Date: Mar 2009
Posts: 19
Rep Power: 8
andre is on a distinguished road
Hi, i got exactly the same errors.
I be glad to hear something.
andre is offline   Reply With Quote

Old   February 10, 2008, 17:43
Default Hello, Good evening! I h
  #6
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hello,

Good evening!

I happened to be looking through the forum, and thought I could put in some pointers regarding this issue.

In order to recompile OpenFOAM with support for paraview 2.4.x series, you need to have the Paraview 2.4.x source available, and you need to first compile Paraview on your machine before compiling OpenFOAM.

Once Paraview is compiled, a couple of files need to be copied to the Paraview installation (which is usually <openfoam>/linux/paraview-2.4.x). One of these files is the "ParaViewConfig.cmake" file, which gets generated during the Paraview compile process (The error you are currently seeing is because the ParaViewConfig.cmake file in the current paraview installation was generated on the machine on which it was compiled.)

The file I am attaching is a short set of instructions for building OpenFOAM along with the auxiliary programs (some of which are not essential in all cases). This file can also be found in the OpenFOAM SVN repository.

buildInstructions.txt

Have a nice day!

Philippose
philippose is offline   Reply With Quote

Old   February 13, 2008, 11:59
Default Hi, thanks for instructions
  #7
Member
 
Robertas N.
Join Date: Mar 2009
Location: Kaunas, Lithuania
Posts: 52
Rep Power: 8
r08n is on a distinguished road
Hi,

thanks for instructions.

I have downloaded the file paraview-2.4.4.linux.tgz from http://www.opencfd.co.uk/openfoam/linux.html. It has the following structure:

paraview-2.4.4
paraview-2.4.4/include
paraview-2.4.4/lib
paraview-2.4.4/lib/paraview-2.4
paraview-2.4.4/lib/paraview-2.4/tcl8.4
paraview-2.4.4/lib/paraview-2.4/tcl8.4/encoding
paraview-2.4.4/lib/paraview-2.4/tk8.4
paraview-2.4.4/lib/paraview-2.4/ServerManager
paraview-2.4.4/lib/paraview-2.4/ServerManager/Resources
paraview-2.4.4/lib/paraview-2.4/tcl
paraview-2.4.4/lib/paraview-2.4/tcl/kwwidgets
paraview-2.4.4/share
paraview-2.4.4/share/paraview-2.4
paraview-2.4.4/share/paraview-2.4/CMakeFiles
paraview-2.4.4/share/paraview-2.4/CMakeFiles/CMakeTmp
paraview-2.4.4/share/paraview-2.4/CMakeFiles/CMakeTmp/CMakeFiles
paraview-2.4.4/share/paraview-2.4/CMakeFiles/CMakeTmp/CMakeFiles/cmTryCompileExe c.dir
paraview-2.4.4/share/paraview-2.4/Scripts
paraview-2.4.4/share/paraview-2.4/Demos
paraview-2.4.4/share/paraview-2.4/Data
paraview-2.4.4/share/paraview-2.4/Data/SPCTH
paraview-2.4.4/share/paraview-2.4/Data/chombo3d
paraview-2.4.4/share/paraview-2.4/Data/headsq
paraview-2.4.4/bin

It seems that the file CMakeLists.txt is missing. therefore, I cannot build the paraview version supplied with OpenFOAM.
There is a newer version (3.2.1) available from http://www.paraview.org/New/download.html, but it requires Qt-4.2.2, and I only have Qt-4.2.1 that comes with Debian 4.0. I also have libvtk-5.0.2-4. Is it possible to use these?

Considering the above, what would be the best way:
1) Try to find paraview-2.4.4 that works;
2) Upgrade libqt and build paraview-3.2.1;
3) Something else? Did I overlook something?
Any suggestions are very welcome.
r08n is offline   Reply With Quote

Old   February 13, 2008, 14:15
Default Hello, A Good evening! T
  #8
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hello,

A Good evening!

The Paraview-2.4.4 version that you downloaded from the OpenFOAM webpage contains only the binaries... as in... it is a precompiled version, and does not contain the sources.

In order to compile Paraview-2.4.4, you need to download the sources, which can be downloaded from the following link:

http://powerlab.fsb.hr/ped/kturbo/OpenFOAM/release/

In the above FTP site, the sources are contained in the file: paraview-2.4.4.tar.gz

Once you have extracted the contents of the tgz file, you need to follow the instructions given in the text file posted earlier on this thread.


As for Paraview-3.2.1 ... As of now, a plugin for Paraview-3.2.1 which can be used to postprocess OpenFOAM cases directly from within Paraview is available in the following thread (paraFoam only works with the Paraview-2.4.x series), dated 23 October, 2007 (The install process is also given there):

http://www.cfd-online.com/OpenFOAM_D...tml?1201176762

It would be easiest to upgrade your Qt version to 4.2.2... but if thats not possible, you can try the following:

Within the Paraview3 source files, go to the following folder: \ParaView3\Qt

Here, open the file CMakeLists.txt, and change the line in the beginning starting with STRING(REGEX MATCH.........) to (unless it already looks like this):

STRING(REGEX MATCH "^4\.[2-3]\.[0-9]+" qt_version_tmp "${QTVERSION}")

And change: SET(QT_MIN_VERSION "4.2.2") to SET(QT_MIN_VERSION "4.2.1")


The advantage with Paraview-3.2.1 is, that the interface is extremely slick and professional, and things look a lot better, though there seems to be problems with Lookmarks.

Hope all this helps :-)!

Enjoy!

Philippose
philippose is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM Install Script ljsh OpenFOAM Installation 82 October 12, 2009 11:47
OpenFOAM 15 and CentOS 52 installation issues remrich OpenFOAM Bugs 9 March 20, 2009 02:48
Statically Compiling OpenFOAM Issues herzfeldd OpenFOAM Installation 21 January 6, 2009 10:38
install the openfoam aya CFX 4 July 23, 2008 07:58
How to install the paraview ztdep ParaView 0 June 20, 2006 08:51


All times are GMT -4. The time now is 20:39.