CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   OpenFOAM141 FoamX and paraView problem on cluster server (http://www.cfd-online.com/Forums/openfoam-installation/57446-openfoam141-foamx-paraview-problem-cluster-server.html)

seigi January 23, 2008 00:06

Hi, I installed OpenFOAM 1.4.
 
Hi,
I installed OpenFOAM 1.4.1 64bit on a cluster sever(SUSE 10.0.0 64bit). I want to use this server from local computer by ssh. The Solver of OpenFOAM on server machine worked fine, but FoamX and paraView can not run. To FoamX, I changed the NameServer port from 1234 to 1235 for the problem of runFoamXHB. But it still has something run.

hfc1@n1:~> FoamX
Starting NameServer with inet:n1:1235 ...
Starting FoamX Host Browser with inet:n1:1235 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.4.1 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : FoamXHostBrowser
Date : Jan 23 2008
Time : 00:02:04
Host : n1
PID : 13040
Root :
Case :
Nprocs : 1
HostBrowser running.....
Setting LANG to en_EN
Using jar /home/hfc1/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/preProcessing/FoamX/li b/FoamX.jar
Using jar /home/hfc1/OpenFOAM/OpenFOAM-1.4.1/applications/utilities/preProcessing/FoamX/li b/jlfgr-1_0.jar
Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.
at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
at sun.awt.X11GraphicsEnvironment.<clinit>(X11Graphic sEnvironment.java:134)
at java.lang.Class.forName0(Native Method)
at java.lang.Class.forName(Class.java:141)
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvir onment(GraphicsEnvironment.jav a:62)
at java.awt.Window.init(Window.java:231)
at java.awt.Window.<init>(Window.java:275)
at java.awt.Frame.<init>(Frame.java:401)
at java.awt.Frame.<init>(Frame.java:366)
at javax.swing.JFrame.<init>(JFrame.java:154)
at FoamX.App.<init>(App.java:196)
at FoamX.App.main(App.java:184)
/home/hfc1/OpenFOAM/OpenFOAM-1.4.1/bin/runFoamXHB: line 139: 13040 Killed FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 13036).
/home/hfc1/OpenFOAM/OpenFOAM-1.4.1/bin/runFoamXHB: line 66: 13036 Killed nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null
hfc1@n1:~>

seigi January 28, 2008 15:44

it's running now, should be OS
 
it's running now, should be OS problem


All times are GMT -4. The time now is 15:54.