CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Conflicting installations for gcc (http://www.cfd-online.com/Forums/openfoam-installation/57488-conflicting-installations-gcc.html)

fbisetti August 22, 2006 11:46

Hi all, I'm having problems
 
Hi all,

I'm having problems installing OpenFOAM from binaries. I followed (I hope correctly) the instructions. As I run the installation check, I get 1 critical error abour conflicting gcc as below:

gcc 3.3.6
WARNING: Conflicting installations:
foam settings: /home/fbisetti/OpenFOAM/linux/gcc-4.1.0/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

I found some posts on a similar problem for previous versions of gcc. There it seemed that the problem was a misplaced linux/gcc-x.x.x directory, but I'm positive the gcc I downloaded from your website is placed correctly. See that

ls -lt /home/fbisetti/OpenFOAM/linux/gcc-4.1.0/bin/gcc

returns:
-rwxr-xr-x 3 fbisetti users 299700 Mar 5 15:39 /home/fbisetti/OpenFOAM/linux/gcc-4.1.0/bin/gcc

Do I have to do something else to override my system installation of gcc?

Thanks a lot,
Fabrizio

msrinath80 August 22, 2006 16:12

If you are on a 64-bit system,
 
If you are on a 64-bit system, you need to do an export WM_64=on in your ~/.bashrc

Also, you need to put all the third party stuff (gcc, paraview et al.) into ~/OpenFOAM/linuxAMD64

fbisetti August 22, 2006 16:28

Sorry but I don't see the rele
 
Sorry but I don't see the relevance. I do not have a AMD and/or a 64-bit system. The problem seems to be somewhere else.

If I didn't understand the suggestion, can you please clearify?

Thanks again,
fb

grtabor August 22, 2006 17:41

You probably need to check tha
 
You probably need to check that /home/fbisetti/OpenFOAM/linux/gcc-4.1.0/bin comes first in your $PATH, so that it gets searched before /usr/bin. Are you sourcing .OpenFOAM-1.3/cshrc correctly?

Gavin

ribe September 27, 2006 05:43

I have the same problem. I've
 
I have the same problem. I've set the path so that gcc-4.1.0 comes first and all $WM_COMPILER* environment variables point to the correct location. Any other tries to make or options to set the compiler for wmake?

/Rickard

vivekjoshi November 5, 2006 14:56

I have the same troblem too. I
 
I have the same troblem too. I have a 32 bit SUSE 10.1 linux installation. I am not able to get rid of the critical error.
gcc 4.1.0
WARNING: Conflicting installations:
foam settings: /home/joshi/OpenFOAM/linux/gcc-4.1.0/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR
I check the following to make sure my PATH is correct
echo $PATH
/home/joshi/OpenFOAM/OpenFOAM-1.3/src/lam-7.1.1/platforms/linuxGcc4DPOpt/bin:/ho me/joshi/OpenFOAM/OpenFOAM-1.3/src/mico-2.3.11/platforms/linuxGcc4DPOpt/bin:/hom e/joshi/OpenFOAM/linux/j2sdk1.4.2_05/bin:/home/joshi/OpenFOAM/linux/gcc-4.1.0/bi n:/home/joshi/OpenFOAM/linux/gcc-4.1.0/../gdb-6.4/bin:/home/joshi/OpenFOAM/joshi -1.3/applications/bin/linuxGcc4DPOpt:/home/joshi/OpenFOAM/OpenFOAM-1.3/applicati ons/bin/linuxGcc4DPOpt:/home/joshi/OpenFOAM/OpenFOAM-1.3/wmake:/home/joshi/OpenF OAM/OpenFOAM-1.3/bin:/home/joshi/OpenFOAM/linux/bin:/home/joshi/OpenFOAM/OpenFOA M-1.3/src/lam-7.1.1/platforms/linuxGcc4DPOpt/bin:/home/joshi/OpenFOAM/OpenFOAM-1 .3/src/mico-2.3.11/platforms/linuxGcc4DPOpt/bin:/home/joshi/OpenFOAM/linux/j2sdk 1.4.2_05/bin:/home/joshi/OpenFOAM/linux/gcc-4.1.0/bin:/home/joshi/OpenFOAM/joshi -1.3/applications/bin/linuxGcc4DPOpt:/home/joshi/OpenFOAM/OpenFOAM-1.3/applicati ons/bin/linuxGcc4DPOpt:/home/joshi/OpenFOAM/OpenFOAM-1.3/wmake:/home/joshi/OpenF OAM/OpenFOAM-1.3/bin:/usr/local/bin:/usr/bin:/home/joshi/bin:/usr/X11R6/bin:/bin :/usr/games:/opt/gnome/bin:/opt/kde3/bin:/opt/cross/bin:/usr/lib/qt3/bin:/home/j oshi/OpenFOAM/linux/paraview-2.4.2/bin

amolinao December 2, 2006 10:46

I'm getting a similar error:
 
I'm getting a similar error:

Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 3.4.5
WARNING: Conflicting installations:
foam settings: /home/amolinao/OpenFOAM/linux/gcc-4.1.0-64/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR


Any suggestions?

amolinao December 2, 2006 10:50

I'm getting a similar error:
 
I'm getting a similar error:

Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 3.4.5
WARNING: Conflicting installations:
foam settings: /home/amolinao/OpenFOAM/linux/gcc-4.1.0-64/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR


Any suggestions?

altair January 3, 2007 06:10

Similar error again.. Softw
 
Similar error again..

Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc *** not installed ***
CRITICAL ERROR

any suggestions?

altair January 3, 2007 06:16

Similar error again.. Softw
 
Similar error again..

Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc *** not installed ***
CRITICAL ERROR

any suggestions?

altair January 3, 2007 07:58

Hello all, The error mentio
 
Hello all,

The error mentioned is now sorted out.
The issue was in the foam settings referring to gcc binaries within 'linux' directory under OpenFOAM that dint exist. So creating a directory named 'linux' and moving the gcc binaries as well as the java bits in there solved the problem.

Thanks and regards..

altair January 3, 2007 08:01

Hello all, The error mentio
 
Hello all,

The error mentioned is now sorted out.
The issue was in the foam settings referring to gcc binaries within 'linux' directory under OpenFOAM that dint exist. So creating a directory named 'linux' and moving the gcc binaries as well as the java bits in there solved the problem.

Thanks and regards..

mss June 22, 2007 04:07

Hej, I have the same proble
 
Hej,

I have the same problem (with OpenFOAM-1.4 on SuSe 10.2) :
-------------------------------------------------------------------------------
gcc ...figure
WARNING: Conflicting installations:
foam settings: /home/alex/OpenFOAM/linux64/gcc-4.1.2/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

java 1.5.0_10
WARNING: Conflicting installations:
foam settings: /home/alex/OpenFOAM/linux64/j2sdk1.4.2_05/bin/java
current path : /usr/bin/java

gzip 1.3.5 /usr/bin/gzip
tar 1.3.5 /bin/tar
icoFoam ...OpenFOAM-1.4/applications/bin/linux64Gcc4DPOpt/icoFoam
-------------------------------------------------------------------------------

Could someone help me?

Thank you,
Rita

anger July 9, 2007 08:31

Hello, just for documentati
 
Hello,

just for documentation purposes: I had the same problem about the conflicting installations of gcc on a SLES 9.3 system.
I noticed that the path to the gcc which should be used by FOAM (found after the keyword "foam settings") was not present which seems to be the problem; actually, this line mentioning the gcc is misleading because one could think that FOAM actually has found the compiler, while it did not.
So there are two soutions to this problem: putting the compiler into the right place (i.e. into the path mentioned in the line "foam settings") or changing the bashrc (or cshrc) in a way to point to the correct location. My problem was resolved by using the first solution.

Regards,
-Thomas

coops October 4, 2007 23:27

Hello All, I have read this
 
Hello All,

I have read this thread and some others but I can't seem to get it right! I have installed OpenFOAM on 32 bit before but this is my first time with 64-bit. I have the following issue from foamInstallationTest

gcc 4.1.2
WARNING: Conflicting installations:
foam settings: /home/model/OpenFOAM/linux/gcc-4.2.1-64/bin/gcc
current path : /usr/lib64/ccache/gcc
CRITICAL ERROR

I have put the files in the following positions:

/home/model/OpenFOAM/
for OpenFOAM General and DP Precison

and

/home/model/OpenFOAM/linux64/
for paraview and gcc respectively. (as suggested on the download website. I'm not using FoamX so no java)

My .bashrc file reads:

# .bashrc

# Source global definitions
if [ -f /etc/bashrc ]; then
. /etc/bashrc
fi

# User specific aliases and functions

export WM64=1

. $HOME/OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/bashrc

Can someone tell me if a) the .bashrc is right. b) how to get around the gcc problem c) (I think this is related to b)) the paraview command is not recognised. It may not be getting the right directory (like gcc) but I am not sure.

I hope this hasn't been covered before (I did search!)

Thanks in advance,

Shaun

dmoroian October 5, 2007 01:30

Hi Shaun, I suspect the probl
 
Hi Shaun,
I suspect the problem resides in your WM_64, environment variable, which most probably you did not set. This is why you have the wrong path towards your compiler (/home/model/OpenFOAM/linux/gcc-4.2.1-64/bin/gcc instead of /home/model/OpenFOAM/linux64/gcc-4.2.1-64/bin/gcc)
Solution: in OpenFOAM/OpenFOAM-1.4.1/.OpenFOAM-1.4.1/basrc
include the following line just before line 98:
export WM_64=shaun

I hope this will be useful,
Dragos

coops October 5, 2007 02:23

Hi Dragos, Thankyou very mu
 
Hi Dragos,

Thankyou very much! I need to learn to read properly! I changed that and the foamInstallationTest says everything is fine now. I will just have to wait for my collegue to test it for me. I installed it on a machine in alaska from my machine in australia.

Thanks again

Shaun


All times are GMT -4. The time now is 02:00.