CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   FoamX problem (http://www.cfd-online.com/Forums/openfoam-installation/57495-foamx-problem.html)

richardhsieh June 21, 2006 14:40

After installed OpenFOAM accor
 
After installed OpenFOAM according to the instructions, I ran FoamX and got all these following messages, and then it just hanged up!

[mxie@opws10 OpenFOAM]$ FoamX
Starting NameServer with inet:opws10.cct.lsu.edu:1234 ...
nsd: error while loading shared libraries: libelf.so.0: cannot open shared object file: No such file or directory

How can I make it working?! Thanks a lot!

hjasak June 21, 2006 15:26

In on Suse, install the follow
 
In on Suse, install the following package:

libelf-0.8.5-36

This will give you the library /usr/lib/libelf.so and all will be well. For other operating systems you will need to do the equivalent.

Enjoy,

Hrv

mahdi August 1, 2007 20:20

I want to install openfoam 1.3
 
I want to install openfoam 1.3 on my laptop (open suse 10.2).
I have some problem when strartinf FoamX.
here it is:
mahdi@cfdlab:~> FoamX
Starting NameServer with inet:cfdlab:1234 ...
Starting FoamX Host Browser with inet:cfdlab:1234 ...
FoamXHostBrowser: error while loading shared libraries: libmpi.so.0: cannot open shared object file: No such file or directory
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 4573).
/home/mahdi/OpenFOAM/OpenFOAM-1.3/bin/runFoamXHB: line 66: 4573 Killed nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null


any suggestion???
Moghimi

pierre_xu August 1, 2007 21:07

Moghimi, I've met this proble
 
Moghimi,
I've met this problem before when I wanted to run it on a local machine. After I added a line which declared my IP address and hostname into /etc/hosts, it runs well.
Check if there is a line looks like:
127.0.0.1 cfdlab
or
(another IP address) cfdlab
in your /etc/hosts

If there isn't, write it into that file.
Hope it will work.

Xu

gulitom September 17, 2007 22:41

I have a same problem with ric
 
I have a same problem with richard, but i don't know how to install the libelf-0.8.5-36, can anybody help me?


All times are GMT -4. The time now is 10:40.