CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Libstdcso6 ABI problem (http://www.cfd-online.com/Forums/openfoam-installation/57519-libstdcso6-abi-problem.html)

maka November 8, 2005 12:08

I get the following message wh
 
I get the following message when trying to run OpenFOAM in 32 bit mode on 64 bit machine. when I run "which gcc" it give me a location that is different than OpenFOAM/linux directory. It seems that it does not see /OpenFOAM/linux/gcc-4.0.1 as an installation directory that should be used instead of /usr/lib32/lib. Please, can any one tell what I should do?

icoFoam: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by icoFoam)
icoFoam: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /home/maka/OpenFOAM/OpenFOAM-1.2/lib/linuxGcc4Opt/libcfdTools.so)
icoFoam: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /home/maka/OpenFOAM/OpenFOAM-1.2/lib/linuxGcc4Opt/libOpenFOAM.so)
icoFoam: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /home/maka/OpenFOAM/OpenFOAM-1.2/lib/linuxGcc4Opt/libmeshTools.so)
icoFoam: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /home/maka/OpenFOAM/OpenFOAM-1.2/lib/linuxGcc4Opt/libsampling.so)
icoFoam: /usr/lib32/libstdc++.so.6: version `CXXABI_1.3.1' not found (required by /home/maka/OpenFOAM/OpenFOAM-1.2/lib/linuxGcc4Opt/libtriSurface.so)

Thanks,
Maka

maka November 9, 2005 03:25

I noticed that WM_COMPILER_DIR
 
I noticed that WM_COMPILER_DIR is set wrong:
WM_COMPILER_DIR=/home/mhussin/OpenFOAM/linux/gcc-4.0.1-64
So, I corrected it to /linux/gcc-4.0.1/ but also this did not solve the problem.

/Maka

mattijs November 9, 2005 05:40

You probably don't have a gcc-
 
You probably don't have a gcc-4.0.1 in the correct position. Make sure WM_64 is not set and install everything as for a 32 bit machine.

Put some print statements in the .../OpenFOAM-1.2/.bashrc file if you want to find out exactly.

maka November 10, 2005 06:16

In the light of your suggestio
 
In the light of your suggestions. I found two ways to solve the problem. The cluster that we have has both 32 bit and 64 bit machines that "share the same file system". So the gcc 32 bit is installed in OpenFOAM/linux while the 64 bit version in OpenFOAM/linuxAMD64.

I noticed that when running in 32 bit mode on the 64 bit machine OpenFOAM expects the gcc files in OpenFOAM/linux$WM_COMPILER_ARCH. $WM_COMPILER_ARCH=-64 in that case. This is because in OpenFOAM-1.2/.bashrc, there exist the line:

if [ "$WM_COMPILER" = "Gcc4" ]; then
export WM_COMPILER_DIR=$WM_PROJECT_INST_DIR/$WM_ARCH/gcc-4.0.1$WM_COMPILER_ARCH
...

Since unpacking the gcc-4.0.1.linux.tgz in linux folder according the installation procedure, only create a folder named gcc-4.0.1 but NOT gcc-4.0.1-64 as expected by the above line in OpenFOAM-1.2/.bashrc. As a result there are two ways to solve the problem:

(1)- modify OpenFOAM-1.2/.bashrc to be:

if [ "$WM_COMPILER" = "Gcc4" ]; then
export WM_COMPILER_DIR=$WM_PROJECT_INST_DIR/$WM_ARCH/gcc-4.0.1
...

in this way running 32 bit mode (either on 32 bit machine or 64 bit one) will use the same gcc folder;

(2) make two copies of the 32 bit gcc vesion inside OpenFOAM/linux directory:
gcc-4.0.1 (used when running in 32 bit mode on 32 bit machine)
gcc-4.0.1-64 (used when running in 32 bit mode on 64 bit machine)


Both solution worked for me. Solution (1) is better since one can run (in 32 bit mode) a parallel simulation on a combination of 32 bit and 64 bit machines if he can adjust some load factor to keep up with difference in the speed between different machines.

Many thanks for your suggestions,
Maka

maka November 10, 2005 10:51

I tried both solutions: Act
 
I tried both solutions:

Actually both work fine when run (in 32 bit mode) a parallel simulation on a combination of 32 bit and 64 bit machines. The last statement that favors solution (1) is wrong.

Regards,
Maka.

oscar_j July 17, 2007 20:40

Also the wmake compiler works
 
Also the wmake compiler works to you??
Try in $FOAM_APP/solvers/laplacianfoam directory,
Type> wmake

Thanks!
Oscar


All times are GMT -4. The time now is 19:36.