CFD Online Discussion Forums

CFD Online Discussion Forums (
-   OpenFOAM Installation (
-   -   Mpich and OpenFOAM14 problem with decomposePar (

conry May 3, 2007 07:00

Hi All, I've almost successfu
Hi All,
I've almost successfully installed OpenFOAM 1.4 on our SuSE SLES9 cluster, using mpich 1.2.7. However, there is one outstanding issue and maybe someone here can give me a pointer on how to fix it.

I have compiled and installed mpich1.2.7 in the OpenFOAM tree, and compiled the pstream part. Parallel jobs are working via mpirun. However, what is not working is decomposePar. On my installation of 1.3, decomposePar works (and I used this installation to decompose the job for my 1.4 test). However on 1.4 I get an error about missing Doing
ldd `which decomposePar`
shows two unmet dependencies => not found => not found
These do not appear I try the same thing with the OpenFOAM 1.3 version.
reconstructPar, however, works fine in both versions.

Can anyone shed any light on how I might manage to resolve this difficulty?

Best regards,

olesen May 3, 2007 08:00

The same problem and its solut
The same problem and its solution appeared a few weeks ago in connection with openmpi.
Search the forum for Mattijs' definitive answer and the reason.
The quick fix: just to recompile decompoesePar with the mpich or openmpi settings.

conry May 7, 2007 05:25

Thanks, that seems to have wor
Thanks, that seems to have worked fine (I did ./Allmake in utilities/parallelProcessing/decompositionMethods/). Afterwards things seem to work fine and I have decomposed and run a parallel job using mpich.

Apologies for not finding the solution in the forums myself!


All times are GMT -4. The time now is 15:04.