CFD Online URL
[Sponsors]
Home > Forums > OpenFOAM Installation

Ubuntu and finding libelfso0

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   February 20, 2007, 23:55
Default Would someone please point me
  #1
Member
 
Shaun Darmody
Join Date: Mar 2009
Posts: 36
Rep Power: 7
shaun is on a distinguished road
Would someone please point me in the correct direction to download and install the libelf.so.0 file so that I may get FoamX to work.

I am only just starting with OpenFOAM and am using Ubuntu 6.06 LTS (Dapper Drake).

Thanks for your help in advance.

Regards

Shaun.D
shaun is offline   Reply With Quote

Old   February 21, 2007, 01:54
Default Well I found the libelf packag
  #2
Member
 
Shaun Darmody
Join Date: Mar 2009
Posts: 36
Rep Power: 7
shaun is on a distinguished road
Well I found the libelf package at http://packages.ubuntu.com/dapper/

and then went to install it using Gdebi. Turns out that libelf.so.0 was already installed at usr/lib/libelf.so.0

So, I tried running the command FoamX and still got the same error that everyone else I have noticed on this discussion forum has had in the past. I.e

Starting NameServer with inet:darmodys-desktop:1234 ...
nsd: error while loading shared libraries: libelf.so.0: cannot open shared object file: No such file or directory

So, now I am thinking that somehow FoamX is looking in the wrong directory for this file.

Has anyone had this problem with OpenFOAM in Ubuntu and if so how do you reslove it? My group here in AUS are keen to have OpenFOAM up and running. If needs be, I will reinstall with SUSE if I cannot resolve this issue.

Any help will be much appreciated.

Regards

Shaun.D
shaun is offline   Reply With Quote

Old   April 30, 2007, 05:08
Default I recently installed OpenFOAM
  #3
New Member
 
Félix Salazar
Join Date: Mar 2009
Location: Venezuela
Posts: 1
Rep Power: 0
orodoni_le is on a distinguished road
I recently installed OpenFOAM 1.4 in Ubuntu 7.04 Feisty Fawn. The installation instructions could be followed with very detail from this sites:

http://ubuntuforums.org/showthread.php?t=156298
https://help.ubuntu.com/community/OpenFOAM

The only difference between sites it's the version number (1.4 in the first and 1.3 in the second). This only affects the filenames on the command line

When I try to run FoamX, received the following error message:

nsd: error while loading shared libraries: libssl.so.0.9.7: cannot open shared object file: No such file or directory

To solve that problem, I simply went to Synaptic, and install the libssl.so.0.9.7 package.

Regards

Felix

PD: Sorry if the help it's late
orodoni_le is offline   Reply With Quote

Old   April 30, 2007, 19:40
Default Thanks for the post Felix. I h
  #4
Member
 
Shaun Darmody
Join Date: Mar 2009
Posts: 36
Rep Power: 7
shaun is on a distinguished road
Thanks for the post Felix. I had solved the problem a while ago, and also came across the same issue for OF1.4. I was able to quickly resolve that.

Cheers

Shaun.D
shaun is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenFOAM 13 FoamX libelfso0 and Fedora Core 4 crosby OpenFOAM Pre-Processing 23 June 24, 2008 03:01
FoamX libelfso0 nunoinlux OpenFOAM Bugs 6 September 11, 2007 21:13
Canbt fix libelfso0 proble clo OpenFOAM Installation 3 January 10, 2007 05:17
FoamX libelfso0 mockealm OpenFOAM Installation 6 June 29, 2006 16:37
Sshd amp libelfso0 on gentoo box alfreed OpenFOAM Installation 2 June 15, 2006 11:05


All times are GMT -4. The time now is 11:06.