CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Problem running FoamX

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   March 10, 2007, 19:15
Default Hi, I've been trying to run
  #1
New Member
 
Ian Zhang
Join Date: Mar 2009
Location: Illinois, US
Posts: 13
Rep Power: 8
ianz8802 is on a distinguished road
Hi,

I've been trying to run FoamX for a week now, and I've came up with nothing but problems. The latest one is that the "default name server could not be contacted". I've tried following the suggestions of the previous posts like:

1) turning off SElinux
2)changing the host name so that it's not "localhost"
3)Going through the steps suggested by Philippose Rajan at http://www.cfd-online.com/OpenFOAM_D...es/1/1767.html
(it didn't work out for me, the /usr/sbin/semodule -i local.pp always say that it cannot be read).

and it still shows the same thing over and over and over again.

Any help/suggestions/hints in fixing this thing will be GREATLY appreciated, I'm going against a pretty close deadline to get some work done and I've already used a week just trying to get OpenFOAM to work.

Here's the prompt printout thing

Executing: /home/Ian/OpenFOAM/OpenFOAM-1.3/.bashrc
Executing: /home/Ian/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/apps/ensightFoam/bashrc
Executing: /home/Ian/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/apps/paraview/bashrc
[Ian@mycomp ~]$ FoamX
Starting NameServer with inet:mycomp:1234 ...
Starting FoamX Host Browser with inet:mycomp:1234 ...
/*---------------------------------------------------------------------------*\
| ========= | |
| \ / F ield | OpenFOAM: The Open Source CFD Toolbox |
| \ / O peration | Version: 1.3 |
| \ / A nd | Web: http://www.openfoam.org |
| \/ M anipulation | |
\*---------------------------------------------------------------------------*/

Exec : FoamXHostBrowser
Date : Mar 10 2007
Time : 17:00:49
Host : mycomp
PID : 3360
Root :
Case :
Nprocs : 1
HostBrowser running.....
Using jar /home/Ian/OpenFOAM/OpenFOAM-1.3/applications/utilities/preProcessing/FoamX/lib/F oamX.jar
Using jar /home/Ian/OpenFOAM/OpenFOAM-1.3/applications/utilities/preProcessing/FoamX/lib/j lfgr-1_0.jar
FoamX.Exceptions.FoamXException: Default name service could not be contacted.
at FoamX.App.initialiseHostBrowser(App.java:512)
at FoamX.App.initialise(App.java:343)
at FoamX.App.main(App.java:186)
/home/Ian/OpenFOAM/OpenFOAM-1.3/bin/runFoamXHB: line 131: 3360 Killed FoamXHostBrowser -ORBNamingAddr $myIOP
runFoamXHB : cleanup
runFoamXHB: Killing name server nsd(pid 3356).
/home/Ian/OpenFOAM/OpenFOAM-1.3/bin/runFoamXHB: line 66: 3356 Killed nsd -ORBIIOPAddr $myIOP --ior $FOAMX_CONFIG/ns.ref </dev/null

(btw, somewhere in that mess a window pops up with the "default server" message and opens the FoamX interface that does absolutely nothing).

I'm currently using Fedora Core 6, I've installed quite a bit of updates, and so far they've done nothing.

Thanks in advance..


Ian Z.
ianz8802 is offline   Reply With Quote

Old   March 10, 2007, 19:52
Default Hi, One question... when you
  #2
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hi,
One question... when you run the utility "foamInstallationTest", at the end does it say that everything is ok?

Specifically, towards the end of the test, it checks whether your system is setup to accept "ssh" or "rsh" connection requests.... atleast one of them should work.

Maybe you could post the output of foamInstallationTest.

Have a nice day!

Philippose
philippose is offline   Reply With Quote

Old   March 11, 2007, 00:48
Default Hi, Here's the foaminstalla
  #3
New Member
 
Ian Zhang
Join Date: Mar 2009
Location: Illinois, US
Posts: 13
Rep Power: 8
ianz8802 is on a distinguished road
Hi,

Here's the foaminstallationtest result. according to it the critical systems are "ok", and I seem to have ssh running.

Oh, one thing I forgot to mention, I ran the ping thing in the readme, and it worked out ok, not sure if that's useful or not.

Thanks for replying.

Ian Z.

[Ian@mycomp bin]$ ./foamInstallationTest
Executing ./foamInstallationTest:


Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: mycomp
OS: Linux version 2.6.19-1.2911.6.5.fc6
User: Ian
User_config: /home/Ian/.bashrc
Foam_config: /home/Ian/.OpenFOAM-1.3/bashrc sourced correctly.
-------------------------------------------------------------------------------


Checking main FOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/Ian/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/Ian/OpenFOAM/Ian-1.3 yes no
$FOAM_JOB_DIR /home/Ian/OpenFOAM/jobControl no yes
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/Ian/OpenFOAM/OpenFOAM-1.3 yes yes yes

$FOAM_USER_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes no
$FOAM_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes yes
$WM_DIR /home/Ian/OpenFOAM/OpenFOAM-1.3/wmake yes yes yes
$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes no yes
$CEI_HOME /usr/local/ensight/CEI no no

$JAVA_PATH /home/Ian/OpenFOAM/linux/j2sdk1.4.2_05 yes yes no
$MICO_ARCH_PATH ...mico-2.3.11/platforms/linuxGcc4DPOpt yes yes yes
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...FOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt yes yes yes
$FOAM_USER_LIBBIN .../OpenFOAM/Ian-1.3/lib/linuxGcc4DPOpt yes yes no
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes
-------------------------------------------------------------------------------


Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.1.0 /home/Ian/OpenFOAM/linux/gcc-4.1.0/bin/gcc
java 1.4.2_05 /home/Ian/OpenFOAM/linux/j2sdk1.4.2_05/bin/java
gzip 1.3.5 /usr/bin/gzip
tar 1.3.5 /bin/tar
icoFoam ...M/OpenFOAM-1.3/applications/bin/linuxGcc4DPOpt/icoFoam
-------------------------------------------------------------------------------


Checking file/directory permissions...
-------------------------------------------------------------------------------
File/directory Set Reqd Crit
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_mycomp Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Successful yes
(*) Only one of rsh or ssh is required by the Foam enviroment.

-------------------------------------------------------------------------------

Base configuration ok.

Critical systems ok.
ianz8802 is offline   Reply With Quote

Old   March 11, 2007, 07:29
Default Hello again, Good day to you!
  #4
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hello again,
Good day to you!

Looks like there is some hangup hiding itself really well in your system :-)! I currently use Fedora Core 6 with the same kernel as yours... and I assume you do an automatic system update once in a while, which means our systems would be more or less comparable.

I tried FoamX again (after a long time now) last evening, and it worked fine for me.... because of this, I am still putting my bet that the problem lies in the SELinux settings of your computer....

I have taken screenshots of all the SELinux settings on my computer, but a zipped version of the 8 JPEG files adds up to around 416KB, which is too large to post here... is there any way I can send them to you.. an email ID or so?

By the way, have you tried to completely disable SELinux on your system and then run FoamX?

On the other hand, the question remains, as to whether you really do need to use FoamX or not. I initially used FoamX during the first few weeks after installing OpenFOAM, but quickly found that its easier to set up a case using the console.

Since my simulations are repetitive, I made some bash scripts which do exactly what I need to do automatically... so I havent used FoamX in a long time :-)!

Have a nice Sunday!

Philippose
philippose is offline   Reply With Quote

Old   March 11, 2007, 11:22
Default Hi once again :-) Ok... if
  #5
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hi once again :-)

Ok... if nothing changed even after disabling SELinux, it looks kind of weird....

Another thing you could try, is to modify the /etc/hosts file which you have listed above....

In my case... it looks like this:

127.0.0.1 localhost.localdomain localhost TheMatrix

I remember that early on while I was trying to get FoamX to work, I removed the second line in the hosts file... the "::1 ......." bit, and changed the order of the first line....

Its ok to have the localhost.localdomain bit, because "localhost.localdomain", "localhost" and in your case "mycomp" are all aliases to the local IP address 127.0.0.1

Just for completion, your /etc/host.conf should have atleast the following line:

order hosts,bind

I shall send you the SELinux screenshots anyway... lets not keep any stones unturned :-)!

Enjoy!

Philippose
philippose is offline   Reply With Quote

Old   March 11, 2007, 11:32
Default One more thing... once you cha
  #6
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
One more thing... once you change anything to SELinux or to the hosts or the host.conf files, you should atleast restart the network system, but better still, is to restart your computer.... in order to enable all the changes.

Philippose

(P.S. I sent the images to the ID)
philippose is offline   Reply With Quote

Old   March 11, 2007, 12:22
Default Thanks!! I'll give that a try.
  #7
New Member
 
Ian Zhang
Join Date: Mar 2009
Location: Illinois, US
Posts: 13
Rep Power: 8
ianz8802 is on a distinguished road
Thanks!! I'll give that a try.

Ian Z.
ianz8802 is offline   Reply With Quote

Old   March 11, 2007, 13:54
Default It worked. : D Thank you.
  #8
New Member
 
Ian Zhang
Join Date: Mar 2009
Location: Illinois, US
Posts: 13
Rep Power: 8
ianz8802 is on a distinguished road
It worked. : D

Thank you.

Ian Z.
ianz8802 is offline   Reply With Quote

Old   March 11, 2007, 15:37
Default Hey :-) Great... could you
  #9
Senior Member
 
Philippose Rajan
Join Date: Mar 2009
Location: Germany
Posts: 530
Rep Power: 16
philippose will become famous soon enough
Hey :-)

Great... could you tell me what it was that finally made it work? it would make things easier the next time when we know exactly which of the numerous changes actually made the difference....!

Or was it an outcome of a sum of all those changes :-)? In that case, it would make sense to document those changes!

Enjoy, and welcome to the interesting world of OpenFOAM :-)!

Philippose
philippose is offline   Reply With Quote

Old   March 11, 2007, 17:10
Default Hi, I just switched the /et
  #10
New Member
 
Ian Zhang
Join Date: Mar 2009
Location: Illinois, US
Posts: 13
Rep Power: 8
ianz8802 is on a distinguished road
Hi,

I just switched the /etc/hosts entry around so that it read

127.0.0.1 localhost.localdomain localhost mycomp

and deleted the second line with the ::1.

I matched the settings that you had with the SELinux, but that didn't affect it.

Once again, thanks for helping.

Ian Z.
ianz8802 is offline   Reply With Quote

Old   March 22, 2007, 12:16
Default did somebody help me? i work
  #11
Member
 
hamdi
Join Date: Mar 2009
Posts: 72
Rep Power: 8
hamcer is on a distinguished road
did somebody help me?
i work unde linux mandriva and the foamx not worked ; the foam installationstest said that : no remote shall available
Faom1-3 envirenant requires either ssh and/ or rsh
...................
hamcer_n@hotmail.com
hamcer is offline   Reply With Quote

Old   March 23, 2007, 12:22
Default hi! freinds! can any body hel
  #12
Member
 
hamdi
Join Date: Mar 2009
Posts: 72
Rep Power: 8
hamcer is on a distinguished road
hi! freinds!
can any body help me to how show! the figure 2.1 in 1st tutorial..

thanks
hamcer is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding FoamX running Kindly help out hariya03 OpenFOAM Pre-Processing 0 April 18, 2008 04:26
Problem with running FoamX in a distributed environment susana OpenFOAM Pre-Processing 1 March 28, 2007 17:11
Running FoamX vivekjoshi OpenFOAM Installation 0 November 5, 2006 17:13
Running icoDyMFoam from FoamX jdkummer OpenFOAM Running, Solving & CFD 3 September 13, 2006 04:31
problem in running FoamX in Open FOAM Gaurav Main CFD Forum 3 May 10, 2006 05:06


All times are GMT -4. The time now is 21:35.