CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Failed foamInstallationTest (http://www.cfd-online.com/Forums/openfoam-installation/57568-failed-foaminstallationtest.html)

craiger February 27, 2007 23:02

I'm a linux newbie (SUSE 10) b
 
I'm a linux newbie (SUSE 10) but have followed the README file and read the threads on this discussion site.

There are problems with my gcc installation, pinging the host, and activation of ssh and rsh.

Where have I gone wrong?

Really appreciate the help.



Here is the foamInstallationTest

Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: U197
OS: Linux version 2.6.13-15.12-smp
User: craiger
User_config: /home/craiger/.bashrc
Foam_config: /home/craiger/.OpenFOAM-1.3/bashrc sourced correctly.
-------------------------------------------------------------------------------


Checking main FOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/craiger/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/craiger/OpenFOAM/craiger-1.3 yes no
$FOAM_JOB_DIR /home/craiger/OpenFOAM/jobControl yes yes
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/craiger/OpenFOAM/OpenFOAM-1.3 yes yes yes

$FOAM_USER_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes no
$FOAM_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes yes
$WM_DIR .../craiger/OpenFOAM/OpenFOAM-1.3/wmake yes yes yes
$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes no yes
$CEI_HOME /usr/local/ensight/CEI no no

$JAVA_PATH ...craiger/OpenFOAM/linux/j2sdk1.4.2_05 yes yes no
$MICO_ARCH_PATH ...mico-2.3.11/platforms/linuxGcc4DPOpt yes yes yes
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...FOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt yes yes yes
$FOAM_USER_LIBBIN ...nFOAM/craiger-1.3/lib/linuxGcc4DPOpt yes yes no
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes
-------------------------------------------------------------------------------


Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc *** not installed ***
CRITICAL ERROR

java 1.4.2_05 /home/craiger/OpenFOAM/linux/j2sdk1.4.2_05/bin/java
gzip 1.3.5 /usr/bin/gzip
tar 1.3.5 /bin/tar
icoFoam ...M/OpenFOAM-1.3/applications/bin/linuxGcc4DPOpt/icoFoam
-------------------------------------------------------------------------------


Checking file/directory permissions...
-------------------------------------------------------------------------------
File/directory Set Reqd Crit
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_U197 No_entry_for_"U197"_in_/etc/hosts yes
WARNING: CRITICAL ERROR

Pinging_localHost Successful yes
Test_rsh: Not_active* yes
Test_ssh: Not_active* yes
FATAL ERROR: No remote shell available.
Foam1.3 enviroment requires either ssh and/or rsh.
Contact your system administrator.


-------------------------------------------------------------------------------

The system test has evoked 1 fatal error(s).

The foam installation contains 2 critical error(s).

Review the output for warning messages and consult
the installation guide for trouble shooting.


thanks again,

Craig

eugene February 28, 2007 06:44

You either did not download al
 
You either did not download all the 3rd party binary packs (especially gcc-4.1.0.linux.tgz). Or you failed to untar the gcc pack correctly. I see you have the java component installed so you are on the right track.

You also need to enable/install ssh/sshd on your workstation. In Suse 10 you can do this via yast->software->software management. Do a search for ssh and install or speak to your sysadmin.

craiger March 1, 2007 02:22

Thanks for the help. For th
 
Thanks for the help.

For the first critical error: gcc not installed

As per the README instructions, I downloaded the source pack and two binary packs into the folder /home/craiger/OpenFOAM/

I decompressed each file by:

'tar xf OpenFOAM-1.3.General.gtgz'
'tar xf OpenFOAM-1.3.linux.Gcc4DPOpt.gtgz'
'tar xf OpenFOAM-1.3.linux.Gcc4SPOpt.gtgz'

*note: if I use tar xzf, it says that the files are not in the right format. tar xf works though.

I downloaded the three 3rd party binary packs (including gcc-4.1.0.linux.tgz) into the folder /home/craiger/OpenFOAM/linux/

again I used the commands:

'tar xzf gcc-4.1.0.linux.tgz'
'tar xzf paraview-2.4.2.linux.tgz'
'tar xzf j2sdk1.4.2_05.linux.tgz'

I added . $HOME/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/bashrc to my .bashrc file and typed the following into the terminal:
'. $HOME/.bashrc'

After running the foamInstallationTest, I still have the error: gcc *** not installed ***.

SO....

have I downloaded the 3rd party binary packs correctly? If so, where am I going wrong in installing them?

Thanks again.

Craig

dmoroian March 1, 2007 03:17

Hi Craig, The third party pac
 
Hi Craig,
The third party packages are ok (if you have a 32 bit machine), but you need to unpack them in a directory called:
$HOME/OpenFOAM/linux
From what you said before, it seems that you forgot to create that directory and unpacked the archives in a wrong place.

Dragos

eugene March 1, 2007 07:20

This is very curious. If you d
 
This is very curious. If you did what you described it should work fine.

What does "which gcc" return? If nothing, please post the output of

"echo $PATH"

and

"echo $WM_COMPILER_BIN"

craiger March 1, 2007 14:20

Hi Dragos, if I type "echo
 
Hi Dragos,

if I type "echo $HOME" it returns /home/craiger

you said I need to unpack the 3rd party packages into $HOME/OpenFOAM/linux. In my previous post I said I unpacked them into /home/craiger/OpenFOAM/linux/

So... have I made a mistake here?

Eugene,

"which gcc" returns nothing

"echo $PATH" returns
/home/craiger/OpenFOAM/OpenFOAM-1.3/src/lam-7.1.1/platforms/linuxGcc4DPOpt/bin:/ home/craiger/OpenFOAM/OpenFOAM-1.3/src/mico-2.3.11/platforms/linuxGcc4DPOpt/bin: /home/craiger/OpenFOAM/linux/j2sdk1.4.2_05/bin:/home/craiger/OpenFOAM/craiger-1. 3/applications/bin/linuxGcc4DPOpt:/home/craiger/OpenFOAM/OpenFOAM-1.3/applicatio ns/bin/linuxGcc4DPOpt:/home/craiger/OpenFOAM/OpenFOAM-1.3/wmake:/home/craiger/Op enFOAM/OpenFOAM-1.3/bin:/home/craiger/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin :/bin:/usr/games:/opt/gnome/bin:/opt/kde3/bin:/home/craiger/OpenFOAM/linux/parav iew-2.4.2/bin

"echo $WM_COMPILER_BIN" returns
/home/craiger/OpenFOAM/linux/gcc-4.1.0-64/bin:/home/craiger/OpenFOAM/linux/gcc-4 .1.0-64/../gdb-6.4/bin


Thanks guys

Craig

dmoroian March 2, 2007 04:17

Hi Craig, Yes, it was my mist
 
Hi Craig,
Yes, it was my mistake. Strange though that you don't have the path for gcc in your PATH variable. Try to add it by hand:
export PATH=$HOME/OpenFOAM/linux/gcc-4.1.0
and then run again the installation test.
Now I see that you have gcc-4.1.0-64 in your WM_COMPILER_BIN variable which I thing is wrong. Maybe you have enabled the WM_64 variable. You can check it be typing echo $WM_64. If you get a value, then you have to disable it from ~/OpenFOAM/OpenFOAM-1.3/.OpenFOAM-1.3/bashrc.

Dragos

eugene March 2, 2007 06:18

Ok, like Dragos said, the -64
 
Ok, like Dragos said, the -64 is the problem.
Basically, you are trying to run the 32bit exicutables on a 64bit machine (which should work fine) and the configuration scripts are pointing you too the wrong location for the gcc executable.

If you look at line 104 of the .OpenFOAM-1.3/bashrc file, you will find the line causing the issue.

I suggest you install the 64bit binaries and add "export WM_64=1" to line 87 of .OpenFOAM-1.3/bashrc. (only if you are using bash of course!)

Alternatively, you can try and soft link the directory gcc-4.1.0 to gcc-4.1.0-64 (ln -s gcc-4.1.0 gcc-4.1.0-64). 32bit binaries compiled on a 64bit machine should be identical to those compiled on a 32bit machine (if I recall correctly).


All times are GMT -4. The time now is 22:06.