CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   How to install binary pack in Debian 31 Linux (http://www.cfd-online.com/Forums/openfoam-installation/57577-how-install-binary-pack-debian-31-linux.html)

navaladi February 6, 2007 13:59

Hi All, I have download all
 
Hi All,

I have download all the files.
I want to use Binary Pack,It has following files.

navaladi@debian:~/OpenFOAM/binary/OpenFOAM-1.3$ ls -l
total 16
drwxr-xr-x 3 navaladi navaladi 4096 2007-02-04 12:30 applications
drwxr-xr-x 3 navaladi navaladi 4096 2007-02-04 12:30 lib
drwxr-xr-x 4 navaladi navaladi 4096 2007-02-04 12:30 src
drwxr-xr-x 3 navaladi navaladi 4096 2007-02-04 12:30 wmake
navaladi@debian:~/OpenFOAM/binary/OpenFOAM-1.3$

I have found no install/README file, and no install script.

Can anyone tell me how to install it.

hemph February 7, 2007 06:32

Hi Navaladi, You will need b
 
Hi Navaladi,
You will need both the binary pack *and* the source pack to install OpenFOAM. The installation README file comes in the source package I believe.
The preferred location of OpenFoam-1.3 is in the ~/OpenFOAM -directory (i.e. no 'binary' folder is needed). Take a look at http://www.opencfd.co.uk/openfoam/linux.html for further instrucions. Good luck!

//Rasmus

navaladi February 7, 2007 14:33

hi Rasmus, Thanks for reply.
 
hi Rasmus, Thanks for reply.

Then, should i have to compile it manually?What is the need for Binary Pack developed for Linux.I can build it without binary pack.

I searched entire forum, i didn't get any clue for that.I have found pre-compiled binaries under applications/ folder ( with FoamX).

Thanks

hemph February 8, 2007 06:01

Hi again, The binary pack con
 
Hi again,
The binary pack contains compiled libraries and executables for the linux or AMD-64 platform. They are not required for running OpenFOAM (you could compile everything yourself using the source package), but save time and effort for us linux-users on intel and AMD systems. If you are a new user on one of those systems, I recommend you use the binary pack.
The source pack contains essential applications and scripts as well as the complete source code and documentation. It must be installed in order to run OpenFOAM.

//Rasmus

navaladi February 8, 2007 09:18

Yeah Thanks Rasmus, I understa
 
Yeah Thanks Rasmus, I understand.I ll compile it myself.

Thanks


All times are GMT -4. The time now is 23:54.