CFD Online Logo CFD Online URL
www.cfd-online.com
[Sponsors]
Home > Forums > OpenFOAM Installation

Network_problem

Register Blogs Members List Search Today's Posts Mark Forums Read

Reply
 
LinkBack Thread Tools Display Modes
Old   January 10, 2005, 11:02
Default Hello everybody, I have a
  #1
Djeghri Noureddine (Noureddine)
Guest
 
Posts: n/a
Hello everybody,

I have a problem with installation of openFOAM, when i check my system by executing the script foamSystemcheck, I have an error message:

cheking Networking:
---------------------------------------
ping_localhost: Successuful
ping_localhost: Successuful
Test_rsh: Unsuccessuful, Connection refused*
Test_ssh: Unsuccessuful, Connection refused*

FATALERROR: No remote Shell available
foam 2.3 environment requires
passwordless ' ssh' and/or ' rsh' to
current host
Contact your system adminstrator

I would to precise that i have only one pc, i'm not connected to a network and i have only 'ssh ' command

help me, please

Thanks in advance

Noureddine
  Reply With Quote

Old   January 10, 2005, 12:14
Default As far as I can remember the
  #2
Mattijs Janssens (Mattijs)
Guest
 
Posts: n/a
As far as I can remember the 'passwordless' ssh/rsh is only required if you are want to run parallel or FoamX remotely.

Does your installation work?

Mattijs
  Reply With Quote

Old   January 10, 2005, 12:28
Default I had a similar problem - see
  #3
Andrew Heather (Heather)
Guest
 
Posts: n/a
I had a similar problem - seemed that i needed to add the machine to the 'etc/hosts' file (SUSE v9.2). I.e. underneath where localhost is defined, i added the machine IP address and machine name.
  Reply With Quote

Old   January 13, 2005, 10:54
Default Hello missinjs I installe
  #4
Djeghri Noureddine (Noureddine)
Guest
 
Posts: n/a
Hello missinjs

I installed foam but by checking the installation, I have this message:

[root@localhost bin] #./foamInstallationTest
Executing ./foamInstallationTest.

Cheking basic setup…
Shell : bash
Host : localhost
OS : linux version 2.6.3-4mdk
User : nour
User_Config : /root/.bashrc
Foam_Config : /root/.OpenFOAM-1.0/bashrc sourced correctly


Cheking main FOAM environment variables…
Environment_variable Set_to_file_or_directory Valid Crit
$WM_PROJECT_INST_DIR /root/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /root/OpenFOAM/nour-1.0 yes no
$FOAM_JOB_DIR root/OpenFOAM/JobControl no yes


Cheking the FOAM environment variables set on the PATH…
Environment_variable Set_to_file_or_directory Valid Path Crit
$WM_PROJECT_DIR /root/OpenFOAM-1.0 yes yes yes

$FOAM_USER_APPBIN …M/nour-1.0/applications/bin/linuxOpt no no
$FOAM _APPBIN ...enFOAM-1.0/applications/bin/linuxOpt yes yes yes
$WM_DIR /root/OpenFOAM/OpenFOAM-1.0/wmake yes yes yes
$FOAM_PATH ...actions/utilites/pre Processing/FoamX yes yes yes
$DXROOT /root/OpenFOAM/linux/dx-4.3.2/dx no no
$CEI_HOME /usr/local/ensight/CEI no no

$JAVA_PATH /root/OpenFOAM/linux/j2dsk1.4.2-05 yes yes no
$MICRO_ARCH_PATH …o/src/micro-2.3.11/platforms/linuxOpt no yes
$LAM_ARCH_PATH …1.0/src/lam-7.1.1/platforms/linuxOpt no yes
$MPICH_ARCH_PATH --------- env variable not set--------------- no


Cheking the FOAM environment variables set on the LD_LIBRARY_PATH…
Environment_variable Set_to_file_or_directory Valid Path Crit
$FOAM_LIBBIN /root/OpenFOAM/OpenFOAM-1.0/lib/linuxOpt yes yes yes
$FOAM_USER_LIBBIN /root/OpenFOAM/nour-1.0/lib/linuxOpt no no
$LAM_ARCH_PATH …1.0/src/lam-7.1.1/platforms/linuxOpt no yes


Software versions
Software Version location
gcc 3.4.3 /root/OpenFOAM/linux/gcc-3.4.3/bin/gcc
java 1.4.2-05 /root/OpenFOAM/linux/j2sdk1.4.2-05/bin/java
dx *** not installed ***

gzip 1.2.4 (18 Aug 93)
compilation options
DIRENT UTIME STDC_HEADERS HAVE_UNISTD_H
gzip /bin/gzip
tar /bin/tar
icoFoam *** not installed ***
CRITICAL ERROR


Cheking file/directory permissions...
Files/directory Set Reqd Crit


Cheking networking…
Action Result Crit
Pinging_localhost Successful yes
Pinging_localhost Successful yes
Test_rsh Unsuccessful “ connection refused*” yes
Test_ssh Unsuccessful “ connection refused*” yes

FATAL ERROR : No remote shell available
Foam -1.0 environment requires either ssh and/or rsh
Contact your System administration


The System test has evoke 1 fatal error(s)

The foam installation contains 1 critical error(s)

Review the output for warnings messages and consult
the installation guide for trouble shooting.


it seems that the dx is not installed, and the ssh always persists
what is this dx?

please help me

thank you in advence

Djeghri
  Reply With Quote

Old   January 13, 2005, 11:14
Default Hello mattijs sorry Dje
  #5
Djeghri Noureddine (Noureddine)
Guest
 
Posts: n/a
Hello mattijs

sorry

Djeghri Noureddine
  Reply With Quote

Old   January 17, 2007, 19:44
Default Hi, I have a message very s
  #6
New Member
 
Richard Jones
Join Date: Mar 2009
Location: Adelaide, South Australia, Australia
Posts: 22
Rep Power: 8
richard is on a distinguished road
Hi,

I have a message very similar to the first post..
I am running Ubuntu 6.10, and trying to get OpenFoam 1.3 to be friendly

here is the message i recieved after trying to execute foamInstallationTest..

Checking basic setup...
-------------------------------------------------------------------------------
Shell: bash
Host: Richard
OS: Linux version 2.6.17-10-generic
User: richard
User_config: /home/richard/.bashrc
Foam_config: /home/richard/.OpenFOAM-1.3/bashrc sourced correctly.
-------------------------------------------------------------------------------


Checking main FOAM env variables...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Crit
-------------------------------------------------------------------------------
$WM_PROJECT_INST_DIR /home/richard/OpenFOAM yes yes
$WM_PROJECT_USER_DIR /home/richard/OpenFOAM/richard-1.3 yes no
$FOAM_JOB_DIR /home/richard/OpenFOAM/jobControl no yes
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$WM_PROJECT_DIR /home/richard/OpenFOAM/OpenFOAM-1.3 yes yes yes

$FOAM_USER_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes no
$FOAM_APPBIN ...-1.3/applications/bin/linuxGcc4DPOpt yes yes yes
$WM_DIR .../richard/OpenFOAM/OpenFOAM-1.3/wmake yes yes yes
$FOAMX_PATH ...ations/utilities/preProcessing/FoamX yes no yes
$CEI_HOME /usr/local/ensight/CEI no no

$JAVA_PATH ...richard/OpenFOAM/linux/j2sdk1.4.2_05 no no
$MICO_ARCH_PATH ...mico-2.3.11/platforms/linuxGcc4DPOpt yes yes yes
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes
$MPICH_ARCH_PATH --------- env variable not set --------- no
-------------------------------------------------------------------------------


Checking the FOAM env variables set on the LD_LIBRARY_PATH...
-------------------------------------------------------------------------------
Environment_variable Set_to_file_or_directory Valid Path Crit
-------------------------------------------------------------------------------
$FOAM_LIBBIN ...FOAM/OpenFOAM-1.3/lib/linuxGcc4DPOpt yes yes yes
$FOAM_USER_LIBBIN ...nFOAM/richard-1.3/lib/linuxGcc4DPOpt yes yes no
$LAM_ARCH_PATH ...c/lam-7.1.1/platforms/linuxGcc4DPOpt yes yes yes
-------------------------------------------------------------------------------


Software versions
-------------------------------------------------------------------------------
Software Version Location
-------------------------------------------------------------------------------
gcc 4.1.2
WARNING: Conflicting installations:
foam settings: /home/richard/OpenFOAM/linux/gcc-4.1.0/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

java 1.4.2
libgcj)
WARNING: Conflicting installations:
foam settings: /home/richard/OpenFOAM/linux/j2sdk1.4.2_05/bin/java
current path : /usr/bin/java

gzip 1.3.5 /bin/gzip
tar 1.3.5 /bin/tar
icoFoam ...M/OpenFOAM-1.3/applications/bin/linuxGcc4DPOpt/icoFoam
-------------------------------------------------------------------------------


Checking file/directory permissions...
-------------------------------------------------------------------------------
File/directory Set Reqd Crit
-------------------------------------------------------------------------------


Checking networking...
-------------------------------------------------------------------------------
Action Result Crit
-------------------------------------------------------------------------------
Pinging_Richard Successful yes
Pinging_localHost Successful yes
Test_rsh: Unsuccessful_connection_refused* yes
Test_ssh: Unsuccessful_connection_refused* yes
FATAL ERROR: No remote shell available.
Foam1.3 enviroment requires either ssh and/or rsh.
Contact your system administrator.


-------------------------------------------------------------------------------

The system test has evoked 1 fatal error(s).

The foam installation contains 1 critical error(s).


Thanks in advance for your help!
richard is offline   Reply With Quote

Old   January 18, 2007, 04:08
Default Hi Richard, just install ss
  #7
Senior Member
 
Jens Klostermann
Join Date: Mar 2009
Posts: 117
Rep Power: 8
jens_klostermann is on a distinguished road
Hi Richard,

just install ssh or rsh client+server, e.g. openssh.

Regards Jens
jens_klostermann is offline   Reply With Quote

Old   January 18, 2007, 12:18
Default Also, (your main problem) it l
  #8
Senior Member
 
Eugene de Villiers
Join Date: Mar 2009
Posts: 725
Rep Power: 12
eugene is on a distinguished road
Also, (your main problem) it looks like you did not install the linux components that are distributed with foam.

gcc 4.1.2
WARNING: Conflicting installations:
foam settings: /home/richard/OpenFOAM/linux/gcc-4.1.0/bin/gcc
current path : /usr/bin/gcc
CRITICAL ERROR

Check the Foam installation instructions again. You need to download and install the linux/linuxAMD64 - subdirectory of third-party binary packs.
eugene is offline   Reply With Quote

Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -4. The time now is 20:40.