CFD Online Discussion Forums

CFD Online Discussion Forums (http://www.cfd-online.com/Forums/)
-   OpenFOAM Installation (http://www.cfd-online.com/Forums/openfoam-installation/)
-   -   Number 05 not of correct type (http://www.cfd-online.com/Forums/openfoam-installation/57603-number-05-not-correct-type.html)

Michael Wessels (Wessels) December 22, 2004 04:12

I am tyring to change the end
 
I am tyring to change the endTime in controlDict of the tutorial 'cavity'. I got this message
'Number 0,5 not of correct type'

I am able to change parameters with an integral value.

What is the solultion of this probelm ?

I am running OpenFOAM on a Pentium4-Linux-PC.

Best regards

Michael

Hrvoje Jasak (Hjasak) December 22, 2004 04:33

Try writing 0.5 with a dot in
 
Try writing 0.5 with a dot instead of comma

Michael Wessels (Wessels) December 22, 2004 04:40

I have tried it. But it doesn
 
I have tried it. But it doesn't work.

Michael

Michael Wessels (Wessels) December 22, 2004 04:47

I have tried it. But it doesn
 
I have tried it. But it doesn't work.

Michael

Joern Beilke (Beilke) December 22, 2004 05:34

I happens because you have a
 
I happens because you have a german installation and java thinks, that the germans always use the "," instead of the "."

Just put the line

export LANG=en_EN

at the beginning of the

~/OpenFOAM/OpenFOAM-1.0/.OpenFOAM-1.0/bashrc

Duderino (Duderino) January 12, 2005 14:22

Thank you for making FOAM ope
 
Thank you for making FOAM open source.

I've got the same problem as Michael.
I am using OpenFOAM-1.0.2 on Linux (Mandrake 10)

The hint of Joern:
#Just put the line
#export LANG=en_EN
#at the beginning of the
#~/OpenFOAM/OpenFOAM-1.0.2/.OpenFOAM-1.0.2/bashrc
didn't solve the problem so far.

Thank you

duderino

hoerl October 30, 2006 04:14

Same Problem here. Using Ub
 
Same Problem here.

Using Ubuntu 6.10 and OpenFOAM 1.3 it shows me the exception "Number 0,5 not of correct type" this message also appears if i type "0.5"

yes the ubuntu install was made in german.

is there an fix for this ?!

mfg matthias

dmoroian October 30, 2006 04:24

Didn't it work with the soluti
 
Didn't it work with the solution provided by Joern Beilke few posts above?
If it doesn't, then I suggest to skip FoamX and edit directly your controlDict file.

Dragos

hoerl October 30, 2006 04:47

skipping FoamX would be the on
 
skipping FoamX would be the only way - thx for answering so fast ...

gschaider October 30, 2006 05:22

Matthias: The answer to you
 
Matthias:

The answer to your question might be this:
http://openfoamwiki.net/index.php/Main_FAQ#Why_doesn.27t_FoamX_allow_me_to_enter _numbers.3F

philippose October 30, 2006 14:10

Hi, I happened to come acro
 
Hi,
I happened to come across this discussion, and maybe I can be of a little help here....:-)

I installed OpenFOAM 1.3 on Fedora Core 6 yesterday for a friend who uses a German interface. As noted by you all, when you run FoamX, Java adopts the regional setting from the Operating system to display the numbers, and you end up with...0,5 instead of 0.5.

This is what I did, and it works like a charm...

I opened the FoamX bash script:

cd $WM_PROJECT_DIR/bin/
<editor> FoamX

Once the file opens, after the comments, just before the lines:

# Set default JDK path.
jdkhome="/usr/java/jdk1.4"

I added the following:

# Set Language to English
oldLang=`echo $LANG`
export LANG=en_EN

And, at the end of the script file, right at the bottom, I added:

# Reset Language to original
export LANG=$oldLang

This is basically what the link which Bernhard Gschaider provided suggests too.

Have a nice day!

Philippose

hoerl October 30, 2006 15:42

ok thanx to both of you ..
 
ok thanx to both of you ..

as you said philippose - this works like a charm
thanks for sharing


All times are GMT -4. The time now is 18:36.